Bug 120228 - cant change the filename when using kget from konquerors "save as" dialog
Summary: cant change the filename when using kget from konquerors "save as" dialog
Alias: None
Product: kget
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Rainer Wirtz
Depends on:
Reported: 2006-01-16 08:16 UTC by Mathias Homann
Modified: 2008-03-09 19:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description Mathias Homann 2006-01-16 08:16:07 UTC
Version:           v0.8.5 (using KDE 3.5.0 Level "a" , SUSE 9.2 UNSUPPORTED)
Compiler:          gcc version 3.3.4 (pre 3.3.5 20040809)
OS:                Linux (i686) release 2.6.8-24.19-default

when konqueror asks me what to do with a file i'm downloading, and i hit "save as", kget used to show me a kfileselection dialog (or whatever its called), where i could select the target directory, and change the target filename.

now (since kde 3.5), it shows me a directory selection dialog, and I can't change the file name.

With some misconfigured webservers that send filenames like "index.php?fileid=qw786342ir4hz23876e7kjdfh8723z4r", this is not funny.
Comment 1 Rainer Wirtz 2006-01-16 19:20:59 UTC
Works as expected with SVN (branch 3.5, R-497051). Looks like it's been fixed before it was reported. 
Comment 2 Mathias Homann 2006-01-17 07:58:30 UTC
seems that this was some weird unconfigurable configuration setting (i.e. something with no frontend anywhere in the configuration dialogues), since killing kget, deleting its rc file, then starting kget fixed it for me...
Comment 3 Mathias Homann 2006-01-19 08:44:49 UTC
it is back...

and this time, killing kget and deleting kgets rc file didnt help at all.

it seems to be related to the mime type of the downloaded file, for some mimetypes the directory selection dialog appears, for others the proper file name dialog appears.

test cases:

download anything from source forge, works.
download anything that gets announced as application/octet-stream, doesnt work.
Comment 4 Rainer Wirtz 2006-01-20 01:32:50 UTC
Can you give an URL where this happens please. Looks like I can't find one.
Comment 5 Mathias Homann 2006-01-20 12:54:18 UTC

oh btw that exact url ends in an "illegal address" for me when i 
select a directory, following by an "download complete" together with 
the file having been downloaded to the exact directory i chose.
Comment 6 Rainer Wirtz 2006-01-20 17:39:21 UTC
Not a very good test case. The server seems to have problems, I can't even ping it. In both konqueror and kget, I get "Could not connect to host mine.myphotos.cc (port 6966)" errors. When I retry often enough it works sometimes, but konqueror is not calling kget at all( which may be considered a bug in konqueror). When I do "file->paste" in kget (and the server can be reached) then I get the normal file-dialog and everything works as expected.

Give me a better test case or I'll close as "works for me".
Comment 8 Rainer Wirtz 2006-01-22 01:36:32 UTC
The first server gives me a timeout. On the second, using the links on http://www.point-blank.cc:7001/ I can do a "RMB->download with kget" and the normal file-dialog opens. I can spot no problem here, except maybe that "LMB->Save as.." is not calling kget, but konqueror is doing the job itself, again with a normal file-dialog.
I have to assume that whatever problem you have here, it's fixed by now (I'm using kdelibs and kget from SVN).
Comment 9 Mathias Homann 2006-01-22 11:19:36 UTC
both links work for me.
in both cases, kget comes up with a "choose directory" box.
and with the links on the tracker page, with LMB->save as, it's "choose directoy" boxes again, in each case.

and what you say is basically "i can't reproduce your problem with a totally different software version when doing something different from what you do when the bug hits you, so it must be fixed by now."
Comment 10 Mathias Homann 2006-01-22 13:26:08 UTC
just for the record, i can easily reproduce this bug on three different systems:

1. a machine running suse 9.2 with kde 3.5 from suse supplementary
2. a second machine like the one above, using a different user account
3. a third machine running suse 10.0 with kde 3.5 from suse supplementary
Comment 11 Mathias Homann 2006-01-22 15:02:24 UTC
oh and before you say it...

the suse package maintainer explicitely told me to file that bug here, he said they did not run any parches against kde 3.5 which would possibly warrant such behaviour...
Comment 12 Mathias Homann 2006-01-22 17:08:06 UTC
ok, you might be right there...

so far, i tried to reproduce this behaviour in kubuntu 5.10 running in a vmware, with kde 3.5.0 packages from the apt repository mentioned in http://kubuntu.org/announcements/kde-35.php, and while on "suse kde" i get the "choose directory" dialog, which (according to its title) is from kget, when i download those torrent files in kubuntu kde (at the very same moment, on the very same internet connection), i get the proper "save as" dialog...

Next try shall be pcbsd 1.0 which comes with kde 3.5 as well. I'll post updates here, and if the results are the same as in kubuntu, I'll hit adrian over the head with them until he tells me what they broke with kget.
Comment 13 Mathias Homann 2006-01-22 18:16:27 UTC
ok, its also not reproduceable on pcbsd 1.0.

Guess I'll shove it back in the face of the kde people at suse.

but lets keep it open until they solve it.
Comment 14 Stephan Binner 2006-01-23 11:24:25 UTC
I tracked it down to this commit breaking it: http://websvn.kde.org/branches/KDE/3.5/kdenetwork/kget/main.cpp?rev=490685&view=rev

And you can only reproduce it with the SUSE KDE "3.5" supplementary rpms because they actually contain a recent snapshot of the KDE 3.5 branch much newer than 3.5.0.
Comment 15 Mathias Homann 2006-01-23 13:24:39 UTC
then why couldn't rainer reproduce it with kdelibs and kget from svn?
ah well, as long as its been confirmed and going to be fixed now...
Comment 16 Rainer Wirtz 2006-01-23 23:39:28 UTC
Sorry, my fault, I can reproduce it now.
Comment 17 Rainer Wirtz 2006-01-24 02:05:05 UTC
*** Bug has been marked as fixed ***.
Comment 18 Mathias Homann 2006-01-24 07:26:57 UTC
good. but will the fix make it into 3.5.1?
after all, the release schedule said 3.5.1 would be tagged on jan 20th...
Comment 19 Stephan Binner 2006-01-24 11:35:36 UTC
> but will the fix make it into 3.5.1?

No. SUSE will pick up the bugfix for Beta 3.
Comment 20 Mathias Homann 2006-01-24 13:10:47 UTC
beta 3 of what?

suse 10.1? that would be... bad... because i'm going to stick with 9.2 for a while...
Comment 21 Mathias Homann 2006-02-03 07:59:11 UTC
did this fix make it into kde 3.5.1? its not listed in the changelog...
Comment 22 Stephan Binner 2006-02-03 14:09:12 UTC
This didn't make it into KDE 3.5.1. And I meant SUSE 10.1 Beta 3 in #19.
Comment 23 Mathias Homann 2006-02-26 11:33:00 UTC
this also did not make it into kde 3.5.1 in "supplementary" from suse :(

So, which "official" kde release will this fix be in? 4.1.x?
Comment 24 Adrian Dziubek 2006-05-17 00:49:25 UTC
I get the problem too. There is some unintuitive work around:

In the "directories" tab, you add an empty (no folder specified) entry for all files (that is *). I hope this is not the case in 3.5.1 ;)
Comment 25 Lukas Appelhans 2008-03-09 19:15:50 UTC
This bug is fixed in KDE 4.1 trunk...