Bug 120040 - konsole misses dcop/dbus call to set the number of lines in history
Summary: konsole misses dcop/dbus call to set the number of lines in history
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-13 14:57 UTC by Richard Bos
Modified: 2012-04-20 05:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.9.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Bos 2006-01-13 14:57:00 UTC
Version:            (using KDE KDE 3.5.0)
OS:                Linux

konsole misses dcop call to set the number of lines to be
kept in the history buffer.

The only call found related to history is:
> dcop konsole-11421 session-1 | grep -i Hi
void clearHistory()

Checked the dcop targets as well, as well as other strings
like lines and such.  It would be handy if the history
buffer size could be changed by dcop.
Comment 1 Richard Bos 2006-01-13 15:02:03 UTC
Hmm, related to this; are dcop commands to read out the number of
lines in the buffer and the possibility to save the contents of buffer.
Comment 2 Matthias Schniedermeyer 2007-02-10 13:05:25 UTC
I can confirm that.
I'm also missing these dcop-calls
Comment 3 Robert Knight 2008-01-03 20:30:44 UTC
This feature is not implemented exactly in KDE 4.0, since there was a transition from D-Cop to D-Bus and the DBus interfaces have not been implemented.

However, what I presume is one of the use cases of this, changing the number of lines of history through a command-line script can be done using the konsoleprofile tool which emits a special escape sequence that konsole recognises.

konsoleprofile historysize=<lines>

Inside a Konsole tab will change the maximum lines of output recorded to <lines> in that tab.
Comment 4 Richard Bos 2008-01-03 20:52:33 UTC
Sounds good, but... how would the innocent konsole user know about
what konsoleprofile can change? konsoleprofile itself does not reveal
too much of the secrets either ;) :

> cat /usr/bin/konsoleprofile
#!/bin/sh

/bin/echo -e "\033]50;$1\a"
Comment 5 Robert Knight 2008-01-03 21:49:32 UTC
> how would the innocent konsole user know about
> what konsoleprofile can change?

They wouldn't, until the documentation for Konsole/KDE 4 is written.  At the moment the handbook is completely out of date.
Comment 6 Jekyll Wu 2012-01-26 13:22:48 UTC
Git commit 95b8d5551e9cf7dae76854b9f31d1374c5e3aee5 by Jekyll Wu.
Committed on 26/01/2012 at 12:04.
Pushed by jekyllwu into branch 'master'.

Add dbus method for setting and querying history size per session
FIXED-IN: 4.9

M  +28   -0    src/Session.cpp
M  +17   -0    src/Session.h

http://commits.kde.org/konsole/95b8d5551e9cf7dae76854b9f31d1374c5e3aee5