Bug 119632 - kontact hangs/crashes when composing new email
Summary: kontact hangs/crashes when composing new email
Status: RESOLVED DUPLICATE of bug 108312
Alias: None
Product: kontact
Classification: Applications
Component: mail (show other bugs)
Version: 1.1.2
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-06 15:15 UTC by lee hartley
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lee hartley 2006-01-06 15:15:35 UTC
Version:           1.1.2 (using KDE KDE 3.5.0)
Installed from:    SuSE RPMs
OS:                Linux

background: suse 9.2 fresh install...updated to kde 3.4 from suse supplementray yast repo. -> again for 3.5

reproduce: open kontact, click the new mail icon, start composing mail...things seem fine at first...then seems to slow down...then gets REALLY slow (all of X not just kontact)...then after ~5-10 mins the crash handler pops up...

backtrace: 
Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 1105793152 (LWP 1097)]
[KCrash handler]
#7  0x426be5ca in KMMessage::asDwString ()
   from /opt/kde3/lib/libkmailprivate.so
#8  0x426be8e8 in KMMessage::asString () from /opt/kde3/lib/libkmailprivate.so
#9  0x42889337 in KMComposeWin::autoSaveMessage ()
   from /opt/kde3/lib/libkmailprivate.so
#10 0x428ba610 in KMComposeWin::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#11 0x4110fcfe in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#12 0x411104a6 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#13 0x4145a559 in QTimer::timeout () from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0x4113490f in QTimer::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0x410adb9f in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0x410af749 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0x40dbf911 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#18 0x410a248c in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0x4105c143 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0x410c5841 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0x410c5686 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0x410af61f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0x080635c5 in main ()

last part of strace: 
access("/home/lhartley/.ICEauthority", R_OK) = 0
open("/home/xxx/.ICEauthority", O_RDONLY) = 4
fstat64(4, {st_mode=S_IFREG|0600, st_size=400, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40018000
read(4, "\0\3ICE\0\0\0004local/lhartley-d2:/tmp/"..., 4096) = 400
close(4)                                = 0
munmap(0x40018000, 4096)                = 0
write(3, "\0\4\1\0\3\0\0\0\20\0\0\0\0\0\0\0\342\230\223(\346\3Z\263"..., 32) = 32
read(3, "\0\10\0\2\2\0\0\0", 8)         = 8
read(3, "\3\0KDE\0\0\0\3\0002.0\0\0\0", 16) = 16
getsockopt(3, SOL_SOCKET, SO_PEERCRED, "Ea\0\0\350\3\0\0d\0\0\0", [12]) = 0
getuid32()                              = 1000
write(3, "\1\2\1\0H\0\0\0\0\0\0\0", 12) = 12
write(3, "\0\0\0\0\0\0\0\vDCOPServer\0\0\0\0\1\0\0\0\0\25regi"..., 53) = 53
write(3, "\0\0\0\17anonymous-1096\0", 19) = 19
read(3, "\2\3\0\0027\0\0\0", 8)         = 8
read(3, "\271\1\0\0", 4)                = 4
read(3, "\0\0\0\vDCOPServer\0\0\0\0\0\0\0\0\tQCString\0"..., 55) = 55
write(3, "\1\2\1\0]\0\0\0\271\1\0\0", 12) = 12
write(3, "\0\0\0\17anonymous-1096\0\0\0\0\vDCOPServe"..., 81) = 81
write(3, "\0\0\0\10kontact\0", 12)      = 12
read(3, "\2\3\0\0023\0\0\0", 8)         = 8
read(3, "\271\1\0\0", 4)                = 4
read(3, "\0\0\0\vDCOPServer\0\0\0\0\17anonymous-109"..., 51) = 47
read(3, "\0\0\0\1", 4)                  = 4
write(3, "\1\2\1\0h\0\0\0\2\0\0\0", 12) = 12
write(3, "\0\0\0\17anonymous-1096\0\0\0\0\10kontact\0\0"..., 65) = 65
write(3, "\0\0\0\17/home/lhartley\0\0\0\0\1\0\0\0\0\0\0\0\0\0"..., 39) = 39
read(3, "\2\5\0\2#\0\0\0", 8)           = 8
read(3, "\2\0\0\0", 4)                  = 4
read(3, "\0\0\0\10kontact\0\0\0\0\17anonymous-1096\0\0"..., 35) = 35
read(3, "\2\6\0\0023\0\0\0", 8)         = 8
read(3, "\2\0\0\0", 4)                  = 4
read(3, "\0\0\0\10kontact\0\0\0\0\17anonymous-1096\0\0"..., 51) = 51
close(3)                                = 0
exit_group(0)                           = ?
xxx@xxx:~> QTime::setHMS Invalid time 25:00:00.000
QWidget::setMaximumSize: (unnamed/RecipientComboBox) The largest allowed size is (32767,32767)

xxx@xxx:~> *** KMail got signal 11 (Crashing)
KCrash: Application 'kontact' crashing...
Comment 1 lee hartley 2006-01-06 15:18:42 UTC
kmail version = 1.8.2
Comment 2 Unknown 2006-05-11 16:45:27 UTC
I observed the same behaviour in kontact 1.2 / kmail 1.9.1 from Debian/SID here on Kanotix. Though I didn't get the crash popup - maybe I didn't wait long enough as I was sick of the huge typing delays. I only noticed it twice so far - maybe because I rarely write longer emails. How comes nobody else commented to this bug since january? 
It doesn't seem to depend on the time you need to type. I copied all the text I wrote, restarted kmail and pasted it in again - and the slowness was there again. I retried it pasting less text and it didn't slow down until I added some more words...
Comment 3 Unknown 2006-05-11 17:01:55 UTC
just found Bug 119281 "kmail composer suddenly becomes very slow"... have a look at it
Comment 4 Andreas Kling 2006-07-31 14:28:41 UTC

*** This bug has been marked as a duplicate of 108312 ***