Bug 119435 - kate crash when a file is saved
Summary: kate crash when a file is saved
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dirk Mueller
URL:
Keywords:
: 128246 141567 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-01-03 05:11 UTC by Marc Collin
Modified: 2008-02-09 05:37 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Backtrace of a crash (1.18 KB, text/plain)
2006-03-18 10:43 UTC, Maxilys
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Collin 2006-01-03 05:11:09 UTC
Version:           2.5.0 (using KDE 3.5.0 Level "a" , SUSE 10.0 UNSUPPORTED)
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.13-15.7-default

often when i open some java file, change it... and save it... kate crash

in konsole mode the message is: 

QColor::setRgb: RGB parameter(s) out of range
KCrash: Application 'kate' crashing...
Comment 1 Anders Lund 2006-01-03 13:03:29 UTC
On Tuesday 03 January 2006 05:11, Marc Collin wrote:
> often when i open some java file, change it... and save it... kate crash
>
> in konsole mode the message is:
>
> QColor::setRgb: RGB parameter(s) out of range
> KCrash: Application 'kate' crashing...


Please fill in the information fields of the bug report, like OS, installation 
method etc, and we also need a backtrace if you expect us to be able to track 
down the reason.

However, given we havent heard this before, it will probably still be hard to 
reproduce, so the more information the better. I can say that i have opened, 
changed and saved 1000s of files using kate 2.5 with kernels 2.6.11 and 
2.6.14 without a single crash.

-anders
Comment 2 Marc Collin 2006-01-03 19:17:33 UTC
you suppose to have all this information... i used the form wizard in the help dialog box of kate...

os: suse 10, rpm, kde 3.5
how to have the backtrace
Comment 3 Anders Lund 2006-01-03 22:47:36 UTC
On Tuesday 03 January 2006 19:17, Marc Collin wrote:
> you suppose to have all this information... i used the form wizard in the
> help dialog box of kate...


I don't know what suse does to their packages. The version and platform fields 
are unspecified.

> os: suse 10, rpm, kde 3.5
> how to have the backtrace


If you get a kcrash dialog, press the button, and copy it to the information 
for the bug report. If there is no kcrash dialog, suse probably disabled 
debugging information anyway (likely they did). In that case we can't really 
do anything to investigate apart from hoping someone with a working debug 
build experiences the same problem.
Comment 4 Anders Lund 2006-01-08 11:37:39 UTC
Considering the amount of problem the kernels in SuSE 10 causes, updating your 
kernel could help.

-anders
Comment 5 Stephan Binner 2006-01-08 11:55:19 UTC
What knowledge do you have that the inotify bug is specific to kernels of SUSE?

And there are two distinct problems user experience with Kate: one with the random changed file notification and the one crashing within kdirwatcher when saving with backupfiles turned on.
Comment 6 Anders Lund 2006-01-08 12:05:17 UTC
On Sunday 08 January 2006 11:55, Stephan Binner wrote:
> What knowledge do you have that the inotify bug is specific to kernels of
> SUSE?


None, apart form the fact that the reports seems to come from suse users.

> And there are two distinct problems user experience with Kate: one with the
> random changed file notification and the one crashing within kdirwatcher
> when saving with backupfiles turned on.


This report have only little indications of what happens. Why do you associate 
it with kdirwatcher?
Comment 7 Stefan Nikolaus 2006-02-18 17:45:09 UTC
confirmed
KDE build from sources (SVN 507025)
Qt 3.3.5 (qt-copy w/ applied patches)
SuSE Linux 10.0 OSS
kernel 2.6.15.1 (build from sources)
gcc (GCC) 4.0.2 20050901 (prerelease) (SUSE Linux)


Using host libthread_db library "/lib/tls/libthread_db.so.1".
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread 1098218272 (LWP 23456)]
[KCrash handler]
#6  0x40045206 in QString::unicode (this=0x8e0a8ac) at qstring.h:653
#7  0x410dfede in operator== (s1=@0x8e0a8ac, s2=@0xbfb9e4b4)
    at qstring.cpp:6412
#8  0x40245878 in KDirWatchPrivate::slotActivated (this=0x81ace70)
    at /usr/local/src/kde/3.5/kdelibs/kio/kio/kdirwatch.cpp:438
#9  0x40245a6e in KDirWatchPrivate::qt_invoke (this=0x81ace70, _id=4, 
    _o=0xbfb9e5a8) at kdirwatch_p.moc:90
#10 0x40db64e3 in QObject::activate_signal (this=0x81ac6d8, clist=0x819c1e0, 
    o=0xbfb9e5a8) at qobject.cpp:2356
#11 0x40db6e31 in QObject::activate_signal (this=0x81ac6d8, signal=2, 
    param=11) at qobject.cpp:2449
#12 0x4114e648 in QSocketNotifier::activated (this=0x81ac6d8, t0=11)
    at moc_qsocketnotifier.cpp:85
#13 0x40dd74df in QSocketNotifier::event (this=0x81ac6d8, e=0xbfb9e890)
    at qsocketnotifier.cpp:258
#14 0x40d4bb10 in QApplication::internalNotify (this=0xbfb9fc24, 
    receiver=0x81ac6d8, e=0xbfb9e890) at qapplication.cpp:2635
#15 0x40d4bd28 in QApplication::notify (this=0xbfb9fc24, receiver=0x81ac6d8, 
    e=0xbfb9e890) at qapplication.cpp:2358
#16 0x40828887 in KApplication::notify (this=0xbfb9fc24, receiver=0x81ac6d8, 
    event=0xbfb9e890)
    at /usr/local/src/kde/3.5/kdelibs/kdecore/kapplication.cpp:550
#17 0x4004d29f in QApplication::sendEvent (receiver=0x81ac6d8, 
    event=0xbfb9e890) at qapplication.h:496
#18 0x40d3cda9 in QEventLoop::activateSocketNotifiers (this=0x80d7bf8)
    at qeventloop_unix.cpp:578
#19 0x40cf02d8 in QEventLoop::processEvents (this=0x80d7bf8, flags=4)
    at qeventloop_x11.cpp:383
#20 0x40d642b2 in QEventLoop::enterLoop (this=0x80d7bf8) at qeventloop.cpp:198
#21 0x40d4a6c9 in QApplication::enter_loop (this=0xbfb9fc24)
    at qapplication.cpp:2793
#22 0x4020795c in KIO::NetAccess::enter_loop (this=0xbfb9ec04)
    at /usr/local/src/kde/3.5/kdelibs/kio/kio/netaccess.cpp:498
#23 0x40207dea in KIO::NetAccess::filecopyInternal (this=0xbfb9ec04, 
    src=@0xbfb9ee84, target=@0xbfb9ed20, permissions=420, overwrite=true, 
    resume=false, window=0x0, move=false)
    at /usr/local/src/kde/3.5/kdelibs/kio/kio/netaccess.cpp:316
#24 0x40208546 in KIO::NetAccess::file_copy (src=@0xbfb9ee84, 
    target=@0xbfb9ed20, permissions=420, overwrite=true, resume=false, 
    window=0x0) at /usr/local/src/kde/3.5/kdelibs/kio/kio/netaccess.cpp:127
#25 0x41c8c2fe in KateDocument::save (this=0x9575688)
    at /usr/local/src/kde/3.5/kdelibs/kate/part/katedocument.cpp:2461
#26 0x41cca8d0 in KateView::save (this=0x9fdcf38)
    at /usr/local/src/kde/3.5/kdelibs/kate/part/kateview.cpp:850
#27 0x41cd4e20 in KateView::qt_invoke (this=0x9fdcf38, _id=138, _o=0xbfb9f0ac)
    at kateview.moc:741
#28 0x40db64e3 in QObject::activate_signal (this=0xa03f1a8, clist=0xa03f3a0, 
    o=0xbfb9f0ac) at qobject.cpp:2356
#29 0x40db6fc7 in QObject::activate_signal (this=0xa03f1a8, signal=2)
    at qobject.cpp:2325
#30 0x4053f7ac in KAction::activated (this=0xa03f1a8) at kaction.moc:176
#31 0x40540546 in KAction::slotActivated (this=0xa03f1a8)
    at /usr/local/src/kde/3.5/kdelibs/kdeui/kaction.cpp:1102
#32 0x4053f959 in KAction::slotButtonClicked (this=0xa03f1a8, 
    state=LeftButton) at /usr/local/src/kde/3.5/kdelibs/kdeui/kaction.cpp:1147
#33 0x40543b8d in KAction::qt_invoke (this=0xa03f1a8, _id=17, _o=0xbfb9f1f4)
    at kaction.moc:220
#34 0x40db64e3 in QObject::activate_signal (this=0xa20ddb0, clist=0xa215fa0, 
    o=0xbfb9f1f4) at qobject.cpp:2356
#35 0x4061294f in KToolBarButton::buttonClicked (this=0xa20ddb0, t0=-195, 
    t1=LeftButton) at ktoolbarbutton.moc:154
#36 0x40612bc2 in KToolBarButton::mouseReleaseEvent (this=0xa20ddb0, 
    e=0xbfb9f6e4)
    at /usr/local/src/kde/3.5/kdelibs/kdeui/ktoolbarbutton.cpp:479
#37 0x40df20c0 in QWidget::event (this=0xa20ddb0, e=0xbfb9f6e4)
    at qwidget.cpp:4677
#38 0x406120b6 in KToolBarButton::event (this=0xa20ddb0, e=0xbfb9f6e4)
    at /usr/local/src/kde/3.5/kdelibs/kdeui/ktoolbarbutton.cpp:651
#39 0x40d4bb10 in QApplication::internalNotify (this=0xbfb9fc24, 
    receiver=0xa20ddb0, e=0xbfb9f6e4) at qapplication.cpp:2635
#40 0x40d4c0d4 in QApplication::notify (this=0xbfb9fc24, receiver=0xa20ddb0, 
    e=0xbfb9f6e4) at qapplication.cpp:2421
#41 0x40828887 in KApplication::notify (this=0xbfb9fc24, receiver=0xa20ddb0, 
    event=0xbfb9f6e4)
    at /usr/local/src/kde/3.5/kdelibs/kdecore/kapplication.cpp:550
#42 0x40cdc2d7 in QApplication::sendSpontaneousEvent (receiver=0xa20ddb0, 
    event=0xbfb9f6e4) at qapplication.h:499
#43 0x40cd7ff3 in QETWidget::translateMouseEvent (this=0xa20ddb0, 
    event=0xbfb9fa38) at qapplication_x11.cpp:4297
#44 0x40cd62ca in QApplication::x11ProcessEvent (this=0xbfb9fc24, 
    event=0xbfb9fa38) at qapplication_x11.cpp:3448
#45 0x40cef864 in QEventLoop::processEvents (this=0x80d7bf8, flags=4)
    at qeventloop_x11.cpp:192
#46 0x40d642b2 in QEventLoop::enterLoop (this=0x80d7bf8) at qeventloop.cpp:198
#47 0x40d641db in QEventLoop::exec (this=0x80d7bf8) at qeventloop.cpp:145
#48 0x40d4a699 in QApplication::exec (this=0xbfb9fc24)
    at qapplication.cpp:2758
#49 0x40a17784 in kdemain (argc=1, argv=0x80bb478)
    at /usr/local/src/kde/3.5/kdebase/kate/app/katemain.cpp:246
#50 0x40a107f0 in kdeinitmain (argc=1, argv=0x80bb478)
    at kdeinit_kate.la.cpp:3
#51 0x080501ff in launch (argc=1, _name=0x80bb0e4 "kate", 
    args=0x80bb0e9 "\001", cwd=0x0, envc=1, envs=0x80bb0fa "", 
    reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x80bb0fe "filve;1140276621;74393;6279_TIME12025754")
    at /usr/local/src/kde/3.5/kdelibs/kinit/kinit.cpp:639
#52 0x08050b5c in handle_launcher_request (sock=8)
    at /usr/local/src/kde/3.5/kdelibs/kinit/kinit.cpp:1205
#53 0x0805129d in handle_requests (waitForPid=0)
    at /usr/local/src/kde/3.5/kdelibs/kinit/kinit.cpp:1406
#54 0x08051c45 in main (argc=2, argv=0xbfba0644, envp=0xbfba0650)
    at /usr/local/src/kde/3.5/kdelibs/kinit/kinit.cpp:1850
Comment 8 Maxilys 2006-03-18 10:37:43 UTC
Same here. Kate crashes sometimes just after I release the CTRL+S keys I use to save a file.

On rare occasions the file is saved entirely but most of the time, only the beginning. It happens on any files with or without syntax colorization and it looks like that having several files opened at the same time prevents the crash most of the times.

Kate crashed just while I was looking at this bug so here is my backtrace.
Comment 9 Maxilys 2006-03-18 10:43:18 UTC
Created attachment 15182 [details]
Backtrace of a crash

My backtrace has also been attached to another bug... I don't know which one
and that's not my fault but a bug in bugs.kde.org.
Comment 10 Maxilys 2006-03-18 10:56:04 UTC
What I forgot to say:

Kate 2.5.1 (Using KDE 3.5.1 Level "a" SUSE 10.0 UNSUPPORTED)
Comment 11 Stefan Nikolaus 2006-03-18 18:05:27 UTC
It crashes after a file was modified by another program (after reloading this file; not sure about this) and saving a modified (by Kate) file. 
Comment 12 Stefan Nikolaus 2006-03-28 16:51:03 UTC
The crash occurs only after reloading the foreignly changed file. After the crash a file copy dialog stays open.
Comment 13 Gunnar Wegner 2006-03-30 11:42:25 UTC
Hello,

I have the same problem here. I am using kde 3.5.2 (i.e., kate 2.5.2) installed from RPMs on Opensuse 10, Kernel 2.6.13.

The problem first occurred in kile but then I figured out that kate itself crashes. The backtrace I had is similar to the one already attached here (see below).

Some observations:
*The problematic files are kept in a subdirectory (home/Eigene_Dateien/masterthesis) of a directory whose name contains an underscore. It does not (seem to) happen for any files kept outside this directoy (i.e., it does not occur in /home). Can anyone comment on this? Might it be related to handling of special characters?
*On my machines, the problem is unrelated to any modifications outside kate - I observed the problem without having had the file modified elsewhere. 
*The file remains corrupted and can only be manually restored from a backup copy. The process of saving seems to be interrupted while writing and leaves me with a file containing anything between 5 and 95% of the original. It is always the beginning of the file that is intact and the end that is missing.
*It occurs in about 2-3 of 5 times I open the file in kate. 
*For me, it is unrelated to the number of files open in kate, since I closed all of them and kate crashes with only one file open. 
*It is not specific to one certain file.
*It happens no matter if I chose File/Save or if I press Ctrl+S. 
*It happens also when I chose File/Save all or press Ctrl+L. It does seem to be less frequently, though.
*Kile has an autosave feature. It doesn't happen once kile autosaved the file at least once. In fact, this is my workaround. I did not find such an option in kate itself.

Regards, Gunnar :)


Backtrace:
(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 1096208064 (LWP 8676)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xffffe410 in __kernel_vsyscall ()
#7  0x40f07541 in raise () from /lib/tls/libc.so.6
#8  0x40f08dbb in abort () from /lib/tls/libc.so.6
#9  0x40f3d8b5 in __libc_message () from /lib/tls/libc.so.6
#10 0x40f43842 in malloc_printerr () from /lib/tls/libc.so.6
#11 0x40f438da in malloc_consolidate () from /lib/tls/libc.so.6
#12 0x40ffc8b0 in main_arena () from /lib/tls/libc.so.6
#13 0x40ffc8c4 in main_arena () from /lib/tls/libc.so.6
#14 0x084ae508 in ?? ()
#15 0x40ffc8d8 in main_arena () from /lib/tls/libc.so.6
#16 0x00000050 in ?? ()
#17 0x00000018 in ?? ()
#18 0x40ffaff4 in ?? () from /lib/tls/libc.so.6
#19 0x40ffc8a0 in mp_ () from /lib/tls/libc.so.6
#20 0x00000000 in ?? ()
#21 0xbfd240ec in ?? ()
#22 0x40f44534 in _int_malloc () from /lib/tls/libc.so.6
Comment 14 jfvasconcelos 2006-03-31 16:31:11 UTC
If the Ctrl+S shortcut is assigned to "Kate/Save" instead of being assigned to "Kate Part/Save", the problem seems to vanish. In Kile, I've assigned the Ctrl+S shortcut to Kile/Save All with the same good result. Maybe it is a bug in Kate Part?
Comment 15 Gunnar Wegner 2006-05-24 09:17:32 UTC
I have to revise my earlier comments: 

*The crash occurs no matter if there are special characters in the directory name or not.
*It also happens when I use kile's autosave feature (although not as frequently).
*However, as proposed in comment #14, assigning Ctrl+S to "Kile/Save" does work in 100% of the cases.

Regards, Gunnar :)
Comment 16 Dominik Haumann 2006-05-29 17:04:14 UTC
*** Bug 128246 has been marked as a duplicate of this bug. ***
Comment 17 Raúl 2006-05-30 15:26:14 UTC
I have fresh info, I hope this helps. I got this same error and backtrace, but this time while I was trying to duplicate a file into its own same directory. What I did is:
1- Select a file.
2- Ctrl-C
3- Ctrl-V
4- Change the new filename form "foo.ext" to "foo2.ext"
5- Press continue.

After this, I got the progress dialog, and before the progress dialog started to indicate any progress I got the crash, same backtrace and konqueror closed.

Before trying to do the duplication I was snooping with older versions of this file which belongs to a SVN repo.
Comment 18 Dominik Haumann 2006-05-30 16:25:44 UTC
This is unclear. What did you do exactly?
> 1- Select a file. 
The contents of a file? ctrl+a?

> 2- Ctrl-C 
> 3- Ctrl-V 
Paste in the same file? or another? in kate? in kwrite?

> 4- Change the new filename form "foo.ext" to "foo2.ext" 
Sorry? Where change the filename? externally? or save as?

> 5- Press continue. 
I do not see a continue.

Thanks for upcoming clarification ;)
Comment 19 Raúl 2006-05-30 18:10:26 UTC
I'm very sorry, but obviously I wasn't 100% concentrated on what I was writing (let alone 10%). I was talking about konqueror. If you are very sharp you could have seen a mention to it, but it is not clarifying enough.

So all my comments applied to konqueror.
Comment 20 Per Ångström 2006-06-09 21:54:07 UTC
I started seeing this problem in KDE 3.5.1, and I have now upgraded to KDE 3.5.3 (Level "a" unofficial build of SUSE) without seeing any visible improvement.

My distribution is OpenSUSE 10.1, kernel 2.6.16.13-4-default.

I can reproduce the problem easily, following these steps:

1) Open Kate.
2) Create a file, put some text in it and save it.
3) Without closing Kate, open the same file in another editor, modify it and save it.
4) Go back to Kate. Kate should have noticed that file has been changed, and you should choose to update the file from disk.
5) Make some edits to the file in Kate.
6) Use the shortcut CTRL+L to save all open files.

Result: Kate crashes, leaving a File copy dialog behind.

Stack trace:
[KCrash handler]
#6  0xb7950839 in operator== () from /usr/lib/qt3/lib/libqt-mt.so.3
#7  0xb70f7010 in KDirWatchPrivate::slotActivated ()
   from /opt/kde3/lib/libkio.so.4
#8  0xb70f72bc in KDirWatchPrivate::qt_invoke () from /opt/kde3/lib/libkio.so.4
#9  0xb7680edd in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#10 0xb7681a42 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#11 0xb79ba5f0 in QSocketNotifier::activated ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#12 0xb769f0e0 in QSocketNotifier::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#13 0xb7621ec7 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0xb7622c91 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0xb7cdc633 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#16 0xb7616b04 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0xb75d17d4 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#18 0xb7638ce8 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0xb76219ef in QApplication::enter_loop ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0xb7011b75 in KIO::NetAccess::enter_loop () from /opt/kde3/lib/libkio.so.4
#21 0xb705ae2a in KIO::NetAccess::filecopyInternal ()
   from /opt/kde3/lib/libkio.so.4
#22 0xb705b125 in KIO::NetAccess::file_copy () from /opt/kde3/lib/libkio.so.4
#23 0xb6561c8c in KateDocument::save () from /opt/kde3/lib/kde3/libkatepart.so
#24 0xb65343e0 in KateView::save () from /opt/kde3/lib/kde3/libkatepart.so
#25 0xb7dbce29 in KateDocManager::saveAll ()
   from /opt/kde3/lib/libkateinterfaces.so.0
#26 0xb7de1173 in KateDocManager::qt_invoke ()
   from /opt/kde3/lib/libkateinterfaces.so.0
#27 0xb7680edd in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0xb7681b3d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0xb6d48819 in KAction::activated () from /opt/kde3/lib/libkdeui.so.4
#30 0xb6d7da22 in KAction::slotActivated () from /opt/kde3/lib/libkdeui.so.4
#31 0xb6e5010f in KAction::qt_invoke () from /opt/kde3/lib/libkdeui.so.4
#32 0xb7680edd in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0xb7681b3d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0xb7bf6829 in KAccelPrivate::menuItemActivated ()
   from /opt/kde3/lib/libkdecore.so.4
#35 0xb7c462e7 in KAccelPrivate::emitActivatedSignal ()
   from /opt/kde3/lib/libkdecore.so.4
#36 0xb7caa6f9 in KAccelPrivate::eventFilter ()
   from /opt/kde3/lib/libkdecore.so.4
#37 0xb76807dc in QObject::activate_filters ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#38 0xb768084b in QObject::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#39 0xb76b988c in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#40 0xb7774982 in QMainWindow::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#41 0xb7de0b4c in KateMainWindow::event ()
   from /opt/kde3/lib/libkateinterfaces.so.0
#42 0xb7621ec7 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#43 0xb7623222 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#44 0xb7cdc633 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#45 0xb7c52762 in KAccelEventHandler::x11Event ()
   from /opt/kde3/lib/libkdecore.so.4
#46 0xb7cda47b in KApplication::x11EventFilter ()
   from /opt/kde3/lib/libkdecore.so.4
#47 0xb75b0dc4 in qt_x11EventFilter () from /usr/lib/qt3/lib/libqt-mt.so.3
#48 0xb75c0733 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#49 0xb75d15ea in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#50 0xb7638ce8 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#51 0xb7638b7e in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#52 0xb7621a7f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#53 0xb7f60d18 in kdemain () from /opt/kde3/lib/libkdeinit_kate.so
#54 0x080484b2 in main ()
Comment 21 Dominik Haumann 2006-06-10 11:12:53 UTC
I tried comment #20 but it does not crash :(
Comment 22 Christopher J. Bottaro 2006-06-10 17:08:35 UTC
following comment #20's steps, kate crashes every time for me...

In a sentence, kate crashes when trying to save a file that has been externally modified.

Where can I get a previous version of kate (from kde-3.5.0)?  I can't seem to find the sources for kde-3.5.0 on any of the mirrors.
Comment 23 Israel Cabrera 2006-06-11 04:36:40 UTC
In SuSE 10.0, KDE 3.5.2 Level-a
kernel: 2.6.13-15-default

The same thing for QUANTA & Kwrite... when I save files, occasionaly mm... must said: very often it crashes when I click save or CTRL-S
and results:  (sorry I have no debugging package installed, Im gonna try to update kernel today to version:2.6.13-15.10 last available in apt-update  and tell you if this solves the problem)

#73 0x40b8a1c0 in KToolBar::clicked () from /opt/kde3/lib/libkdeui.so.4
#74 0x080f2bf6 in ?? ()
#75 0x084d3410 in ?? ()
#76 0x00000000 in ?? ()
#77 0xbff32c88 in ?? ()
#78 0x4125296b in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#79 0x41252929 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#80 0x41252de0 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#81 0x40b8a3b9 in KAction::activated () from /opt/kde3/lib/libkdeui.so.4
#82 0x40bc4451 in KAction::slotActivated () from /opt/kde3/lib/libkdeui.so.4
#83 0x40bc43ed in KAction::slotButtonClicked ()
   from /opt/kde3/lib/libkdeui.so.4
#84 0x40be3856 in KAction::qt_invoke () from /opt/kde3/lib/libkdeui.so.4
#85 0x41252929 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#86 0x40bcc30f in KToolBarButton::buttonClicked ()
   from /opt/kde3/lib/libkdeui.so.4
#87 0x40bcc510 in KToolBarButton::mouseReleaseEvent ()
   from /opt/kde3/lib/libkdeui.so.4
#88 0x4128d108 in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#89 0x40c28cc1 in KToolBarButton::event () from /opt/kde3/lib/libkdeui.so.4
#90 0x411f1f41 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#91 0x411f3078 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#92 0x40ecb2fe in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#93 0x4118c11c in QETWidget::translateMouseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#94 0x4118aedb in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#95 0x4119f31a in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#96 0x41208ff2 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#97 0x41208ed6 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#98 0x411f188f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#99 0x080f8950 in ?? ()
#100 0x083e02a8 in ?? ()
#101 0x00000000 in ?? ()
#102 0x00000000 in ?? ()
#103 0x00000000 in ?? ()
#104 0x00000000 in ?? ()
#105 0x00000001 in ?? ()
#106 0x0837dd9c in typeinfo name for QMemArray<char> ()
#107 0x0837acfc in typeinfo name for QMemArray<char> ()
#108 0x08374e35 in vtable for QGList ()
#109 0x083746e1 in vtable for QGList ()
#110 0x419c9178 in main_arena () from /lib/libc.so.6
#111 0x00000020 in ?? ()
#112 0x41910ece in _int_malloc () from /lib/libc.so.6
#113 0x418c187c in __libc_start_main () from /lib/libc.so.6
#114 0x0808b801 in ?? ()
Comment 24 Israel Cabrera 2006-06-11 05:12:46 UTC
Maybe bug 123315 have something to do with this?
Comment 25 Stefan Nikolaus 2006-06-11 09:31:32 UTC
Just a wild guess, but may this has something to do with it:

kdirwatch.cpp
revision 484448
date: 30.11.2005 21:41; author: mueller

inotify support

It was introduced after 3.5.0 (483367) and is used since SuSE 10.0, kernel 2.6.13.
Comment 26 Stefan Nikolaus 2006-06-11 10:01:02 UTC
Oops, this was already mentioned in #5.
Comment 27 Hamish Rodda 2006-06-11 11:57:35 UTC
Please try the patch attached to bug 123315 and report if this fixes the issue.
Comment 28 Israel Cabrera 2006-06-13 00:24:11 UTC
I didn't applied the patch but,, I upgrade my system from KDE 3.5.2 to kde 3.5.3 from opensuse repositories and now kwrite & quanta DO NOT crash when saving (tested hundreds of times)... =)  For me, the bug was corrected in this new KDE version...

(as an additional comment, when I was using KDE 3.5.2 I upgraded the kernel from SuSE 10.0 2.6.13-15-default to 2.6.13-15.10 and the bug of crash when saving still remained.)

thanks all
Comment 29 Dirk Mueller 2006-06-13 13:55:23 UTC
its supposed to be fixed by revision r501664
Comment 30 Dirk Mueller 2006-06-13 13:55:40 UTC
*** Bug has been marked as fixed ***.
Comment 31 Michal Trzcinski 2006-07-31 14:15:37 UTC
I have KDE 3.5.3 installed from Slackware packages (Kwrite 4.5.3). Kernel 2.6.18-rc1.
When i want to save a file Kwrite is crashing sometimes. All changes in file was saved but kwrite crashes anyway.

I'm not sure that problem is fixed.

Backtrace:

(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1234180416 (LWP 23699)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#5  0xb75e6be0 in QMapPrivate<int, int>::clear ()
   from /opt/kde/lib/libkdecore.so.4
#6  0xb75e6c3c in QMapPrivate<int, int>::clear ()
   from /opt/kde/lib/libkdecore.so.4
#7  0xb723f4c1 in QPtrVector<QRegExpEngine::State>::deleteItem ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#8  0xb722ad33 in QGVector::clear () from /usr/lib/qt/lib/libqt-mt.so.3
#9  0xb7239083 in QRegExpEngine::~QRegExpEngine ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#10 0xb723f29f in QCache<QRegExpEngine>::deleteItem ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#11 0xb7220b93 in QGCache::makeRoomFor () from /usr/lib/qt/lib/libqt-mt.so.3
#12 0xb7221008 in QGCache::insert_string () from /usr/lib/qt/lib/libqt-mt.so.3
#13 0xb723d21c in QRegExpEngine::QRegExpEngine ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#14 0xb723d2f3 in QRegExp::invalidateEngine ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#15 0xb723d845 in QRegExp::~QRegExp () from /usr/lib/qt/lib/libqt-mt.so.3
#16 0xb64388fd in KateHlManager::realWildcardFind ()
   from /opt/kde/lib/kde3/libkatepart.so
#17 0xb6438b29 in KateHlManager::wildcardFind ()
   from /opt/kde/lib/kde3/libkatepart.so
#18 0xb6438daf in KateHlManager::detectHighlighting ()
   from /opt/kde/lib/kde3/libkatepart.so
#19 0xb641a752 in KateDocument::saveFile ()
   from /opt/kde/lib/kde3/libkatepart.so
#20 0xb7e97694 in KParts::ReadWritePart::save ()
   from /opt/kde/lib/libkparts.so.2
#21 0xb6404cad in KateDocument::save () from /opt/kde/lib/kde3/libkatepart.so
#22 0xb6447b76 in KateView::save () from /opt/kde/lib/kde3/libkatepart.so
#23 0xb64539de in KateView::qt_invoke () from /opt/kde/lib/kde3/libkatepart.so
#24 0xb6f50d44 in QObject::activate_signal ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#25 0xb6f514dc in QObject::activate_signal ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#26 0xb7840169 in KAction::activated () from /opt/kde/lib/libkdeui.so.4
#27 0xb7840bf3 in KAction::slotActivated () from /opt/kde/lib/libkdeui.so.4
#28 0xb7845677 in KAction::qt_invoke () from /opt/kde/lib/libkdeui.so.4
#29 0xb6f50d44 in QObject::activate_signal ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#30 0xb6f514dc in QObject::activate_signal ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#31 0xb75e4d69 in KAccelPrivate::menuItemActivated ()
   from /opt/kde/lib/libkdecore.so.4
#32 0xb75e5337 in KAccelPrivate::emitActivatedSignal ()
   from /opt/kde/lib/libkdecore.so.4
#33 0xb75e5ed0 in KAccelPrivate::eventFilter ()
   from /opt/kde/lib/libkdecore.so.4
#34 0xb6f4e0cf in QObject::activate_filters ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#35 0xb6f4e1a4 in QObject::event () from /usr/lib/qt/lib/libqt-mt.so.3
#36 0xb6f8a51f in QWidget::event () from /usr/lib/qt/lib/libqt-mt.so.3
#37 0xb704ec42 in QMainWindow::event () from /usr/lib/qt/lib/libqt-mt.so.3
#38 0xb6eec23f in QApplication::internalNotify ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#39 0xb6eec881 in QApplication::notify () from /usr/lib/qt/lib/libqt-mt.so.3
#40 0xb75509f5 in KApplication::notify () from /opt/kde/lib/libkdecore.so.4
#41 0xb75e3a44 in KAccelEventHandler::x11Event ()
   from /opt/kde/lib/libkdecore.so.4
#42 0xb7553ee7 in KApplication::x11EventFilter ()
   from /opt/kde/lib/libkdecore.so.4
#43 0xb6e76c75 in qt_set_x11_event_filter ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#44 0xb6e843f8 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#45 0xb6e97f25 in QEventLoop::processEvents ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#46 0xb6f02961 in QEventLoop::enterLoop () from /usr/lib/qt/lib/libqt-mt.so.3
#47 0xb6f028b6 in QEventLoop::exec () from /usr/lib/qt/lib/libqt-mt.so.3
#48 0xb6eeb39f in QApplication::exec () from /usr/lib/qt/lib/libqt-mt.so.3
#49 0xb7f1ad0b in kdemain () from /opt/kde/lib/libkdeinit_kwrite.so
#50 0x0804876e in ?? ()
#51 0x00000002 in ?? ()
#52 0xbff7c8c4 in ?? ()
#53 0x08049878 in ?? ()
#54 0xb6889ffc in ?? () from /lib/tls/libc.so.6
#55 0x00000000 in ?? ()
Comment 32 Matt Rogers 2008-02-09 05:37:55 UTC
*** Bug 141567 has been marked as a duplicate of this bug. ***