Bug 119294 - moving window to top of screen by grabbing titlebar doesn't work if using xinerama w/ panel on top edge
Summary: moving window to top of screen by grabbing titlebar doesn't work if using xin...
Status: RESOLVED DUPLICATE of bug 74559
Alias: None
Product: kwin
Classification: Plasma
Component: xinerama (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-12-31 07:51 UTC by Andy Neitzke
Modified: 2006-12-23 23:05 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Neitzke 2005-12-31 07:51:19 UTC
Version:            (using KDE KDE 3.5.0)
Installed from:    Compiled From Sources
OS:                Linux

I am using nvidia's TwinView for a two-screen setup.  One of the screens has a panel along the top edge.  If I grab a window by its titlebar and try to move it to the top edge, then the top of the titlebar cannot move higher than the bottom edge of the panel.  This is sensible behavior if the window is on the screen with the panel, since then it just means the window is refusing to overlap the panel.  The bug is that the same behavior occurs on the screen without the panel -- there is empty space at the top of that screen, yet the window refuses to go there.

Moving windows by alt-dragging still works fine.
Comment 1 Christian Stoitner 2006-08-16 16:50:28 UTC
This bug is especially enjoying when one of the displays is smaller than the other - the working area of the bigger screen just shrinks to the height(or width in a vertical setup) of the smaller one.
Comment 2 Christoph Burger-Scheidlin 2006-09-09 16:21:18 UTC
This bug is a consequence of bug # 74559 for xinerama users. It could be 
marked as duplicate of it, however it might be easier to fix for the xinerama 
case than for the general case.
Comment 3 illogic-al 2006-12-23 23:05:13 UTC

*** This bug has been marked as a duplicate of 74559 ***