Bug 119292 - Sub-menus on www.18footer.org are not shown
Summary: Sub-menus on www.18footer.org are not shown
Status: RESOLVED WORKSFORME
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: 3.5
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2005-12-31 05:14 UTC by kim Lux
Modified: 2011-11-26 05:09 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kim Lux 2005-12-31 05:14:51 UTC
Version:            (using KDE KDE 3.5.0)
Installed from:    Fedora RPMs
OS:                Linux

http://www.18footer.org/Default.aspx?ItemID=4&TabID=233&controlpath=cs_MoreInfo.ascx&mode=dir
Comment 1 Thiago Macieira 2005-12-31 13:23:30 UTC
Confirmed. It looks like they open an iframe, which Konqueror always renders with infinite z-index.
Comment 2 Rui G. 2008-05-19 14:49:55 UTC
Confirmed in kde 3.5.9. The upper horizontal menu just doesn't load. However it works fine in svn trunk r808114 but it crashes konq4.
Comment 3 A. Spehr 2008-07-11 11:02:14 UTC
Renders fine, but crashes if i move the resizing thing that gwenview does.

Application: Konqueror (konqueror), signal SIGABRT
[Thread debugging using libthread_db enabled]
[New Thread 0xb5b4e720 (LWP 22595)]
[KCrash handler]
#6  0xb7f1e430 in __kernel_vsyscall ()
#7  0xb5e8f5e0 in raise () from /lib/i686/cmov/libc.so.6
#8  0xb5e90fb8 in abort () from /lib/i686/cmov/libc.so.6
#9  0xb6fe036d in qt_message_output (msgType=QtFatalMsg, 
    buf=0xbff363d0 "ASSERT: \"!image.isNull()\" in file /home/ax4/kde/src/KDE/kdegraphics/gwenview/lib/imagescaler.cpp, line 145") at global/qglobal.cpp:2058
#10 0xb6fe03d1 in qFatal (msg=0xb7133020 "ASSERT: \"%s\" in file %s, line %d")
    at global/qglobal.cpp:2260
#11 0xb6fe0813 in qt_assert (assertion=0xb01971cb "!image.isNull()", 
    file=0xb019718c "/home/ax4/kde/src/KDE/kdegraphics/gwenview/lib/imagescaler.cpp", line=145) at global/qglobal.cpp:1828
#12 0xb016ef29 in Gwenview::ImageScaler::scaleRect (this=0x9500848, 
    rect=@0x9525920)
    at /home/ax4/kde/src/KDE/kdegraphics/gwenview/lib/imagescaler.cpp:145
#13 0xb016f73c in Gwenview::ImageScaler::doScale (this=0x9500848)
    at /home/ax4/kde/src/KDE/kdegraphics/gwenview/lib/imagescaler.cpp:126
#14 0xb016f808 in Gwenview::ImageScaler::setDestinationRegion (this=0x9500848, 
    region=@0xbff386f0)
    at /home/ax4/kde/src/KDE/kdegraphics/gwenview/lib/imagescaler.cpp:91
#15 0xb0172fd1 in Gwenview::ImageViewPrivate::setScalerRegionToVisibleRect (
    this=0xa045678)
    at /home/ax4/kde/src/KDE/kdegraphics/gwenview/lib/imageview.cpp:160
#16 0xb0171c8b in Gwenview::ImageView::setZoom (this=0x9db8e18, 
    zoom=0.22600000000000001, center=@0xbff38818)
    at /home/ax4/kde/src/KDE/kdegraphics/gwenview/lib/imageview.cpp:435
#17 0xb1ba1333 in Gwenview::GVPart::setZoom (this=0x959ceb8, 
    zoom=0.22600000000000001, _center=@0xbff38850)
    at /home/ax4/kde/src/KDE/kdegraphics/gwenview/part/gvpart.cpp:402
#18 0xb1ba1a7a in Gwenview::GVPart::applyZoomSliderValue (this=0x959ceb8)
    at /home/ax4/kde/src/KDE/kdegraphics/gwenview/part/gvpart.cpp:316
#19 0xb1ba20b4 in Gwenview::GVPart::qt_metacall (this=0x959ceb8, 
    _c=QMetaObject::InvokeMetaMethod, _id=12, _a=0xbff3897c)
    at /home/ax4/kde/build/KDE/kdegraphics/gwenview/part/gvpart.moc:99
#20 0xb70f2b08 in QMetaObject::activate (sender=0xa045368, 
    from_signal_index=27, to_signal_index=27, argv=0xbff3897c)
    at kernel/qobject.cpp:3007
#21 0xb70f2f95 in QMetaObject::activate (sender=0xa045368, m=0xb6b10714, 
    local_signal_index=0, argv=0xbff3897c) at kernel/qobject.cpp:3080
#22 0xb6a36166 in QAbstractSlider::valueChanged (this=0xa045368, _t1=-86)
    at .moc/debug-shared/moc_qabstractslider.cpp:161
#23 0xb678e299 in QAbstractSlider::setValue (this=0xa045368, value=-86)
    at widgets/qabstractslider.cpp:533
#24 0xb678e407 in QAbstractSlider::triggerAction (this=0xa045368, 
    action=QAbstractSlider::SliderMove) at widgets/qabstractslider.cpp:622
#25 0xb678e9a1 in QAbstractSlider::setSliderPosition (this=0xa045368, 
    position=-86) at widgets/qabstractslider.cpp:490
#26 0xb68439fe in QSlider::mouseMoveEvent (this=0xa045368, ev=0xbff391a4)
    at widgets/qslider.cpp:526
#27 0xb646fcf4 in QWidget::event (this=0xa045368, event=0xbff391a4)
    at kernel/qwidget.cpp:6912
#28 0xb678e09a in QAbstractSlider::event (this=0xa045368, e=0xbff391a4)
    at widgets/qabstractslider.cpp:849
#29 0xb6844193 in QSlider::event (this=0xa045368, event=0xbff391a4)
    at widgets/qslider.cpp:438
#30 0xb6411d95 in QApplicationPrivate::notify_helper (this=0x9168d00, 
    receiver=0xa045368, e=0xbff391a4) at kernel/qapplication.cpp:3772
#31 0xb6412917 in QApplication::notify (this=0xbff39a08, receiver=0xa045368, 
    e=0xbff391a4) at kernel/qapplication.cpp:3501
#32 0xb78d3e1f in KApplication::notify (this=0xbff39a08, receiver=0xa045368, 
    event=0xbff391a4)
    at /home/ax4/kde/src/KDE/kdelibs/kdeui/kernel/kapplication.cpp:311
#33 0xb70ddf67 in QCoreApplication::notifyInternal (this=0xbff39a08, 
    receiver=0xa045368, event=0xbff391a4) at kernel/qcoreapplication.cpp:583
#34 0xb641dffb in QCoreApplication::sendSpontaneousEvent (receiver=0xa045368, 
    event=0xbff391a4) at ../../include/QtCore/qcoreapplication.h:218
#35 0xb641670a in QApplicationPrivate::sendMouseEvent (receiver=0xa045368, 
    event=0xbff391a4, alienWidget=0xa045368, nativeWidget=0x9221da8, 
    buttonDown=0xb6b2d720, lastMouseReceiver=@0xb6b2d724)
    at kernel/qapplication.cpp:2766
#36 0xb648e4ee in QETWidget::translateMouseEvent (this=0x9221da8, 
    event=0xbff39690) at kernel/qapplication_x11.cpp:4133
#37 0xb648f215 in QApplication::x11ProcessEvent (this=0xbff39a08, 
    event=0xbff39690) at kernel/qapplication_x11.cpp:3133
#38 0xb64b8c2d in x11EventSourceDispatch (s=0x916bc40, callback=0, 
    user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#39 0xb5d12978 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#40 0xb5d15bce in ?? () from /usr/lib/libglib-2.0.so.0
#41 0x0916a6e8 in ?? ()
#42 0x00000000 in ?? ()
#0  0xb7f1e430 in __kernel_vsyscall ()
Comment 4 A. Spehr 2008-07-11 11:10:03 UTC
Looks like this isn't a dup of something else? So I guess nobody filed another report... Does look like Gwenview though, and now I know who to toss it to. :)
Comment 5 Frank Reininghaus 2008-07-31 00:32:46 UTC
@comment #3: Alex, do you still get a Gwenview resizing thing on this site? I don't in 4.1 and SVN trunk 839800. But I can confirm comment #2: Konqueror crashes when you move the mouse pointer over the menu (move it left or right a bit if it doesn't crash instantly).

Application: Konqueror (konqueror), signal SIGABRT

Thread 1 (Thread 0xb5e30720 (LWP 8184)):
[KCrash Handler]
#6  0xb7fd6410 in __kernel_vsyscall ()
#7  0xb638c085 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb638da01 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb74441d8 in qt_message_output (msgType=QtFatalMsg, buf=0xbfc64900 "ASSERT failure in QVector<T>::at: \"index out of range\", file /home/kde-devel/qt-copy/include/QtCore/qvector.h, line 323")
    at global/qglobal.cpp:2058
#10 0xb744425d in qFatal (msg=0xb75c1e48 "ASSERT failure in %s: \"%s\", file %s, line %d") at global/qglobal.cpp:2260
#11 0xb74442b4 in qt_assert_x (where=0xb42f9c20 "QVector<T>::at", what=0xb42f9c0d "index out of range", file=0xb42f9bdc "/home/kde-devel/qt-copy/include/QtCore/qvector.h", line=323)
    at global/qglobal.cpp:1836
#12 0xb4132bb7 in QVector<khtml::RenderLayer*>::at (this=0x8d2e650, i=0) at /home/kde-devel/qt-copy/include/QtCore/qvector.h:323
#13 0xb4130e09 in khtml::RenderLayer::updateWidgetMasks (this=0x8f9ba40, rootLayer=0x833cae0) at /home/kde-devel/kde/src/KDE/kdelibs/khtml/rendering/render_layer.cpp:404
#14 0xb413108f in khtml::RenderLayer::updateWidgetMasks (this=0x833cbc8, rootLayer=0x833cae0) at /home/kde-devel/kde/src/KDE/kdelibs/khtml/rendering/render_layer.cpp:424
#15 0xb413108f in khtml::RenderLayer::updateWidgetMasks (this=0x833cae0, rootLayer=0x833cae0) at /home/kde-devel/kde/src/KDE/kdelibs/khtml/rendering/render_layer.cpp:424
#16 0xb4166e3c in khtml::RenderCanvas::layout (this=0x833ca08) at /home/kde-devel/kde/src/KDE/kdelibs/khtml/rendering/render_canvas.cpp:199
#17 0xb3fa752e in KHTMLView::layout (this=0x85eaf18) at /home/kde-devel/kde/src/KDE/kdelibs/khtml/khtmlview.cpp:971
#18 0xb3fa7a38 in KHTMLView::timerEvent (this=0x85eaf18, e=0xbfc67484) at /home/kde-devel/kde/src/KDE/kdelibs/khtml/khtmlview.cpp:4024
#19 0xb7573c4e in QObject::event (this=0x85eaf18, e=0xbfc67484) at kernel/qobject.cpp:1105
#20 0xb67922d9 in QWidget::event (this=0x85eaf18, event=0xbfc67484) at kernel/qwidget.cpp:7310
#21 0xb6b5eaa8 in QFrame::event (this=0x85eaf18, e=0xbfc67484) at widgets/qframe.cpp:657
#22 0xb6c09b61 in QAbstractScrollArea::event (this=0x85eaf18, e=0xbfc67484) at widgets/qabstractscrollarea.cpp:897
#23 0xb6c10c17 in QScrollArea::event (this=0x85eaf18, e=0xbfc67484) at widgets/qscrollarea.cpp:297
#24 0xb3fa51db in KHTMLView::event (this=0x85eaf18, e=0xbfc67484) at /home/kde-devel/kde/src/KDE/kdelibs/khtml/khtmlview.cpp:526
#25 0xb6727f55 in QApplicationPrivate::notify_helper (this=0x805d2a8, receiver=0x85eaf18, e=0xbfc67484) at kernel/qapplication.cpp:3772
#26 0xb6729ca9 in QApplication::notify (this=0xbfc67800, receiver=0x85eaf18, e=0xbfc67484) at kernel/qapplication.cpp:3739
#27 0xb7aa404b in KApplication::notify (this=0xbfc67800, receiver=0x85eaf18, event=0xbfc67484) at /home/kde-devel/kde/src/KDE/kdelibs/kdeui/kernel/kapplication.cpp:311
#28 0xb755e24d in QCoreApplication::notifyInternal (this=0xbfc67800, receiver=0x85eaf18, event=0xbfc67484) at kernel/qcoreapplication.cpp:587
#29 0xb75627dd in QCoreApplication::sendEvent (receiver=0x85eaf18, event=0xbfc67484) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#30 0xb7596f01 in QTimerInfoList::activateTimers (this=0x80601fc) at kernel/qeventdispatcher_unix.cpp:563
#31 0xb7594614 in timerSourceDispatch (source=0x80601c8) at kernel/qeventdispatcher_glib.cpp:166
#32 0xb60d6bf8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#33 0xb60d9e5e in ?? () from /usr/lib/libglib-2.0.so.0
#34 0xb60da3ac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#35 0xb759378c in QEventDispatcherGlib::processEvents (this=0x805ac48, flags=@0xbfc675f4) at kernel/qeventdispatcher_glib.cpp:325
#36 0xb67e3db0 in QGuiEventDispatcherGlib::processEvents (this=0x805ac48, flags=@0xbfc67624) at kernel/qguieventdispatcher_glib.cpp:204
#37 0xb755aaca in QEventLoop::processEvents (this=0xbfc676ac, flags=@0xbfc67664) at kernel/qeventloop.cpp:149
#38 0xb755ad09 in QEventLoop::exec (this=0xbfc676ac, flags=@0xbfc676b4) at kernel/qeventloop.cpp:200
#39 0xb755eb84 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:845
#40 0xb6727c6e in QApplication::exec () at kernel/qapplication.cpp:3304
#41 0xb7fbba8e in kdemain (argc=1, argv=0xbfc67b14) at /home/kde-devel/kde/src/KDE/kdebase/apps/konqueror/src/konqmain.cpp:227
#42 0x080486f6 in main (argc=) at /home/kde-devel/kde/build/KDE/kdebase/apps/konqueror/src/konqueror_dummy.cpp:3

Comment 6 A. Spehr 2008-07-31 21:10:27 UTC
I don't actually see the resize bar on there anymore? Maybe it was fixed anyway or we are very lucky and aurelien knows the problem just from the bt?

No crash on the menus, but the drop down ones go white after you mouse over them. Page probably needs a testcase before it changes again, and we should check to see if there's an archived version yet.
Comment 7 A. Spehr 2008-07-31 21:12:24 UTC
838499, btw, so yours is newer. ;)
Comment 8 Aurelien Gateau 2008-07-31 22:05:25 UTC
If with "resize bar" you mean the zooming slider, then I removed it from 
the KPart. I still get a crash when I visit this page, but it's no 
longer in Gwenview KPart, it's in KHTML.
Comment 9 Frank Reininghaus 2008-07-31 22:40:16 UTC
OK, I'll change the summary to something that reflects better the current problem with the page (the rendering problem appears to be fixed). Actually, it crashes already on the start page http://www.18footer.org/. 

I already tried to make a test case, but I failed: Both Firefox' "Save Page, complete" feature and "wget --convert-links --page-requisites ..." seem to miss some important files and leave me with a messed up version of the page that does not crash Konqueror :-(
Comment 10 Aurelien Gateau 2008-07-31 23:35:45 UTC
The rendering of the start page is quite bad, but it does not crash for 
me with trunk r840090.
Comment 11 Dominik Tritscher 2008-08-25 21:56:50 UTC
The startpage loads fine here with 4.1 but crashes wenn hovering over the menu with the same assert failure as reported above.
Comment 12 Frank Reininghaus 2008-08-31 20:52:37 UTC
Note that the crash is gone in trunk - it was a duplicate of bug 169447 which was fixed today. Nevertheless, the rendering is still broken: Sub-menus are not shown when hovering with the mouse over menu entries, so we should leave this bug report open. I'm changing the summary and the severity accordingly.
Comment 13 A. Spehr 2008-11-23 01:59:47 UTC
Submenus show up as white boxes still, so confirming. (no crash)

r887759
Comment 14 Dawit Alemayehu 2011-11-26 05:09:33 UTC
Cannot reproduce in KDE 4.7.x and KDE 3.x is unmaintained.