Bug 118496 - "Add to custom colors" does not work in the KDE color selector widget
Summary: "Add to custom colors" does not work in the KDE color selector widget
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal with 80 votes (vote)
Target Milestone: ---
Assignee: Lukáš Tinkl
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-12-17 07:23 UTC by Øyvind Stegard
Modified: 2014-06-04 08:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.13.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Øyvind Stegard 2005-12-17 07:23:25 UTC
Version:            (using KDE KDE 3.5.0)
Installed from:    Fedora RPMs
Compiler:          gcc (GCC) 4.0.2 20051125 (Red Hat 4.0.2-8) 
OS:                Linux

The "Add to custom colors"-button has no effect in the standard KDE color selection widget. I doesn't seem to work at all. There are no colors in the custom color palette.

Tested with the following apps:
kdesktop
kolourpaint
knotes

I am assuming it applies to all applications that use this widget.
Comment 1 Travis Evans 2006-01-23 01:30:06 UTC
I noticed the same problem with KColorChooser with KDE 3.5.0, SUSE 9.3.  There is an extra blank entry at the bottom of the color palette drop-down list box, and the Add to Custom Colors button switches to this empty palette and does nothing. Same thing in all the other programs I tried with this color selection dialog.

I went back to KDE 3.4.3 to get rid of the problem.
Comment 2 Maxilys 2006-01-23 12:47:11 UTC
I confirm this bug with KDE 3.5.0, SuSE 10.0.

I dug a little and what I found is that --apparently-- to reduce the number of recent colors removes --temporarely-- the empty color list.

Check your ~/.kde/share/config/colors/Recent_Colors

I had over 600 recent colors which I reduced to less than 128. (Some of these recent colors wasn't that recent IMHO.) But this doesn't solve the problem. The empty list re-appears when I click on "Add to custom colors" and nothing else happens.

I tried to reduce the number of custom colors --although there was less than 100 of them-- but it makes no difference. Even erasing the custom colors file doesn't help; it won't be re-created.
Comment 3 Christine Bona 2006-01-27 00:13:50 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 Øyvind Stegard 2006-01-31 16:20:22 UTC
Still doesn't work in KDE 3.5.1.
Comment 5 Lukáš Tinkl 2006-03-15 14:37:21 UTC
I fixed it some time ago in KDE 3.5 branch
Comment 6 Sandro Knauß 2014-06-04 08:01:43 UTC
Git commit 0a23465bc5ea2ba74e96824670c71dc93cf80e32 by Sandro Knauß.
Committed on 01/06/2014 at 15:42.
Pushed by knauss into branch 'KDE/4.13'.

Use credentials in the "Edit Host" window to query LDAP Server.

If the server needs authentification to connect, the "Query Server"
to get the namingcontexts should use the credentials.
Related: bug 335651
FIXED-IN: 4.13.2

M  +6    -13   kldap/ldapconfigwidget.cpp

http://commits.kde.org/kdepimlibs/0a23465bc5ea2ba74e96824670c71dc93cf80e32