Bug 118303 - When trying to print preview a pdf file, kpdf crashed
Summary: When trying to print preview a pdf file, kpdf crashed
Status: RESOLVED INTENTIONAL
Alias: None
Product: kpdf
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Albert Astals Cid
URL:
Keywords:
: 136448 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-12-14 11:56 UTC by Mr Ter
Modified: 2009-08-27 00:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mr Ter 2005-12-14 11:56:03 UTC
Version:           unknown (using KDE 3.4.2 Level "b" , SUSE 10.0)
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.13-15-smp

I clicked on a pdf attachment in kmail. That opened kpdf. I selected print preview from the File menu. The following stack trace has been generated:

(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 1095636672 (LWP 1855)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#7  0x08052f56 in _start ()
#8  0x081627f0 in ?? ()
#9  0x081627f0 in ?? ()
#10 0xbfda5e58 in ?? ()
#11 0x0805000d in _start ()
#12 0x08162868 in ?? ()
#13 0x08162868 in ?? ()
#14 0x400216cc in ?? ()
#15 0x081627f0 in ?? ()
#16 0x00000002 in ?? ()
#17 0x081627f0 in ?? ()
#18 0xbfda5e78 in ?? ()
#19 0x080530c1 in _start ()
#20 0x081627f0 in ?? ()
#21 0xbfda61d0 in ?? ()
#22 0x00000001 in ?? ()
#23 0x00000000 in ?? ()
#24 0x00000001 in ?? ()
#25 0xbfda5f10 in ?? ()
#26 0xbfda5ea8 in ?? ()
#27 0x08053da6 in _start ()
#28 0x081627f0 in ?? ()
#29 0x08162888 in ?? ()
#30 0xbfda61d0 in ?? ()
#31 0x40360008 in ?? () from /opt/kde3/lib/libkio.so.4
#32 0x400aa684 in ?? () from /opt/kde3/lib/libkio.so.4
#33 0x00e87d96 in ?? ()
#34 0xbfda5f30 in ?? ()
#35 0x40f1180c in ?? () from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0x08162390 in ?? ()
#37 0x00000000 in ?? ()
#38 0xbfda5ee8 in ?? ()
#39 0x40ac7159 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
Comment 1 Albert Astals Cid 2005-12-15 19:34:09 UTC
Happens with all pdf or only with one?
Comment 2 Mr Ter 2005-12-15 19:40:51 UTC
On Thursday 15 Dec 2005 18:34, Albert Astals Cid wrote:

Tried 3 different pdfs with the same result - crash.

Tom

[bugs.kde.org quoted mail]
Comment 3 Albert Astals Cid 2005-12-15 19:50:02 UTC
Any possibility you can update to something newer than KDE 3.4.2 ?
Comment 4 Mr Ter 2005-12-15 19:56:01 UTC
I'm afraid not at the moment. I had KDE 3.5 but had to down grade. But if you have something newer I can send you one of the pdf files that cause the crash.
Comment 5 Albert Astals Cid 2005-12-15 21:13:52 UTC
Let's see if it is a kpdf or kprinter problem.

Open kpdf
Open the print dialog 
Choose print to file (Postscript)

If it crashes while doing that it's a problem with kpdf, if not it is a problem with kprinter and i'll reassign the bug to the appropiate person.
Comment 6 Pino Toscano 2006-10-30 00:47:49 UTC
*** Bug 136448 has been marked as a duplicate of this bug. ***
Comment 7 Pino Toscano 2007-01-12 23:11:36 UTC
Any news about this crash? Does still happen with KPDF 0.5.x?
Comment 8 Pino Toscano 2007-09-16 01:48:18 UTC
Sorry if I ask again... does this crash still happen with KPDF 0.5.7?
Comment 9 huart jean-charles 2007-09-17 12:44:07 UTC
Hello,

I am still in 0.5.5 std suse 10.2.

Will confirm situation after upgrade.

Best regards

jch
----------------------------------------> Date: Sat, 15 Sep 2007 23:48:19 +0000> From: toscano.pino@tiscali.it> To: jean_charles_huart@hotmail.com> Subject: [Bug 118303] When trying to print preview a pdf file, kpdf crashed>> ------- You are receiving this mail because: -------> You are on the CC list for the bug, or are watching someone who is.>> http://bugs.kde.org/show_bug.cgi?id=118303>>>>> ------- Additional Comments From toscano.pino tiscali it 2007-09-16 01:48 -------> Sorry if I ask again... does this crash still happen with KPDF 0.5.7?
Comment 10 Pino Toscano 2008-05-17 13:45:32 UTC
Ping? any news about this crash?
Comment 11 Albert Astals Cid 2009-08-27 00:39:42 UTC
KPDF is no longer under development so i'm closing this bug as WONTFIX.

If you still experiment this problem with Okular (KPDF successor) please open a new bug against it.