Bug 117293 - Subject left in body when both body and subject links are present in mailto link
Summary: Subject left in body when both body and subject links are present in mailto link
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: 1.8.2
Platform: unspecified Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-11-29 18:46 UTC by Marcin Kasperski
Modified: 2009-01-29 17:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin Kasperski 2005-11-29 18:46:33 UTC
Version:           1.8.2 (using KDE 3.4.2, Debian Package 4:3.4.2-4 (testing/unstable))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.8

I click the following link (obtained in HTML email which I read via kmail):

<a href="mailto:chess@e4ec.org?body=Help Challenge&subject=How to use the Challenge command">Help Challenge</a>

(in the email source shown after I press V it looks so:
<a href=3D=22mailto:chess=40e4ec.org?body=3DHelp Challenge&subject=3DHow to use the Challenge command=22>Help Challenge</a>
)

1) Current kmail behaviour: 
- composer window pops up with expected To (chess@e4ec.org), *empty* subject and body containing line (text below is in single line)

Help Challenge&subject=How to use the Challenge command

2) Expected behaviour:
- composer window pops up with To=chess@e4ec.org, Subject=How to use the Challenge Command, body=Help Challenge

3) Interesting is that if I write the same link in the konqueror URL box, kmail opens correctly.


Sidenote: www.e4ec.org is freely available service handling chess games played by email, if one would like to test something on it, he or she can play with it
Comment 1 Bastian Venthur 2007-03-19 18:37:30 UTC
Looks like this bug is still alive and kicking. Fixing it should be easy. KMail is BTW the only MUA not correctly handling mailto-URLs. Thunderbird, Mozilla, Sylpheed, Mutt, ... have no problems with URL's like that.
Comment 2 Alberto Gonzalez 2007-06-22 21:48:03 UTC
I think that the problem with this bug is that it seems to work correctly when using Konqueror, but it fails when using Firefox. The easiest way to reproduce and find a fix is by typing in a terminal:

kmail --composer "mailto:mail@example.com?subject=foosubject&body=foobody"

You'll see an empty subject and body. But ff you change kmail for thunderbird or sylpheed (and have these programs installed, obviously), you'll see it works correctly.
Comment 3 Marcelo Barreto Nees 2008-04-03 13:18:59 UTC
Another interesting thing is, if I change "&" by "?" on the second parameter, 
kmail's composer window pops up with expected To (chess@e4ec.org), *empty* subject and body containing line (text below is in single line.

For instance:
<a href="mailto:chess@e4ec.org?body=Help Challenge?subject=How to use the Challenge command">Help Challenge</a>
Comment 4 Alan Braslau 2009-01-23 09:52:28 UTC
kmail version 1.10.4

My company's antispam filter sends me quarantine notices in HTML with links to release individual messages, such as:
<a href="mailto:pmx-auto-approve%2b71c406ecdca9004ea1e280082f68d7f6@server.domaine?subject=Release%20message%20from%20quarantine&body=[%23y6nRYw-3]">[#y6nRYw-3]</a>

(in this example, server.domaine has been changed)

kmail opens a composer window with the correct address, but the subject is set as:
"Release message from quarantine&body=[%23y6nRYw-3]"
and the body, of course, is empty...
Comment 5 Thomas McGuire 2009-01-23 16:07:11 UTC
SVN commit 915697 by tmcguire:

Make mailto links which include body and subject work correctly again.
BUG: 108974
BUG: 117293


 M  +9 -18     kmcommands.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=915697
Comment 6 Thomas McGuire 2009-01-29 17:45:05 UTC
SVN commit 918210 by tmcguire:

Backport r915697 by tmcguire from trunk to the 4.2 branch:

Make mailto links which include body and subject work correctly again.
CCBUG: 108974
CCBUG: 117293



 M  +9 -18     kmcommands.cpp  
 M  +46 -18    messagelistview/core/sortorder.cpp  
 M  +5 -1      messagelistview/core/sortorder.h  
 M  +1 -1      messagelistview/core/widgetbase.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=918210