Bug 116354 - Find in diagram function
Summary: Find in diagram function
Status: RESOLVED FIXED
Alias: None
Product: umbrello
Classification: Unclassified
Component: general (show other bugs)
Version: 1.4.2
Platform: unspecified Linux
: NOR wishlist with 10 votes (vote)
Target Milestone: ---
Assignee: Ralf Habacker
URL:
Keywords:
: 81866 (view as bug list)
Depends on:
Blocks: 81866
  Show dependency treegraph
 
Reported: 2005-11-14 17:40 UTC by Justin Sheckler
Modified: 2019-01-25 23:48 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.14.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Sheckler 2005-11-14 17:40:04 UTC
Version:           1.4.2 (using KDE 3.4.2 Level "b" , SUSE 10.0)
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.13-15-default

I'm currently diagramming a large legacy project of about 80 classes.  It would be great to have a "find" function that would focus a selected object in the current diagram.  Either that, or a context menu option for the UML browser that would zoom in on an object in the current diagram.
Comment 1 Mohamed Bouarfa 2007-11-30 13:15:58 UTC
I would like to add to this wish the possibility to have a "find" which gives the list of diagrams currently using a browser-selected item .
Comment 2 Ralf Habacker 2014-04-23 21:48:09 UTC
Git commit 7566f5b0e8e60072960e7374828825fabca3e942 by Ralf Habacker.
Committed on 21/04/2014 at 21:13.
Pushed by habacker into branch 'work/find-text'.

Add 'Show in diagram' context menu entry for tree view class elements

M  +5    -0    umbrello/listpopupmenu.cpp
M  +1    -0    umbrello/listpopupmenu.h
M  +32   -0    umbrello/umllistview.cpp

http://commits.kde.org/umbrello/7566f5b0e8e60072960e7374828825fabca3e942
Comment 3 Ralf Habacker 2014-04-23 21:51:26 UTC
Git commit 783e62656298cd5ef51961a3cacdf94e3d6aaaf8 by Ralf Habacker.
Committed on 21/04/2014 at 21:13.
Pushed by habacker into branch 'master'.

Add 'Show in diagram' context menu entry for tree view class elements

M  +5    -0    umbrello/listpopupmenu.cpp
M  +1    -0    umbrello/listpopupmenu.h
M  +32   -0    umbrello/umllistview.cpp

http://commits.kde.org/umbrello/783e62656298cd5ef51961a3cacdf94e3d6aaaf8
Comment 4 Ralf Habacker 2014-04-23 21:51:27 UTC
Git commit 73cf55965486c070498db4abfbc4e6fa98ca30cf by Ralf Habacker.
Committed on 23/04/2014 at 21:48.
Pushed by habacker into branch 'master'.

Quick fix for broken diagram zoom.

M  +2    -2    umbrello/umllistview.cpp

http://commits.kde.org/umbrello/73cf55965486c070498db4abfbc4e6fa98ca30cf
Comment 5 Ralf Habacker 2014-04-23 22:38:21 UTC
Git commit a609870a4717ea297d2389e06c3bf7df521617f6 by Ralf Habacker.
Committed on 23/04/2014 at 22:32.
Pushed by habacker into branch 'work/find-text'.

Add 'Show in diagram' support for non tabbed diagram mode.

M  +10   -7    umbrello/umllistview.cpp

http://commits.kde.org/umbrello/a609870a4717ea297d2389e06c3bf7df521617f6
Comment 6 Ralf Habacker 2014-04-24 09:54:14 UTC
Git commit 685b9abca922c503b33dabcb0aab2bf8af84f05d by Ralf Habacker.
Committed on 24/04/2014 at 07:00.
Pushed by habacker into branch 'master'.

Add parameter to UMLApp::setCurrentView() to prevent diagram selection in the tree view.

Use this method in UMLListView::slotMenuSelection() instead of a local implementation.

M  +10   -4    umbrello/uml.cpp
M  +1    -1    umbrello/uml.h
M  +1    -8    umbrello/umllistview.cpp

http://commits.kde.org/umbrello/685b9abca922c503b33dabcb0aab2bf8af84f05d
Comment 7 Ralf Habacker 2014-04-24 09:54:15 UTC
Git commit f872482d4978de28bc94dc119637701ec8fe6360 by Ralf Habacker.
Committed on 24/04/2014 at 09:26.
Pushed by habacker into branch 'master'.

Add result selection menu to 'Show in diagram' feature in case there are more than one results.

M  +39   -6    umbrello/umllistview.cpp
M  +1    -1    umbrello/umllistview.h

http://commits.kde.org/umbrello/f872482d4978de28bc94dc119637701ec8fe6360
Comment 8 Ralf Habacker 2014-04-25 08:55:46 UTC
Git commit c4add472f88389e16f902a8bfc92bd1d127f34bb by Ralf Habacker.
Committed on 25/04/2014 at 08:54.
Pushed by habacker into branch 'master'.

Enable 'Show in diagram' feature for packages and interface too.

M  +4    -0    umbrello/listpopupmenu.cpp

http://commits.kde.org/umbrello/c4add472f88389e16f902a8bfc92bd1d127f34bb
Comment 9 Ralf Habacker 2014-04-25 10:24:03 UTC
Git commit 0236ea8f005c1c84d46ae18e76e6a1e02fa20d4d by Ralf Habacker.
Committed on 21/04/2014 at 21:17.
Pushed by habacker into branch 'work/find-text'.

Add find text in tree view, current diagram and all diagrams feature.

The implementation adds menu entries and keyboard shortcuts for 'find', 'find next' and
'find previous' functions.

On start of a find operation a dialog will be opened, which allows to set the find filter
and a simple search text. Depending on the selected filter all tree view elements or elements
from the current or all diagrams are compared case insensitive against the search text.
The results are stored for later access and the first result will be displayed as described below.

Running 'find next' or 'find previous' using the 'tree view' filter will select the related search result,

Running 'find next' or 'find previous' with current diagram or all diagrams filter set, shows the related
view and selects the requested widget, which is positioned in the center of the view with a 100% zoom.
If a related tree view item is present, it will also be selected.

The implementation is undo/redo proof, because it stores scene/object/widget id's instead of pointers.

M  +12   -0    umbrello/CMakeLists.txt
A  +58   -0    umbrello/dialogs/finddialog.cpp     [License: GPL (v2+)]
A  +41   -0    umbrello/dialogs/finddialog.h     [License: GPL (v2+)]
A  +106  -0    umbrello/dialogs/finddialog.ui
A  +117  -0    umbrello/finder/findresults.cpp     [License: GPL (v2+)]
A  +50   -0    umbrello/finder/findresults.h     [License: GPL (v2+)]
A  +85   -0    umbrello/finder/umldocfinder.cpp     [License: GPL (v2+)]
A  +38   -0    umbrello/finder/umldocfinder.h     [License: GPL (v2+)]
A  +19   -0    umbrello/finder/umlfinder.cpp     [License: GPL (v2+)]
A  +62   -0    umbrello/finder/umlfinder.h     [License: GPL (v2+)]
A  +84   -0    umbrello/finder/umllistviewfinder.cpp     [License: GPL (v2+)]
A  +34   -0    umbrello/finder/umllistviewfinder.h     [License: GPL (v2+)]
A  +111  -0    umbrello/finder/umlscenefinder.cpp     [License: GPL (v2+)]
A  +40   -0    umbrello/finder/umlscenefinder.h     [License: GPL (v2+)]
A  +107  -0    umbrello/findresults.cpp     [License: GPL (v2+)]
A  +48   -0    umbrello/findresults.h     [License: GPL (v2+)]
M  +65   -0    umbrello/uml.cpp
M  +5    -0    umbrello/uml.h
M  +2    -0    umbrello/umllistview.h
M  +1    -0    umbrello/umlobject.h
M  +13   -0    umbrello/umlscene.cpp
M  +2    -0    umbrello/umlscene.h

http://commits.kde.org/umbrello/0236ea8f005c1c84d46ae18e76e6a1e02fa20d4d
Comment 10 Ralf Habacker 2014-04-25 10:42:46 UTC
Git commit e13d4c315c1b648878590a19ebbf8df8e0d8955c by Ralf Habacker.
Committed on 21/04/2014 at 21:17.
Pushed by habacker into branch 'master'.

Add find text in tree view, current diagram and all diagrams feature.

The implementation adds menu entries and keyboard shortcuts for 'find', 'find next' and
'find previous' functions.

On start of a find operation a dialog will be opened, which allows to set the find filter
and a simple search text. Depending on the selected filter all tree view elements or elements
from the current or all diagrams are compared case insensitive against the search text.
The results are stored for later access and the first result will be displayed as described below.

Running 'find next' or 'find previous' using the 'tree view' filter will select the related search result,

Running 'find next' or 'find previous' with current diagram or all diagrams filter set, shows the related
view and selects the requested widget, which is positioned in the center of the view with a 100% zoom.
If a related tree view item is present, it will also be selected.

The implementation is undo/redo proof, because it stores scene/object/widget id's instead of pointers.

M  +12   -0    umbrello/CMakeLists.txt
A  +58   -0    umbrello/dialogs/finddialog.cpp     [License: GPL (v2+)]
A  +41   -0    umbrello/dialogs/finddialog.h     [License: GPL (v2+)]
A  +106  -0    umbrello/dialogs/finddialog.ui
A  +117  -0    umbrello/finder/findresults.cpp     [License: GPL (v2+)]
A  +50   -0    umbrello/finder/findresults.h     [License: GPL (v2+)]
A  +85   -0    umbrello/finder/umldocfinder.cpp     [License: GPL (v2+)]
A  +38   -0    umbrello/finder/umldocfinder.h     [License: GPL (v2+)]
A  +19   -0    umbrello/finder/umlfinder.cpp     [License: GPL (v2+)]
A  +62   -0    umbrello/finder/umlfinder.h     [License: GPL (v2+)]
A  +84   -0    umbrello/finder/umllistviewfinder.cpp     [License: GPL (v2+)]
A  +34   -0    umbrello/finder/umllistviewfinder.h     [License: GPL (v2+)]
A  +111  -0    umbrello/finder/umlscenefinder.cpp     [License: GPL (v2+)]
A  +40   -0    umbrello/finder/umlscenefinder.h     [License: GPL (v2+)]
A  +107  -0    umbrello/findresults.cpp     [License: GPL (v2+)]
A  +48   -0    umbrello/findresults.h     [License: GPL (v2+)]
M  +65   -0    umbrello/uml.cpp
M  +5    -0    umbrello/uml.h
M  +2    -0    umbrello/umllistview.h
M  +1    -0    umbrello/umlobject.h
M  +13   -0    umbrello/umlscene.cpp
M  +2    -0    umbrello/umlscene.h

http://commits.kde.org/umbrello/e13d4c315c1b648878590a19ebbf8df8e0d8955c
Comment 11 Ralf Habacker 2018-05-14 12:03:14 UTC
*** Bug 81866 has been marked as a duplicate of this bug. ***
Comment 12 Ralf Habacker 2019-01-25 23:48:31 UTC
Git commit 3d476963180c3de82827c8e0963fbc03463b2669 by Ralf Habacker.
Committed on 25/01/2019 at 23:47.
Pushed by habacker into branch 'Applications/18.12'.

Add "show" and "properties" to context menu of tree view item types 'category' and 'artifact'

M  +5    -4    umbrello/menus/umllistviewpopupmenu.cpp

https://commits.kde.org/umbrello/3d476963180c3de82827c8e0963fbc03463b2669