Bug 115623 - fast switching through document history
Summary: fast switching through document history
Status: RESOLVED DUPLICATE of bug 104997
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist with 40 votes (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 39116 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-11-03 19:40 UTC by Jörg Rüppel
Modified: 2007-12-09 21:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jörg Rüppel 2005-11-03 19:40:42 UTC
Version:           2.4.92 (using KDE 3.4.92 (beta2, >= 20051010), Arch Linux)
Compiler:          Target: i686-pc-linux-gnu
OS:                Linux (i686) release 2.6.13-ARCH

There is still no way to switch back and fourth between an arbitrary number of related documents in kate and kdevelop. This is what most >notepad windows editors do:

CTRL+TAB switches to the last viewed/active document.
Holding CTRL and pressing TAB several times switches through the document history in order of most recently active documents first, without activating them until CTRL is released. Pressing SHIFT in addition to CTRL reverses the traversal order.

Example:
Doc1 is active
Doc2 is irrelevant
Doc3 irrelevant
Doc4 was viewed before Doc1

I work on Doc1 and need info from Doc4, I press CTRL+TAB.
Doc4 becomes active. Doc1 pushed into the history.
I look at Doc4. I press CTRL+TAB and Doc1 opens again.

That is a very fast way for switching between a small number of currently interesting documents.

The current way is to press ALT+LEFT/RIGHT to switch through documents, which can be cumbersome when lots of documents are open.

For demo look at UltraEdit or Visual Studio.

I am aware that CTRL+TAB is used in KDE. CTRL+^ might work on German keyboards (^ is above TAB).
Comment 1 Jörg Rüppel 2005-11-03 20:22:50 UTC
I just noticed: Window switching with ALT+TAB and ALT+SHIFT+TAB in KDE utilizes the same method.
Comment 2 Anders Lund 2005-11-03 20:44:27 UTC
On Thursday 03 November 2005 19:40, Jörg Rüppel wrote:
> notepad windows editors


If you want a SDI editor, use kwrite. You will get the exact same behavior.

As for browsing to a certain document in kate using the keyboard, we have the 
Documents menu. Press ALT + D and then up/down untill your desired document 
is highlighted, then RETURN ;)
Comment 3 Jörg Rüppel 2005-11-03 20:53:17 UTC
So you propose I should open 30 KWrite instances just to get acceptable 
document switching? Nah, I'm not sure I like that idea. That hasn't to do 
anything with SDI anyway.

I don't want to *browse* to a certain document, I want to activate it with a 
*single* key(combo). And then I want to switch back to the document I viewed 
before with the same single keycombo. Everything else is just too slow.

There is a reason for the "switch between .cpp/.h" shortcut in KDevelop, but C 
is not the only domain where two files relate to each other, so why not make 
it generic and adaptive by utilizing the history?
Comment 4 Anders Lund 2005-11-03 21:02:18 UTC
On Thursday 03 November 2005 20:53, Jörg Rüppel wrote:
> I don't want to *browse* to a certain document, I want to activate it with
> a *single* key(combo). And then I want to switch back to the document I
> viewed before with the same single keycombo. Everything else is just too
> slow.


That is a resonable argument.
Comment 5 Maciej Pilichowski 2006-03-22 09:03:56 UTC
> CTRL+TAB switches to the last viewed/active document. 
>  Holding CTRL and pressing TAB several times switches through the document
> history in order of most recently active documents first, without activating
> them until CTRL is released.

I wouldn't agree more. However I would like to configure that shortcut. It should be ctrl+tab by default since it is so popular but the actual shorcut should be up to the user will.
Comment 6 Jörg Rüppel 2006-11-03 18:29:42 UTC
PSPad, a freeware developer editor (http://www.pspad.com) also works like this. 
Comment 7 Anders Lund 2006-11-22 20:34:26 UTC
Kate does not currently have history navigation, the next/previous document 
does opening order i believe. But you *can* assign shortcuts to those.
Comment 8 Maciej Pilichowski 2006-11-23 08:13:09 UTC
> Kate does not currently have history navigation, 

It does not need to have all history. Just _one_ entry -- previously viewed doc.

> But you *can* assign shortcuts to those.

Yes, but you cannot still switch to the previously viewed doc. Besides -- Kate is extremely slow switching documents (CPU 2GHz!) so it is much better just to display list of documents (like task switch in KDE, page switch in Opera, etc) switch to selected title doc, and that make "physical" switch in Kate to given one.
Comment 9 Thomas Friedrichsmeier 2007-12-07 16:57:53 UTC
*** Bug 39116 has been marked as a duplicate of this bug. ***
Comment 10 Thomas Friedrichsmeier 2007-12-09 21:23:33 UTC
Well, this is an often requested feature, indeed. Just noted that this is a duplicate of bug #104997. Marking this report as such. You may want to transfer your votes.

*** This bug has been marked as a duplicate of 104997 ***