Bug 115210 - K3b freezes KDE and crashes (amd64 in a 32-bit chroot)
Summary: K3b freezes KDE and crashes (amd64 in a 32-bit chroot)
Status: RESOLVED WORKSFORME
Alias: None
Product: k3b
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-27 18:38 UTC by Francois Marier
Modified: 2006-03-10 20:38 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francois Marier 2005-10-27 18:38:56 UTC
Version:           0.12.5 (using KDE KDE 3.4.2)
Installed from:    Debian testing/unstable Packages
OS:                Linux

Jean Berthold <jean.berthold@bluewin.ch> has reported the following through the Debian bug tracking system (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=335577) :

I tried to run that release in my chroot environment, unsucessfully, it
crashed one more time.
For your information, below the execution trace:
----------------------------------------------------------------------------
jeannot@burp:~$ dchroot -c ia32 -d k3b
(ia32) k3b
jeannot@burp:~$ libhal.c 644 : Error connecting to system bus: Failed to
connect to socket /var/run/dbus/system_bus_socket: No such file or directory
kio (KSycoca): WARNING: Found version 75, expecting version 79 or higher.
kio (KSycoca): WARNING: Outdated database found
kio (KSycoca): WARNING: Found version 75, expecting version 79 or higher.
kio (KSycoca): WARNING: Outdated database found
terminate called after throwing an instance of 'std::bad_alloc'
  what():  St9bad_alloc
KCrash: Application 'k3b' crashing...
...
...
(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
...
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 1457357344 (LWP 8618)]
(no debugging symbols found)
...
(no debugging symbols found)
0x56a4a1de in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#0  0x56a4a1de in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#1  0x55f32d0c in KCrash::defaultCrashHandler () from
/usr/lib/libkdecore.so.4
#2  0xffffe500 in ?? ()
#3  0x00000006 in ?? ()
#4  0x0000005b in ?? ()
#5  0x00000000 in ?? ()
#6  0x0000002b in ?? ()
#7  0x0000002b in ?? ()
#8  0x56dafff4 in ?? () from /lib/tls/libc.so.6
#9  0x00000000 in ?? ()
#10 0xffffb9cc in ?? ()
#11 0xffffb9c4 in ?? ()
#12 0x000021aa in ?? ()
#13 0x00000006 in ?? ()
#14 0x000021aa in ?? ()
#15 0x00000000 in ?? ()
#16 0x00000000 in ?? ()
#17 0x00000000 in ?? ()
#18 0x56ca69e7 in raise () from /lib/tls/libc.so.6
#19 0x56ca831b in abort () from /lib/tls/libc.so.6
#20 0x56c1fdd3 in __gnu_cxx::__verbose_terminate_handler ()
   from /usr/lib/libstdc++.so.6
#21 0x56c1d774 in __gxx_personality_v0 () from /usr/lib/libstdc++.so.6
#22 0x56c1d7b1 in std::terminate () from /usr/lib/libstdc++.so.6
#23 0x56c1d93c in __cxa_throw () from /usr/lib/libstdc++.so.6
#24 0x56c1ddca in operator new () from /usr/lib/libstdc++.so.6
#25 0x56c1de9c in operator new[] () from /usr/lib/libstdc++.so.6
#26 0x566e013d in QString::setLength () from /usr/lib/libqt-mt.so.3
#27 0x566e87b0 in operator>> () from /usr/lib/libqt-mt.so.3
#28 0x5592d5d0 in operator>> () from /usr/lib/libkio.so.4
#29 0x559747d4 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#30 0x5591ceb0 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#31 0x55921514 in KIO::Slave::gotInput () from /usr/lib/libkio.so.4
#32 0x559216a9 in KIO::Slave::qt_invoke () from /usr/lib/libkio.so.4
#33 0x563bfc5f in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#34 0x563c05ad in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#35 0x5675120c in QSocketNotifier::activated () from /usr/lib/libqt-mt.so.3
#36 0x563e0659 in QSocketNotifier::event () from /usr/lib/libqt-mt.so.3
#37 0x56355778 in QApplication::internalNotify () from
/usr/lib/libqt-mt.so.3
#38 0x56355996 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#39 0x55f579fc in KApplication::notify () from /usr/lib/libkdecore.so.4
#40 0x562e5665 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#41 0x56346b81 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/libqt-mt.so.3
#42 0x562f93d0 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#43 0x5636dea2 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#44 0x56354335 in QApplication::enter_loop () from /usr/lib/libqt-mt.so.3
#45 0x56574fb6 in QDialog::exec () from /usr/lib/libqt-mt.so.3
#46 0x55d1dfb7 in KMessageBox::createKMessageBox () from
/usr/lib/libkdeui.so.4
#47 0x55d1e6cb in KMessageBox::createKMessageBox () from
/usr/lib/libkdeui.so.4
#48 0x55d46f8d in KMessageBox::sorryWId () from /usr/lib/libkdeui.so.4
#49 0x55d4706d in KMessageBox::sorry () from /usr/lib/libkdeui.so.4
#50 0x5599f65b in KMimeType::errorMissingMimeType () from
/usr/lib/libkio.so.4
#51 0x559e26ee in KMimeType::buildDefaultType () from /usr/lib/libkio.so.4
#52 0x559e2af7 in KMimeType::mimeType () from /usr/lib/libkio.so.4
#53 0x559ecd40 in KFileItem::KFileItem () from /usr/lib/libkio.so.4
#54 0x08090c9e in QValueList<KURL>::detachInternal ()
#55 0x08090daa in QValueList<KURL>::detachInternal ()
#56 0x080958aa in endl ()
#57 0x0809b1ab in QValueList<int>::detachInternal ()
#58 0x0809ba3a in QValueList<int>::detachInternal ()
#59 0x0808c057 in QValueListPrivate<QString>::QValueListPrivate ()
#60 0x0808c8d9 in QValueListPrivate<QString>::QValueListPrivate ()
#61 0x563bfc5f in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#62 0x567505a5 in QSignal::signal () from /usr/lib/libqt-mt.so.3
#63 0x563ddb30 in QSignal::activate () from /usr/lib/libqt-mt.so.3
#64 0x563e5444 in QSingleShotTimer::event () from /usr/lib/libqt-mt.so.3
#65 0x56355778 in QApplication::internalNotify () from
/usr/lib/libqt-mt.so.3
#66 0x56355996 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#67 0x55f579fc in KApplication::notify () from /usr/lib/libkdecore.so.4
#68 0x562e5665 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#69 0x56346a44 in QEventLoop::activateTimers () from /usr/lib/libqt-mt.so.3
#70 0x562f93f8 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#71 0x5636dea2 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#72 0x5636ddcb in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#73 0x56354305 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#74 0x0809f283 in QPtrList<K3bPlugin>::~QPtrList ()
#75 0x56c91ec0 in __libc_start_main () from /lib/tls/libc.so.6
#76 0x08087001 in ?? ()
Comment 1 Francois Marier 2006-03-10 20:38:10 UTC
It seems to be fixed in current K3b versions.  At least I can't reproduce this bug anymore on my machine and another Debian user (Martin Orr <martin@martinorr.name>) has reported success with this.