Bug 114540 - versioning of images in digikam
Summary: versioning of images in digikam
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Versioning (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist with 30 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-16 23:40 UTC by Sorin Milutinovici
Modified: 2022-02-02 05:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 6.3.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sorin Milutinovici 2005-10-16 23:40:17 UTC
Version:            (using KDE KDE 3.4.2)
Installed from:    Gentoo Packages
OS:                Linux

I tend to keep an unaltered copy of all my images and all processing is done in various versions. A versioning system will be very usefull for me and I hope also for other people. This is how I think it should work:

All images, when imported into digikam should receive a version number (i.e. 1).
Right click on a thumbnail should present a new option: Create a new version of this image

A dialog should pop up with the following:

1. Name of the version
2. Description of the version 
3. Version number (automatically incremented as new version of the same image are added).
4. Should we keep all additional info (e.g. tags) in the new version?
5. Location of the new image (same album/folder, work album)

When confirmed, an exact copy of the image should be created with an automatically generated name. This new image can then be edited with gimp or other tools. 

A new dialog - image history or image versions - should be added that will present all versions of an image together with the original. The advanced search tool should have also the capability to specify versions - I want to find all images in album "Houses" with the tag "Red roofs" versions 2 and 3.
Comment 1 deech 2005-11-15 09:07:30 UTC
I just started using digikam and sofar i love it. One thing I absolutely miss is versioning. So I second the request above for versioning :) 
I also want my originals to be kept save always and not be overwritten (even when i edit the original, it should be automatically saved as a version). 

Based on the above suggested way of work, this would mean that:
- i can make a new version myself and edit it
- or whenever i edit the original picture that was imported by Digikam (it is not a version created by digikam) it would automatically save it as a new version of the original and thus not apply the changes to the original. 

As an extra, what would also be cool is if i could see the changes applied to a certain version. For example, for a certain version it lists: 
Performed actions:
- Unsharp mask (with values)
- changed Levels (with values)
- changed to B/W
- cropped picture
- added frame
- etc

Hope this makes sense to you guys! Thanks for a great product! 
Comment 2 Gilles Schintgen 2005-12-23 17:14:05 UTC
There's a lengthy discussion of similar features at bug 103350. This bug could perhaps even be marked as a duplicate of 103350.
Comment 3 Joern Ahrens 2005-12-23 23:52:00 UTC

*** This bug has been marked as a duplicate of 103350 ***
Comment 4 caulier.gilles 2019-08-13 20:51:14 UTC
Fixed with bug #103350