Bug 114313 - crash when searching imap folder
Summary: crash when searching imap folder
Status: RESOLVED DUPLICATE of bug 113885
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.8.2
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-13 05:51 UTC by jeff pitman
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jeff pitman 2005-10-13 05:51:32 UTC
Version:           1.8.2 (using KDE 3.4.2-1.2.fc4.kde, Fedora)
Compiler:          Target: i386-redhat-linux
OS:                Linux (i686) release 2.6.13-1.1526_FC4

When doing a search on a local imap server, kmail will randomly crash. I cannot establish a direct way to reproduce this problem. Maybe an audit of KMFolder::open() to see if there are any possibilities for Null Pointers would be good.  If I have a solid set of steps to reproduce, I'll post a reply.

Stacktrace:

[KCrash handler]
#4  0x07024fcb in KMFolder::open () from /usr/lib/libkmailprivate.so
#5  0x0727d52f in KMFolderSearch::addSerNum ()
   from /usr/lib/libkmailprivate.so
#6  0x07299cc4 in KMFolderSearch::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#7  0x04bb75e4 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#8  0x0705d356 in KMSearch::found () from /usr/lib/libkmailprivate.so
#9  0x07108ef3 in KMSearch::slotSearchFolderResult ()
   from /usr/lib/libkmailprivate.so
#10 0x071090c8 in KMSearch::qt_invoke () from /usr/lib/libkmailprivate.so
#11 0x04bb75e4 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#12 0x0705a223 in FolderStorage::searchResult ()
   from /usr/lib/libkmailprivate.so
#13 0x0705a296 in KMFolderImap::slotSearchDone ()
   from /usr/lib/libkmailprivate.so
#14 0x072afd02 in KMFolderImap::qt_invoke () from /usr/lib/libkmailprivate.so
#15 0x04bb75e4 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#16 0x0705dd10 in KMail::SearchJob::searchDone ()
   from /usr/lib/libkmailprivate.so
#17 0x07266482 in KMail::SearchJob::slotSearchFolderComplete ()
   from /usr/lib/libkmailprivate.so
#18 0x072a3a03 in KMail::SearchJob::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#19 0x04bb7547 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#20 0x0705bce8 in KMFolderImap::folderComplete ()
   from /usr/lib/libkmailprivate.so
#21 0x071f426e in KMFolderImap::getMessagesResult ()
   from /usr/lib/libkmailprivate.so
#22 0x071f42d2 in KMFolderImap::slotGetLastMessagesResult ()
   from /usr/lib/libkmailprivate.so
#23 0x072afe80 in KMFolderImap::qt_invoke () from /usr/lib/libkmailprivate.so
#24 0x04bb75e4 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#25 0x05edab60 in KIO::Job::result () from /usr/lib/libkio.so.4
#26 0x05f2aec3 in KIO::Job::emitResult () from /usr/lib/libkio.so.4
#27 0x05f2b00a in KIO::SimpleJob::slotFinished () from /usr/lib/libkio.so.4
#28 0x05f2b70d in KIO::TransferJob::slotFinished () from /usr/lib/libkio.so.4
#29 0x05f2cc4f in KIO::TransferJob::qt_invoke () from /usr/lib/libkio.so.4
#30 0x04bb75e4 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#31 0x04bb7aa4 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#32 0x05ed6170 in KIO::SlaveInterface::finished () from /usr/lib/libkio.so.4
#33 0x05f448dd in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#34 0x05eec465 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#35 0x05ef0a00 in KIO::Slave::gotInput () from /usr/lib/libkio.so.4
#36 0x05ef0b95 in KIO::Slave::qt_invoke () from /usr/lib/libkio.so.4
#37 0x04bb75e4 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#38 0x04bb7c18 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#39 0x04f30e46 in QSocketNotifier::activated ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#40 0x04bd7225 in QSocketNotifier::event ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#41 0x04b5281d in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#42 0x04b5319c in QApplication::notify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#43 0x052de197 in KApplication::notify () from /usr/lib/libkdecore.so.4
#44 0x04b46239 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#45 0x04afb0b0 in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#46 0x04b6af52 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#47 0x04b6ae76 in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#48 0x04b521e9 in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#49 0x0805a377 in ?? ()
#50 0x0030ad5f in __libc_start_main () from /lib/libc.so.6
#51 0x08057ec1 in ?? ()
Comment 1 Tommi Tervo 2005-10-13 11:22:27 UTC

*** This bug has been marked as a duplicate of 113885 ***