Bug 112931 - select text then delete causes a crash
Summary: select text then delete causes a crash
Status: RESOLVED DUPLICATE of bug 105258
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-20 09:33 UTC by Daryl Dusheiko
Modified: 2005-09-29 20:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daryl Dusheiko 2005-09-20 09:33:59 UTC
Version:           3.2.1 (using KDE KDE 3.4.1)
Installed from:    Gentoo Packages
Compiler:          gcc (GCC) 3.4.4 (Gentoo 3.4.4-r1, ssp-3.4.4-1.0, pie-8.7.8) 
OS:                Linux

I select a line of text then press delete, go down a few lines select a few more lines press delete. Do this one more time then Kdev crashes. Does this alwasys in the same place on more than one PC.

Below is the backtrace:
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 8052)]
[New Thread 32769 (LWP 8053)]
[KCrash handler]
#6  0xb6b5e88e in QGArray::find () from /usr/qt/3/lib/libqt-mt.so.3
#7  0xb53a9aae in KateCodeFoldingTree::removeEnding ()
   from /usr/kde/3.4/lib/kde3/libkatepart.so
#8  0xb53ad1b9 in KateCodeFoldingTree::cleanupUnneededNodes ()
   from /usr/kde/3.4/lib/kde3/libkatepart.so
#9  0xb53ad6d2 in KateCodeFoldingTree::updateLine ()
   from /usr/kde/3.4/lib/kde3/libkatepart.so
#10 0xb531c0bb in KateBuffer::doHighlight ()
   from /usr/kde/3.4/lib/kde3/libkatepart.so
#11 0xb531d000 in KateBuffer::editEnd ()
   from /usr/kde/3.4/lib/kde3/libkatepart.so
#12 0xb534c214 in KateDocument::editEnd ()
   from /usr/kde/3.4/lib/kde3/libkatepart.so
#13 0xb53574ab in KateDocument::removeSelectedText ()
   from /usr/kde/3.4/lib/kde3/libkatepart.so
#14 0xb5354745 in KateDocument::del ()
   from /usr/kde/3.4/lib/kde3/libkatepart.so
#15 0xb53af9e2 in KateViewInternal::doDelete ()
   from /usr/kde/3.4/lib/kde3/libkatepart.so
#16 0xb5396663 in KateView::keyDelete ()
   from /usr/kde/3.4/lib/kde3/libkatepart.so
#17 0xb5395829 in KateView::qt_invoke ()
   from /usr/kde/3.4/lib/kde3/libkatepart.so
#18 0xb68aaa76 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#19 0xb68ab1a0 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#20 0xb717e9a9 in KAction::activated () from /usr/kde/3.4/lib/libkdeui.so.4
#21 0xb717f412 in KAction::slotActivated () from /usr/kde/3.4/lib/libkdeui.so.4
#22 0xb718423c in KAction::qt_invoke () from /usr/kde/3.4/lib/libkdeui.so.4
#23 0xb68aaa76 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#24 0xb68ab1a0 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#25 0xb6f25f69 in KAccelPrivate::menuItemActivated ()
   from /usr/kde/3.4/lib/libkdecore.so.4
#26 0xb6f27031 in KAccelPrivate::eventFilter ()
   from /usr/kde/3.4/lib/libkdecore.so.4
#27 0xb68a7fd8 in QObject::activate_filters () from /usr/qt/3/lib/libqt-mt.so.3
#28 0xb68a809d in QObject::event () from /usr/qt/3/lib/libqt-mt.so.3
#29 0xb68e18e9 in QWidget::event () from /usr/qt/3/lib/libqt-mt.so.3
#30 0xb684a43e in QApplication::internalNotify ()
   from /usr/qt/3/lib/libqt-mt.so.3
#31 0xb684ac6d in QApplication::notify () from /usr/qt/3/lib/libqt-mt.so.3
#32 0xb6e903dc in KApplication::notify () from /usr/kde/3.4/lib/libkdecore.so.4
#33 0xb6f24c23 in KAccelEventHandler::x11Event ()
   from /usr/kde/3.4/lib/libkdecore.so.4
#34 0xb6e93d52 in KApplication::x11EventFilter ()
   from /usr/kde/3.4/lib/libkdecore.so.4
#35 0xb67d7a9d in qt_set_x11_event_filter () from /usr/qt/3/lib/libqt-mt.so.3
#36 0xbff8e180 in ?? ()
#37 0x00000001 in ?? ()
#38 0xb6cec94c in ?? () from /usr/qt/3/lib/libqt-mt.so.3
#39 0xb6cec94c in ?? () from /usr/qt/3/lib/libqt-mt.so.3
#40 0x0000006b in ?? ()
#41 0xbff8e028 in ?? ()
#42 0xb67e520e in QApplication::x11ProcessEvent ()
   from /usr/qt/3/lib/libqt-mt.so.3
#43 0x00000020 in ?? ()
#44 0x0815a658 in ?? ()
#45 0x00000000 in ?? ()
#46 0x0814b500 in ?? ()
#47 0x0817adf0 in ?? ()
#48 0x08179f88 in ?? ()
#49 0x08198ee0 in ?? ()
#50 0x00000000 in ?? ()
#51 0x00000000 in ?? ()
#52 0x00000001 in ?? ()
#53 0x08084dd8 in ?? ()
#54 0x00000000 in ?? ()
#55 0x00000000 in ?? ()
#56 0x081a1478 in ?? ()
#57 0x08163fd0 in ?? ()
#58 0x08159050 in ?? ()
#59 0x08053c00 in typeinfo name for ShellExtension ()
#60 0xb7024a64 in vtable for KApplication ()
   from /usr/kde/3.4/lib/libkdecore.so.4
#61 0x0815aab8 in ?? ()
#62 0x0815a918 in ?? ()
#63 0x08187a48 in ?? ()
#64 0xb6d037a8 in vtable for QCString () from /usr/qt/3/lib/libqt-mt.so.3
#65 0x0815a5c0 in ?? ()
#66 0xbff8e410 in ?? ()
#67 0x0815a5d0 in ?? ()
#68 0x08084e18 in ?? ()
#69 0x00000128 in ?? ()
#70 0x000000ff in ?? ()
#71 0xb630b541 in __pthread_alt_lock () from /lib/libpthread.so.0
#72 0x080792d8 in ?? ()
Comment 1 Becheru Petru-Ioan 2005-09-20 12:32:29 UTC
I think it is a Kate bug; not a KDevelop; try kdevelop with another editor (see Settings->Configure KDevelop->Editor) and see if KDevelop is responsible;

It is not happening to me(KDevelop 3.2.2 kate 2.4.1); try to update and see if the bug exists

Comment 2 Becheru Petru-Ioan 2005-09-20 12:34:39 UTC
btw update your kde (u have 3.4.1 ) 3.4.2 launched
Comment 3 Jens Dagerbo 2005-09-20 14:30:49 UTC
You can try doing the same thing to the same file in Kate/KWrite (outside KDevelop). The backtrace is clearly going through kate though. Reassigning.
Comment 4 Christoph Cullmann 2005-09-29 20:01:58 UTC

*** This bug has been marked as a duplicate of 105258 ***