Bug 112872 - OpenGL screensavers use only part of the screen with MergedFB
Summary: OpenGL screensavers use only part of the screen with MergedFB
Status: RESOLVED DUPLICATE of bug 66492
Alias: None
Product: kscreensaver
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kscreensaver bugs tracking
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-19 07:46 UTC by Shawn Rutledge
Modified: 2008-05-19 17:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shawn Rutledge 2005-09-19 07:46:53 UTC
Version:            (using KDE KDE 3.4.1)
Installed from:    Compiled From Sources
Compiler:          gcc (GCC) 3.3.5-20050130 (Gentoo 3.3.5.20050130-r1, ssp-3.3.5.20050130-1, pie-8.7.7.1) 
OS:                Linux

Euphoria is a good one to test this with, because it usually fills up the whole screen pretty well.  I have two monitors running in MergedFB mode on a FireGL 8800 card, so my desktop is 2560x1024.  When I select Euphoria and hit "test", I see it only in a vertical strip along the left side of the left monitor; I'd say less than half of the left screen but more than 1/3.  The rest of the left screen and all of the right screen are black.  With other GL screen savers, the whole screen stays black most of the time because the screensaver probably isn't drawing anything into that left edge of the display.

I can start glxgears in a window and drag it anywhere on both screens, and get similar frame rates.  glxinfo says DRI is enabled.  Plain old xscreensaver's gl simulations all work well.

2D screensavers work fine and span across both displays.
Comment 1 Arthur B. 2005-12-22 09:34:53 UTC
This is a me too. I have a single 1280x768 display with and i810.
Euphoria runs only in the first third of the screen ( yet if set in kaleidoscope mode it does use the full screen... weird )
Comment 2 Oswald Buddenhagen 2007-05-12 12:29:48 UTC

*** This bug has been marked as a duplicate of 66492 ***