Bug 112264 - wish: Recognise text's language, or at least try another language, if there are too many wrong words
Summary: wish: Recognise text's language, or at least try another language, if there a...
Status: RESOLVED DUPLICATE of bug 66516
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kspell (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR wishlist
Target Milestone: ---
Assignee: Zack Rusin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-08 20:01 UTC by S. Burmeister
Modified: 2009-06-26 07:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S. Burmeister 2005-09-08 20:01:33 UTC
Version:            (using KDE KDE 3.4.2)
Installed from:    SuSE RPMs
OS:                Linux

A lot of people use at least two languages on a regular basis for email or on the internet. Currently, for one of those, spellchecking fails. Switching each time does not seem to be the best option.

Best would obviously be that the spellchecker would automatically regognise the language used, yet that might be a bit tricky.

Maybe one could set a fallback-language in kcontrol, so that if there are too many wrong words in a text, the spellchecker checks whether there are significantly less wrong words when using that fallback-language set in kcontrol. If so, it would change the language for the current text without actually changing the default language.
Comment 1 Thiago Macieira 2005-09-09 06:35:32 UTC
Doesn't look specific to Kopete.
Comment 2 S. Burmeister 2005-09-09 07:58:08 UTC
Yep, thanks for re-assigning. Maybe the component should have kopete in its name, as it only states: Spell Check Plugin. How should one know whether it is a plugin for all apps that want to use specllchecking, or just for kopete?
Comment 3 Christoph Feck 2009-06-26 07:01:27 UTC

*** This bug has been marked as a duplicate of bug 66516 ***