Bug 111479 - error detection for CORBA exceptions
Summary: error detection for CORBA exceptions
Status: RESOLVED DUPLICATE of bug 111341
Alias: None
Product: kdevelop
Classification: Unclassified
Component: Problem reporter (show other bugs)
Version: 3.2.0
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-25 13:27 UTC by Luke Tucker
Modified: 2006-04-16 00:05 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luke Tucker 2005-08-25 13:27:25 UTC
Version:           3-3.2.0-8 (using KDE KDE 3.4.0)
Installed from:    SuSE RPMs
Compiler:          gcc-3.3.5-5 
OS:                Linux

The following is a perfectly valid definition of a CORBA exception in a .idl file however it is highlighted as an error under the "Problems" tab:

interface myInterface
{
  // EXCEPTIONS
  exception myException{};
  
  .
  .
  .
}
Comment 1 Luke Tucker 2005-08-25 13:36:12 UTC
In addition to this, when you remove the "error" the list of errors under the problems tab does not refresh as it does with C++ files. I am starting to get the impression that KDevelop doesn't yet fully understand CORBA and maybe an overhaul of the syntax parser for idl is required (see also #111341).

kdevelop is a great application by the way! I have only been using it for a week and I am very, very impressed.
Comment 2 Jens Dagerbo 2006-04-16 00:05:51 UTC
As the parser isn't meant to run on IDL files at all, I think we can call this a dupe of bug #111341.

*** This bug has been marked as a duplicate of 111341 ***