Bug 110899 - All DigiKam Image tools don't work in showFoto
Summary: All DigiKam Image tools don't work in showFoto
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Showfoto-Plugins (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-16 18:37 UTC by Tung NGUYEN
Modified: 2022-02-04 22:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.7.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tung NGUYEN 2005-08-16 18:37:47 UTC
Version:           0.2.0 (using KDE KDE 3.4.2)
Installed from:    Compiled From Sources
OS:                Linux

- Run showFoto and open a JPG file.
- Open Filters->Black & White...
- In the "Convert to Black & White" dialog box, the preview area is empty (no preview of the photo) and if I try to apply a Black & White filter and click "OK", nothing happens.

I have the same problem for all the ImagePlugins, each time the preview area is empty and I can do nothing.

All my Settings->Configure showFoto...->Image Plugins are checked.

If I open the same file in DigiKam with the Image Editor, all the plugins work fine.

I have also made regression tests in version 0.7.3-beta2 and all the plugins work fine in the Image Editor and showFoto.
Comment 1 caulier.gilles 2005-08-16 21:43:01 UTC
Please, give me all message when you run showfoto from a console. I suspect a problem with your imlib installation...

Gilles Caulier
Comment 2 Tung NGUYEN 2005-08-16 22:24:12 UTC
Bonsoir Gilles, thank you in advance for your response.

here are the messages:
=====================
[anonyme@localhost ~]$ showfoto Photo-001.jpg
showfoto: ImagePlugin_Core plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_Core
showfoto: ImagePlugin_RainDrop plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_RainDrop
showfoto: ImagePlugin_InPainting plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_InPainting
showfoto: ImagePlugin_Infrared plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_Infrared
showfoto: ImagePlugin_Texture plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_Texture
showfoto: ImagePlugin_Border plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_Border
showfoto: ImagePlugin_OilPaint plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_OilPaint
showfoto: ImagePlugin_InsertText plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_InsertText
showfoto: ImagePlugin_Emboss plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_Emboss
showfoto: ImagePlugin_Unsharp plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_Unsharp
showfoto: ImagePlugin_AdjustLevels plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_AdjustLevels
showfoto: ImagePlugin_ShearTool plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_ShearTool
showfoto: ImagePlugin_Solarize plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_Solarize
showfoto: ImagePlugin_DistortionFX plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_DistortionFX
showfoto: ImagePlugin_LensDistortion plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_LensDistortion
showfoto: ImagePlugin_FilmGrain plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_FilmGrain
showfoto: ImagePlugin_BlowUp plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_BlowUp
showfoto: ImagePlugin_Restoration plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_Restoration
showfoto: ImagePlugin_SuperImpose plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_SuperImpose
showfoto: ImagePlugin_WhiteBalance plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_WhiteBalance
showfoto: ImagePlugin_BlurFX plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_BlurFX
showfoto: ImagePlugin_Despeckle plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_Despeckle
showfoto: ImagePlugin_AntiVignetting plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_AntiVignetting
showfoto: ImagePlugin_AdjustCurves plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_AdjustCurves
showfoto: ImagePlugin_FreeRotation plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_FreeRotation
showfoto: ImagePlugin_Perspective plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_Perspective
showfoto: ImagePlugin_ChannelMixer plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_ChannelMixer
showfoto: ImagePlugin_Charcoal plugin loaded
showfoto: ImagePluginLoader: Loaded plugin ImagePlugin_Charcoal
QMultiInputContext::changeInputMethod(): index=0, slave=xim

# When I try to apply the Filters->Black & White..., I have this:
QMultiInputContext::changeInputMethod(): index=0, slave=xim
***** Imlib2 Developer Warning ***** :
        This program is calling the Imlib call:

        imlib_image_has_alpha();

        With the parameter:

        image

        being NULL. Please fix your program.
QMultiInputContext::changeInputMethod(): index=0, slave=xim
***** Imlib2 Developer Warning ***** :
        This program is calling the Imlib call:

        imlib_image_has_alpha();

        With the parameter:

        image

        being NULL. Please fix your program.
showfoto: WARNING: ImageFilters::channelMixerImage: no image data available!

# When I try to apply the Filters->Raindrops..., I have this:
***** Imlib2 Developer Warning ***** :
        This program is calling the Imlib call:

        imlib_image_has_alpha();

        With the parameter:

        image

        being NULL. Please fix your program.
QMultiInputContext::changeInputMethod(): index=0, slave=xim
QImage::smoothScale: Image is a null image
*******************************************************************

I use libimlib2_1 from MandrivaLinux.

Comment 3 caulier.gilles 2005-08-16 22:38:54 UTC
Me too, and i develop digiKam under mandriva without problem. Witch verion of package you have installed ?

This error have already reported to digikam-devel ML. I think it's an problem of imlib2-modules install (missing certainly). Try to check if you have installed all imlib2 RPM with mcc.

Gilles
Comment 4 Tung NGUYEN 2005-08-16 23:29:42 UTC
I have checked my environnment with the lastest rpm releases installed with MCC:

- MandrivaLinux Cooker (08/14/2005).

- digikam-0.7.3-1mdk
- digikamimageplugins-0.7.3-1mdk
- libdigikam0-0.7.3-1mdk

- kipi-plugins-0.1.0-0.beta2.5mdk
- libkipi0-0.1.1-4mdk

- libimlib2_1-1.2.1-1mdk
- libimlib2_1-devel-1.2.1-1mdk
- libimlib2_1-filters-1.2.1-1mdk
- libimlib2_1-loaders-1.2.1-1mdk

Perhaps, MandrivaLinux Cooker is not a good example, I am going to test digiKam 0.7.3 under MandrivaLinux Limited Edition 2005 and give you the results.

---
Tung.
Comment 5 Tung NGUYEN 2005-08-17 12:03:41 UTC
Gilles,

I have made a fresh installation of MandrivaLinux Limited Edition 2005 and installed the following rpms to test the problem:

1) - digikam-0.7.3-2mdk             (lastest Cooker rpm).
   - digikamimageplugins-0.7.3-1mdk (lastest Cooker rpm).
   - libdigikam0-0.7.3-2mdk         (lastest Cooker rpm).
 
   => the problem remain the same, I always have the same Imlib2 messages.

2) - I have compiled digikam-0.7.3 from source tarball and run showFoto.

   => the problem remain the same, I always have the same Imlib2 messages.

3) - I have compiled digikam-0.7.3-beta2 from source tarball and run showFoto.

   => I don't understand why but the ImagePlugins work perfectly in showFoto with the same environment (I have the same situation under MandrivaLinux Cooker where 0.7.3-beta2 ImagePlugins work fine).
   
The Imlib rpms installed under MandrivaLinux Limited Edition 2005 are:

imlib-1.9.14-11mdk
libimlib1-1.9.14-11mdk
libimlib2_1-1.2.0-3mdk
libimlib2_1-devel-1.2.0-3mdk
libimlib2_1-filters-1.2.0-3mdk
libimlib2_1-loaders-1.2.0-3mdk
Comment 6 Tung NGUYEN 2005-11-02 12:56:22 UTC
Gilles,

In the last package made by Mandriva for Digikam 0.8.0-beta2, the ImagePlugins are correctly loaded in ShowFoto (I can see them in the preview area) and I don't have the message error about Imlib anymore. If you want, you can close this bug report.

---
Tung.
Comment 7 caulier.gilles 2005-11-02 12:58:41 UTC
OK thanks for your very constructive bug reports. You provides an exelent job !

Gilles
Comment 8 Marcus Popp 2006-06-07 22:36:34 UTC
same problem here, digikam preview is fine - showfoto (0.9.0-svn) fails with:

-------------------------------------------------------------------------
showfoto: Preview lensdistortion failed...
***** Imlib2 Developer Warning ***** :
        This program is calling the Imlib call:

        imlib_image_has_alpha();

        With the parameter:

        image

        being NULL. Please fix your program.
showfoto: LensDistortion::End of computation !!! ... ( 0 s )
showfoto: LensDistortion::No valid image data !!! ...
showfoto: Preview lensdistortion failed...
***** Imlib2 Developer Warning ***** :
        This program is calling the Imlib call:

        imlib_image_has_alpha();

        With the parameter:

        image

        being NULL. Please fix your program.
showfoto: Despeckle::No valid image data !!! ...
showfoto: Preview despeckle failed...
~ScimInputContextPlugin()
-------------------------------------------------------------------------

compiled with './configure --enable-debug=full'
kubuntu 6.06 - kde 3.5.3
$ dpkg -l | grep imlib
gdk-imlib1                                       1.9.14-29ubuntu1
gdk-imlib11                                      1.9.14-29ubuntu1
gdk-imlib11-dev                                  1.9.14-29ubuntu1
giblib1                                          1.2.4-2
imlib-base                                       1.9.14-29ubuntu1
libimlib2                                        1.2.1-2
libimlib2-dev                                    1.2.1-2

hth,
Marcus.
Comment 9 Marcus Popp 2006-06-07 22:43:59 UTC
I forgot to mention that i'm running amd64 and that digikam crashes at the moment. If I try to use some plugins. But I have to investigate a little bit more and fill a bug report.
Comment 10 caulier.gilles 2006-06-07 23:11:58 UTC
MArcus : imlib2 error messages cannot come from 0.9.0 version because svn implementation don't use imlib2 now !

i suspect a both installation (0.9.0 and 0.8.x). 0.8.x use imlib2 !

You cannot use image plugins from 0.8.x with digikam 0.9.0 ! 

Gilles

Comment 11 caulier.gilles 2017-06-29 13:21:43 UTC
Since digiKam 5.2.0, all image editor plugins have been removed and embed as well in image editor/showfoto implementation. There is no more run-time loading of plugin libraries.

Gilles Caulier