Bug 110199 - Incorrect, incomplte render of two column pdf documents
Summary: Incorrect, incomplte render of two column pdf documents
Status: RESOLVED FIXED
Alias: None
Product: kpdf
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Albert Astals Cid
URL:
Keywords:
: 111156 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-08-05 01:57 UTC by M S
Modified: 2015-11-10 06:33 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
The pdf file which does not render correctly (917.95 KB, application/pdf)
2005-08-05 02:04 UTC, M S
Details
Screenshot of correct rendering (171.64 KB, image/jpeg)
2005-08-05 02:06 UTC, M S
Details
Screenshot of kpdf rendering (118.54 KB, image/jpeg)
2005-08-05 02:07 UTC, M S
Details

Note You need to log in before you can comment on or make changes to this bug.
Description M S 2005-08-05 01:57:03 UTC
Version:            (using KDE KDE 3.4.2)
Installed from:    Gentoo Packages
Compiler:          gcc version 3.4.4 (Gentoo 3.4.4, ssp-3.4.4-1.0, pie-8.7.8) used heavy optimization: CFLAGS="-march=pentium4 -mtune=pentium4 -pipe -O3 -fweb -fforce-addr -momit-leaf-frame-pointer -fomit-frame-pointer -ffast-math -ftracer" CXXFLAGS="$CFLAGS -fvisibility-inlines-hidden"
OS:                Linux

Hi,
First of all, great work on kpdf. It is an incredible software. I used to use gv earlier or acroread, but now i use kpdf almost 100%.

Using Latex (from package tetex-2.0.2), I noticed that kpdf does not render two column documents properly. In the attached pdf file, check out the figures on page  12-15. Some of the text and materials after the figures is missing. 

On page 12, the text after the figure is missing, and on page 14, first 4 out of 6 figures are visible.

By the look of it, this is a memory or buffer problem. In printing also, the same pdf printed incorrectly  when the printer queue was large. Upon emptying the queue it printed.

In summary
1. Reproducible: Always
2. How to reproduce: open the attached techrep.pdf
Comment 1 M S 2005-08-05 02:04:34 UTC
Created attachment 12083 [details]
The pdf file which does not render correctly

The two column pdf file which does not render correctly. The one column version
renders perfectly
Comment 2 M S 2005-08-05 02:06:15 UTC
Created attachment 12084 [details]
Screenshot of correct rendering
Comment 3 M S 2005-08-05 02:07:20 UTC
Created attachment 12085 [details]
Screenshot of kpdf rendering
Comment 4 Thiago Macieira 2005-08-07 06:04:36 UTC
I can reproduce this.
Comment 5 Albert Astals Cid 2005-08-18 00:42:07 UTC
SVN commit 450335 by aacid:

Disable zlib based decoder from poppler as it cause bugs
BUGS: 110199


 M  +1 -1      Makefile.am  
 M  +1 -2      Stream.cc  
 M  +1 -1      Stream.h  


--- branches/KDE/3.4/kdegraphics/kpdf/xpdf/xpdf/Makefile.am #450334:450335
@@ -4,7 +4,7 @@
 libxpdf_la_LIBADD = $(LIB_X11) $(LIBFREETYPE_LIBS) $(LIBPAPER_LIBS) $(XFT_LIBS) $(LIBJPEG) ../goo/libgoo.la ../fofi/libfofi.la ../splash/libsplash.la 
 libxpdf_la_SOURCES = Annot.cc Array.cc BuiltinFont.cc BuiltinFontTables.cc \
      Catalog.cc CharCodeToUnicode.cc CMap.cc Decrypt.cc Dict.cc DCTStream.cc \
-     FontEncodingTables.cc FlateStream.cc Function.cc Gfx.cc \
+     FontEncodingTables.cc Function.cc Gfx.cc \
      GfxFont.cc GfxState.cc GlobalParams.cc JArithmeticDecoder.cc \
      JBIG2Stream.cc Lexer.cc Link.cc NameToCharCode.cc Object.cc Outline.cc \
      OutputDev.cc PDFDoc.cc PDFDocEncoding.cc PSTokenizer.cc \
--- branches/KDE/3.4/kdegraphics/kpdf/xpdf/xpdf/Stream.cc #450334:450335
@@ -33,7 +33,6 @@
 #include "JPXStream.h"
 #include "Stream-CCITT.h"
 #include "DCTStream.h"
-#include "FlateStream.h"
 
 #ifdef __DJGPP__
 static GBool setDJSYSFLAGS = gFalse;
@@ -3179,6 +3178,7 @@
 GBool DCTStream::isBinary(GBool /*last*/) {
   return str->isBinary(gTrue);
 }
+#endif
 
 //------------------------------------------------------------------------
 // FlateStream
@@ -3710,7 +3710,6 @@
   codeSize -= bits;
   return c;
 }
-#endif
 
 //------------------------------------------------------------------------
 // EOFStream
--- branches/KDE/3.4/kdegraphics/kpdf/xpdf/xpdf/Stream.h #450334:450335
@@ -637,6 +637,7 @@
   int readMarker();
   int read16();
 };
+#endif
 
 //------------------------------------------------------------------------
 // FlateStream
@@ -712,7 +713,6 @@
   int getHuffmanCodeWord(FlateHuffmanTab *tab);
   int getCodeWord(int bits);
 };
-#endif
 
 //------------------------------------------------------------------------
 // EOFStream
Comment 6 Albert Astals Cid 2005-08-20 16:35:38 UTC
*** Bug 111156 has been marked as a duplicate of this bug. ***
Comment 7 Reynaldo 2015-11-10 06:32:05 UTC
*** Removed by KDE Sysadmin due to violation of abuse policies ***
Comment 8 Reynaldo 2015-11-10 06:33:32 UTC
*** Removed by KDE Sysadmin due to violation of abuse policies ***