Bug 109555 - Makefile.cvs: automake version detecting failed
Summary: Makefile.cvs: automake version detecting failed
Status: RESOLVED NOT A BUG
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-24 15:27 UTC by Andrew Gaydenko
Modified: 2006-06-11 12:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Gaydenko 2005-07-24 15:27:34 UTC
Version:           from current svn (using KDE KDE 3.4.1)
Installed from:    Gentoo Packages
OS:                Linux

I'm not sure this is the amaroK bug. Please, retarget the issue if need.

Trying to build the amaroK app using amarok-svn.ebuild from here

http://wordpress.jordswart.org/archives/8

(unfortunately amaroK's official site hasn't svn ebuild)

I get the error shown below. It seems like the error reason was commited into 'admin' rather in 'amarok' svn dir - there was replacement of autoconf-detect.sh with autoconf-detect.pl.

I use Gentoo ~x86 synced with portage. Of course, Gentoo default automake version is much higher rather 1.4-p6 :-) (it is 1.7.9 now).

============ build error ===========================
...
This Makefile is only for the CVS repository
This will be deleted before making the distribution

*** YOU'RE USING automake (GNU automake) 1.4-p6.
*** KDE requires automake 1.6.1 or newer
make[1]: *** [cvs] Error 1
make: *** [all] Error 2
>>> Source unpacked.
This Makefile is only for the CVS repository
This will be deleted before making the distribution

*** YOU'RE USING automake (GNU automake) 1.4-p6.
*** KDE requires automake 1.6.1 or newer
make[1]: *** [cvs] Error 1
...
Comment 1 Ian Monroe 2005-07-25 07:47:52 UTC
You are correct it is not an amaroK issue, but it is not a KDE issue either. Please report this bug to the person distributing the ebuild. If I remember correctly you have to do something like `export AUTOMAKE=1.7`, but don't quote me on that :).
Comment 2 Andrew Gaydenko 2005-07-25 11:35:38 UTC
Ian,

Thanks! I have added 

export WANT_AUTOCONF=2.5
export WANT_AUTOMAKE=1.6

lines to the begining of src_compile(), now ebuilding is OK. I'll report this to the ebuild author.
Comment 3 Andrew Gaydenko 2005-08-02 00:45:36 UTC
After moving the app to unsermake build system, used ebuild file doesn't work anymore. I have checked out unsermake, but don't know how to modify ebuild file. Will anybody be so kind to help me here?

Thanks in advance!

Comment 4 Ian Monroe 2005-08-02 03:21:48 UTC
Use any text editor.

Really this isn't the place for this at all, this is for reporting bugs, not general tech support. The amaroK or gentoo forums would be more appropriate.