Bug 109272 - gnuplot_x11 terminal slows down system
Summary: gnuplot_x11 terminal slows down system
Status: RESOLVED DUPLICATE of bug 101087
Alias: None
Product: klipper
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Esben Mose Hansen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-18 20:41 UTC by Holger Hellwig
Modified: 2006-01-30 19:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Holger Hellwig 2005-07-18 20:41:03 UTC
Version:            (using KDE KDE 3.4.1)
Installed from:    Fedora RPMs
Compiler:          gcc version 4.0.0 20050519 (Red Hat 4.0.0-8) Thread model: posix-with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-libgcj-multifile
OS:                Linux

I am running Gnuplot 4.0 (latest CVS version) under FC4.1, KDE 3.4.1. When I have the X11 output from Gnuplot in the gnuplot_x11 term window, the whole system slows down, especially text input. This slowdown is the more severe the larger the gnuplot_x11 window! When I check the system with the top command, I find that X11 eats up most of the resources, followed by kicker (!). When I do the same under Gnome, there is no problem. It is also independent on Gnuplot itself, since I find the same behavior when I start gnuplot_x11 as a standalone (with the -persist option). If the gnuplot_x11 term window is open for about 1 h, the behavior is normal again, resizing the term window again leads to the observed slowdown.
This is also independent on FC (was the same with FC3) and it was the same with KDE3.4, but not observed under KDE 3.3.
Comment 1 Thiago Macieira 2005-07-18 21:35:44 UTC
Aaron & Seli: is there anything you can do, or is the fault on gnuplot_x11?

If there's nothing you can do, please close.
Comment 2 Stephan Kulow 2005-07-19 09:27:07 UTC
I suggest you contact the gnuplot developers. If gnuplot is the one taking the load, then they might take something KDE does, really really bad. This doesn't mean, the thing KDE does is bad.
Comment 3 Holger Hellwig 2005-07-19 17:30:14 UTC
I went through the gnuplot developers already and we came to the conclusion 
that it is not gnuplot, although obviously gnuplot is triggering the bug. 
Sine the problem does not arise with Gnome (and other systems) it is at least 
strongly related to KDE. It seems that X11 plays a major role, and it might 
turn out that gnuplot_x11 can be modified, but before that I would have to 
have an idea where to start. I already tried to uninstall boost, but that is 
not doing it. The kernel is not really the culprit either, since it is rather 
independent on the actual kernel version and does not appear with the same 
kernel under different environments.
Thanks,
Holger

On Tuesday 19 July 2005 02:27, Stephan Kulow wrote:
[bugs.kde.org quoted mail]
Comment 4 Thomas Lübking 2005-07-19 18:18:43 UTC
tested, confirmed.
the problem seems to be with klipper (try to end klipper and replot)
reason: klipper constantly gets a copy of the plotwindow but don't ask me how or where to prevent this

to test:
gnuplot
> plot sin(x)
Comment 5 Thomas Lübking 2005-07-19 18:19:23 UTC
tested, confirmed.
the problem seems to be with klipper (try to end klipper and replot)
reason: klipper constantly gets a copy of the plotwindow but don't ask me how or where to prevent this

to test:
gnuplot
> plot sin(x)
Comment 6 Holger Hellwig 2005-07-19 18:26:21 UTC
Confirmed, removing Klipper solves the problem. Also that Klipper constantly  
gets a copy of the plot window.
Comment 7 Jonathan Stickel 2005-07-20 19:44:09 UTC
I also have this problem with gnuplot since KDE 3.4.  It goes away when I configure klipper to "ignore selection", but klipper is not very useful then.  I'm wondering if this is related to several other graphics and image bugs for klipper, e.g. Bug 101087.  A nice feature and possible solution would be an option to have klipper only store text, not images.
Comment 8 Lubos Lunak 2006-01-30 19:07:32 UTC

*** This bug has been marked as a duplicate of 101087 ***