Bug 107866 - crash (segfault) when editing
Summary: crash (segfault) when editing
Status: RESOLVED DUPLICATE of bug 105258
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Slackware Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 111297 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-06-21 17:59 UTC by Benoît Jacob
Modified: 2005-09-29 19:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benoît Jacob 2005-06-21 17:59:07 UTC
Version:           1.8.1 (using KDE KDE 3.4.1)
Installed from:    Slackware Packages
Compiler:          gcc 3.3.5 
OS:                Linux

Hi,

I just had a crash in kile. I was just editing a LaTeX file. At the moment of the crash, I was removing several characters with the 'delete' key on the keyboard. That was in a quite long line of text, with long $...$ and $$...$$ mathematical expressions. Could be a bug in syntax highlighting. Below is what KCrash told me. Kile was compiled from source tarball, but for the rest, I use Slackware packages. Slackware recently recompiled glibc to include support for NPTL (the Native POSIX Thread Library), if that can help.

Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1244956960 (LWP 10756)]
[KCrash handler]
#3  0xb6e4f5dd in QGArray::find () from /usr/lib/qt/lib/libqt-mt.so.3
#4  0xb58651d1 in KateCodeFoldingTree::cleanupUnneededNodes ()
   from /opt/kde/lib/kde3/libkatepart.so
#5  0xb586319d in KateCodeFoldingTree::updateLine ()
   from /opt/kde/lib/kde3/libkatepart.so
#6  0xb57d994e in KateBuffer::doHighlight ()
   from /opt/kde/lib/kde3/libkatepart.so
#7  0xb57d750d in KateBuffer::editEnd () from /opt/kde/lib/kde3/libkatepart.so
#8  0xb5803066 in KateDocument::editEnd ()
   from /opt/kde/lib/kde3/libkatepart.so
#9  0xb5802014 in KateDocument::removeText ()
   from /opt/kde/lib/kde3/libkatepart.so
#10 0xb5801dc1 in KateDocument::removeText ()
   from /opt/kde/lib/kde3/libkatepart.so
#11 0xb580d218 in KateDocument::backspace ()
   from /opt/kde/lib/kde3/libkatepart.so
#12 0xb586d942 in KateViewInternal::doBackspace ()
   from /opt/kde/lib/kde3/libkatepart.so
#13 0xb584fb95 in KateView::backspace () from /opt/kde/lib/kde3/libkatepart.so
#14 0xb584301f in KateView::qt_invoke () from /opt/kde/lib/kde3/libkatepart.so
#15 0xb6b9a1ec in QObject::activate_signal ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#16 0xb6b9a014 in QObject::activate_signal ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#17 0xb7452ebb in KAction::activated () from /opt/kde/lib/libkdeui.so.4
#18 0xb745262a in KAction::slotActivated () from /opt/kde/lib/libkdeui.so.4
#19 0xb74531a1 in KAction::qt_invoke () from /opt/kde/lib/libkdeui.so.4
#20 0xb6b9a1ec in QObject::activate_signal ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#21 0xb6b9a014 in QObject::activate_signal ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#22 0xb7208e9b in KAccelPrivate::menuItemActivated ()
   from /opt/kde/lib/libkdecore.so.4
#23 0xb72076b8 in KAccelPrivate::eventFilter ()
   from /opt/kde/lib/libkdecore.so.4
#24 0xb6b97b1e in QObject::activate_filters ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#25 0xb6b97a4c in QObject::event () from /usr/lib/qt/lib/libqt-mt.so.3
#26 0xb6bd055f in QWidget::event () from /usr/lib/qt/lib/libqt-mt.so.3
#27 0xb6b3d94f in QApplication::internalNotify ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#28 0xb6b3d444 in QApplication::notify () from /usr/lib/qt/lib/libqt-mt.so.3
#29 0xb7173585 in KApplication::notify () from /opt/kde/lib/libkdecore.so.4
#30 0xb720661b in KAccelEventHandler::x11Event ()
   from /opt/kde/lib/libkdecore.so.4
#31 0xb717967f in KApplication::x11EventFilter ()
   from /opt/kde/lib/libkdecore.so.4
#32 0xb6ac70b8 in qt_set_x11_event_filter ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#33 0xb6ad0d9b in QApplication::x11ProcessEvent ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#34 0xb6ae7e44 in QEventLoop::processEvents ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#35 0xb6b4fd08 in QEventLoop::enterLoop () from /usr/lib/qt/lib/libqt-mt.so.3
#36 0xb6b4fbb8 in QEventLoop::exec () from /usr/lib/qt/lib/libqt-mt.so.3
#37 0xb6b3dba1 in QApplication::exec () from /usr/lib/qt/lib/libqt-mt.so.3
#38 0x080fd285 in main ()
Comment 1 Benoît Jacob 2005-06-28 12:06:11 UTC
Some clarification...
the version number, 1.8.1, is that of Kile. I use KDE 3.4.1 with the version of Kwrite/Kate that comes with it.

This is most probably a bug in the syntax highlighting code for .tex files.
Comment 2 Anders Lund 2005-06-28 12:23:51 UTC
On Tuesday 28 June 2005 12:06, Benoît Jacob wrote:
> This is most probably a bug in the syntax highlighting code for .tex files.


More information please. Why do you think so? Does all files crash, or only 
some, and do you know which text they contain that causes the crash? 

Can you attach a file that causes a crash to this bug report?

Can you provide a backtrace?
Comment 3 Benoît Jacob 2005-06-28 12:49:58 UTC
> Can you provide a backtrace?

I filed a bug report here, with a backtrace :
http://bugs.kde.org/show_bug.cgi?id=107866
probably you didn't see it because it was a Kile bug report, but the Kile developer reassigned it to kate, because the backtrace says the problem occured in libkatepart.so.

My understanding is that it has crashed while updating the syntax highlighting after I removed some text with the backspace key. There were $ signs, and you know that when you remove a $ sign, that results in a large change of highlighting as text gets math mode toggled on/off.

Unfortunately I haven't been able to reproduce this bug. The crash only happened once. I can't give you more information than what I wrote in the bug report.
Comment 4 Christoph Cullmann 2005-09-29 19:34:40 UTC
*** Bug 111297 has been marked as a duplicate of this bug. ***
Comment 5 Christoph Cullmann 2005-09-29 19:35:34 UTC

*** This bug has been marked as a duplicate of 105258 ***