Bug 107554 - Enhancement Request: Desktop Window Panes
Summary: Enhancement Request: Desktop Window Panes
Status: RESOLVED DUPLICATE of bug 59338
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR wishlist with 1 vote (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-16 21:19 UTC by Chad Groneman
Modified: 2006-09-21 09:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chad Groneman 2005-06-16 21:19:03 UTC
Version:            (using KDE KDE 3.4.1)
Installed from:    SuSE RPMs
OS:                Linux

I would like to be able to create "Frames" in the active desktop, to place windows in.  

I would like this because I often find myself needing to look at multiple windows simultaneously, and rather than open them up and resize them 'till they all fit, I would rather move them into a "frame" and maximize them from there.  Even better would be to be able to drag a task from the taskbar to a frame and have it automatically maximize within the frame.  

An additional feature would be for windows to "snap" to these frames, if they were close enough.

Users would be able to define the frames by dragging a line (horizontal or vertical) which would automatically extend to the borders of another frame or the screen border.

This would save me time & a bit of frustration trying to make everything fit on the window in the way I want.
Comment 1 Jon 2006-09-11 20:38:06 UTC
It's hard to imagine what you are thinking of for an interface.  The interface I'm imagining would be that you would press some key combination and it would "reveal" the "frame borders" (that are always present, but not always visible) in a translucent color over top of the windows:

(Normal view:)

.--------Desktop----------.
|                         |
| .-------.               |
| | win 1 |               |
| |       |   .-------.   |
| '-------'   | win 2 |   |
|             |       |   |
|             |       |   |
|             '-------'   |
'-------------------------'

After pressing "reveal frames" key combination (with one frame border in place), it shows you the frame border in a translucent color:

.--------Desktop----------.
|                  :      |
| .-------.        :      |
| | win 1 |        :      |
| |       |   .----:--.   |
| '-------'   | win:2 |   |
|             |    :  |   |
|             |    :  |   |
|             '----:--'   |
'-------------------------'

and you could drag the frame borders around or create new ones by dragging from one of the edges of the screen:

.--------Desktop----------.
|           :             |
| .-------. :             |
| | win 1 | :             |
| |       | : .-------.   |
| '-------' : | win 2 |   |
|...........: |       |   |
|           : |       |   |
|           : '-------'   |
'-------------------------'

and then, while the frames are revealed, if you drag a window into one of them, it would maximize inside it:

.--------Desktop----------.
|           |             |
| .-------. |             |
| | win 1 | |             |
| |       | |    win 2    |
| '-------' |             |
|...........|             |
|           |             |
|           |             |
'-------------------------'

(then drag win 1 into the top left pane:)

.--------Desktop----------.
|           |             |
|   win 1   |             |
|           |             |
|           |    win 2    |
|           |             |
|-----------|             |
|           |             |
|           |             |
'-------------------------'

Then, after a window was maximized inside of a frame, you could "reveal frames" and drag the frame border to resize two windows at once:

.--------Desktop----------.
|       |                 |
| win 1 |                 |
|       |                 |
|       |      win 2      |
|       |                 |
|-------|                 |
|       |                 |
|       |                 |
'-------------------------'

This part would be similar to Bug 133927.
Comment 2 Lubos Lunak 2006-09-20 16:55:32 UTC

*** This bug has been marked as a duplicate of 59338 ***
Comment 3 Jon 2006-09-20 17:11:18 UTC
How is this a duplicate of "Ion-like window layout"?