Bug 107530 - kmail crash on startup
Summary: kmail crash on startup
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries IRIX
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 140720 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-06-16 14:20 UTC by Frank Van Damme
Modified: 2007-09-14 12:17 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Van Damme 2005-06-16 14:20:36 UTC
Version:            (using KDE KDE 3.4.0)
Installed from:    Unspecified Linux
OS:                Irix

Kmail crashes eash time I start it. Other users on the system aren't affected, only me. Moving kmailrc out of the way does not help. Currently I am running kde 3.4 packages for Debian downloaded from http://pkg-kde.alioth.debian.org/kde-3.4.0/ , but kmail also crashed with the packages from Debian Sarge (version 3.3.2). 

I don't exactly know which user-specific files might be important besides kmailrc (just let me know if there are any, I suppose it would make reproducing the crash easier). 

Here is a backtrace (version 3.4.0). There seem to quit a bit "no debugging symbols found" in it, if recompiling kdepim with debugging symbols would help, let me know. 

(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 1073884992 (LWP 3550)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#3  0x43eab389 in (anonymous namespace)::copy_from_stream<unsigned int> ()
   from /usr/lib/libkmailprivate.so
#4  0x43ea8d1b in KMMsgBase::getLongPart () from /usr/lib/libkmailprivate.so
#5  0x43e61481 in KMMsgInfo::status () from /usr/lib/libkmailprivate.so
#6  0x43ea4451 in KMMsgBase::isDeleted () from /usr/lib/libkmailprivate.so
#7  0x43f91751 in KMFolderIndex::readIndex () from /usr/lib/libkmailprivate.so
#8  0x43ec6ab3 in KMFolderMbox::open () from /usr/lib/libkmailprivate.so
#9  0x43e300c7 in KMFolder::open () from /usr/lib/libkmailprivate.so
#10 0x43efe315 in KMKernel::initFolders () from /usr/lib/libkmailprivate.so
#11 0x43efef5a in KMKernel::init () from /usr/lib/libkmailprivate.so
#12 0x0804a047 in ?? ()
#13 0xbffff710 in ?? ()
#14 0x00000000 in ?? ()
#15 0x00000000 in ?? ()
#16 0x00000000 in ?? ()
#17 0x00000005 in ?? ()
#18 0x00000020 in ?? ()
#19 0x00000000 in ?? ()
#20 0x4ddaac40 in __after_morecore_hook () from /lib/tls/libc.so.6
#21 0x440c97d0 in vtable for KMKernel () from /usr/lib/libkmailprivate.so
#22 0x4dc8d974 in __libc_start_main () from /lib/tls/libc.so.6
#23 0x4dc8d974 in __libc_start_main () from /lib/tls/libc.so.6
#24 0x08049e11 in ?? ()
Comment 1 Carsten Burghardt 2005-06-16 15:56:42 UTC
Looks like something got corrupted. The best would be to delete all
*.index.* files under ~/Mail. Or simply delete your accounts and start
from scratch. If you're using dimap also delete
~/.kde/share/apps/kmail/dimap and for imap  ~/.kde/share/apps/kmail/imap.
Do _not_ switch from 3.4 back to older versions.
Comment 2 Frank Van Damme 2005-06-17 14:51:51 UTC
indeed, removing those files stops the crashing. Would it be helpful to send someone (preferably not too many people ;) those index files?
Comment 3 Tim Wunder 2006-04-16 14:46:02 UTC
I just ran into a very similar crasher with kmail/kontact. Using kmail 1.9.2/kde 3.5.2 as packaged by kde-redhat.sf.net for fedora core 4. 
This is the backtrace I get:
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
`shared object read from target memory' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208568128 (LWP 21834)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0x07621f5f in KMMsgDict::readFolderIds () from /usr/lib/libkmailprivate.so
#7  0x0767397a in FolderStorage::readFolderIdsFile ()
   from /usr/lib/libkmailprivate.so
#8  0x076739cf in FolderStorage::registerWithMessageDict ()
   from /usr/lib/libkmailprivate.so
#9  0x076740a5 in KMFolder::KMFolder () from /usr/lib/libkmailprivate.so
#10 0x07675e03 in KMFolderDir::reload () from /usr/lib/libkmailprivate.so
#11 0x07675a36 in KMFolderDir::reload () from /usr/lib/libkmailprivate.so
#12 0x07675a36 in KMFolderDir::reload () from /usr/lib/libkmailprivate.so
#13 0x076763bd in KMFolderMgr::setBasePath () from /usr/lib/libkmailprivate.so
#14 0x07676655 in KMFolderMgr::KMFolderMgr () from /usr/lib/libkmailprivate.so
#15 0x0769fd94 in KMKernel::init () from /usr/lib/libkmailprivate.so
#16 0x0804a022 in ?? ()
#17 0x007efd7f in __libc_start_main () from /lib/libc.so.6
#18 0x08049e2d in ?? ()

There has to be a better way fr kmail to determine that an index file is corrupt. Crashing and then requiring a user to delete index files manually is non-trivial.
Comment 4 Ismail Onur Filiz 2006-05-05 10:14:25 UTC
Closing since removing the index files 'fixed' the problem.
Comment 5 Tim Wunder 2006-05-05 14:39:57 UTC
IMO, this shouldn't be closed. An e-mail app shouldn't crash because index files are corrupt/borken.
Comment 6 Ismail Onur Filiz 2006-05-06 08:32:42 UTC
KMail is planned to use a different indexing system in KDE 4, which is expected to solve most of such problems.

For the index files not causing crashes, without the problematic index files it is quite difficult to debug, hence I closed the bug. Please save your index file if another corruption occurs, and attach it to a bug report. Thanks for reporting.
Comment 7 Bram Schoenmakers 2007-01-28 17:30:00 UTC
*** Bug 140720 has been marked as a duplicate of this bug. ***