Bug 106287 - email list display defect
Summary: email list display defect
Status: RESOLVED DUPLICATE of bug 121272
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.5.4
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-05-25 18:48 UTC by m.michelbrink
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m.michelbrink 2005-05-25 18:48:58 UTC
Version:           1.5.4 (using KDE 3.1.4)
Installed from:    SuSE
Compiler:          gcc version 3.3.1 (SuSE Linux)
OS:                Linux (i686) release 2.4.21-99-default

My inbox folder shows several entries for one email. By clicking some entries change to "No subject" "unknown" "unknown". Some emails are missing. The fault occured already some time ago but disappeared after restarting linux.
Comment 1 Dik Takken 2005-05-26 20:26:57 UTC
Is this problem reproducable? If so, please describe exactly how to trigger it.
Comment 2 m.michelbrink 2005-05-27 13:06:52 UTC
No it is simply still there. In my Mail/inbox/cur folder are a lot of messages which are not asseccible from the application. After restarting KMail I deleted all multiple entries. These entries changed to "No subject" "unknown" "unknown" when I clicked on them. Something only some entries did before the restart. I restarted KMail afterwards several times but the display stayed in the same state (no double entries, but some messages are not displayed). New messages are displayed normally. The first time the problem occured I restarted linux and the display was alright afterwards. This time the problem remained.  
Comment 3 m.michelbrink 2005-06-21 13:43:46 UTC
I tried the following work-around: I copied one message which was not displayed in the applications inbox folder manually per copy and paste from the folder mail/inbox/cur into an existing folder. The message appeared in the application. I deleted the message manually, created an folder INBOX inside the application, selected all messages from mail/inbox/cur outside the application and pasted them into the folder mail/INBOX/cur. None of this messages was displayed in the application. I deleted all files again and copied a single file in the folder. This file appeared in the application. I did the same with all remaining files selecting 10-50 files in each step. Most times I had to do it twice (copy, paste, delete, copy, paste) before the files became visible in the application. Sometimes this was not necessary. I couldn't figure out any pattern. Strange behaviour, isn't it?
Comment 4 Thomas McGuire 2007-05-07 17:18:04 UTC

*** This bug has been marked as a duplicate of 121272 ***