Bug 10549 - KMail - Filter Rules progress indicator
Summary: KMail - Filter Rules progress indicator
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Unclassified
Component: filtering (show other bugs)
Version: unspecified
Platform: unspecified Other
: NOR wishlist with 86 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2000-09-14 07:33 UTC by Unknown
Modified: 2008-01-21 11:16 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vadim Plessky 2000-09-14 11:08:37 UTC
(*** This bug was imported into bugs.kde.org ***)

Package: KMail
Version: 1.1.94
Severity: Wishlist

There is no progress indicator for Filter Rules.
If you apply it on 1500 messages even my Pentium III/600 freezes for appx. 
10-15 seconds.
In that time user has no idea what's happening.
 
-- 
Vadim Plessky
Comment 1 elonen 2003-04-11 18:02:08 UTC
This is especially annoying when using SpamAssassin. A good solution could be to 
do filtering in a separate thread so that the user could read the mail that has already 
been filtered while Kmail is still processing the rest. 
Comment 2 mischa 2003-07-20 18:54:55 UTC
A simple solution would have the status bar refect the state purely as a line of
text, such as: "Now filtering incoming mail; please wait." I'd rather see an
active progress indicator akin to the downloading of mail, but a simple notify
would suffice, I think.

Mischa.
Comment 3 Timur 2004-03-10 08:14:10 UTC
I think that this issue also apply to incoming mail from different pop/imap account. When you configure a POP/IMAP account you also specify in which folder you want your mail to be moved in: well, if you have multiple mail accounts you actually don't know where the mail went.

In Eudora you have a nice feature that shows a filter report regarding where the downloaded mail went, something like:


Maildir1/In 3 messages

Maildir2/mailinglist 8 messages

Maildir3/Mum 1 Message

I think that having such a report after the mail download would be vry usefull (especially when you come back from a vacation and you didn't have mail access for a bit).

Regards,
Timur
Comment 4 Andreas Gungl 2006-10-28 17:21:24 UTC
An indication in the status bar is implemented in the newest version.
Comment 5 Hugo Costelha 2006-12-20 11:34:31 UTC
In which version was this applyed? I am using KDE 3.5.5, and I selected all the messages, proceeded with apply all filters, but no progress indication.
Comment 6 Andreas Gungl 2006-12-20 11:59:57 UTC
Am Mittwoch, 20. Dezember 2006 11:34 schrieb Hugo Costelha:
> In which version was this applyed? I am using KDE 3.5.5,
> and I selected all the messages, proceeded with apply all filters, but no
> progress indication.


Works fine here (SUSE 10.0 with RPMs for KDE 3.5.5).
Comment 7 Hugo Costelha 2006-12-20 13:01:40 UTC
On Wednesday 20 December 2006 10:59, Andreas Gungl wrote:
> Works fine here (SUSE 10.0 with RPMs for KDE 3.5.5).

Just to make sure we are talking about the same thing: you are not talking about the progress bar that shows up when fetching e-mails, right? You are talking about a progress bar that shows up when select a bunch of e-mails already received, and press "Apply All Filters"?

I get the progress bar when receiving e-mails, but not when I apply filters "manually" to the e-mails.
Comment 8 Andreas Gungl 2006-12-20 14:09:22 UTC
> > Works fine here (SUSE 10.0 with RPMs for KDE 3.5.5).
>
> Just to make sure we are talking about the same thing: you are not
> talking about the progress bar that shows up when fetching e-mails,
> right? You are talking about a progress bar that shows up when select a
> bunch of e-mails already received, and press "Apply All Filters"?


I'm talking about the status bar which states "Filtering message x of y".

> I get the progress bar when receiving e-mails, but not when I apply
> filters "manually" to the e-mails.


ACK. This one might be part of KDE 3.5.6.
Comment 9 Maciej Pilichowski 2008-01-16 18:40:23 UTC
Why this report has status FIXED while it is not fixed.

Apply filter has no progress indicator, so user does not know ETA and does not know how many files are remaining. Also the dialog (please don't put this in status bar) should be stopable.
 
Comment 10 Thomas McGuire 2008-01-19 18:56:35 UTC
>Why this report has status FIXED while it is not fixed. 
Well, it works for me. If i manually apply a filter to many messages, the progress is shown in the progress bar, just like Andreas said.
Comment 11 Maciej Pilichowski 2008-01-19 20:13:20 UTC
Thomas, by many you mean how many? 2000? 

The problem is that while applying filter there is no refresh, so if there are really many messages, the status bar is not visible. So it is not fixed.

Furthermore, for such lengthy operation it would be better to have dialog (not just tiny status bar progress) with cancel button. But I'd better open a separate wish for this one. 
Comment 12 Maciej Pilichowski 2008-01-19 20:17:50 UTC
The second part is here now:
https://bugs.kde.org/show_bug.cgi?id=156194
Comment 13 Thomas McGuire 2008-01-20 21:46:33 UTC
>The problem is that while applying filter there is no refresh
I tested it with a folder with ~200 messages, and the progress bar was refreshed. Maybe you experience the bug that some filters block the UI.
Comment 14 Maciej Pilichowski 2008-01-21 11:16:59 UTC
It maybe be the case -- I thought that applying filter should rather block user but on the other hand refresh the display.