Bug 105482 - Use hal's device name as mount target
Summary: Use hal's device name as mount target
Status: RESOLVED FIXED
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: media (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist with 122 votes (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-05-11 22:46 UTC by Samuel S. Weber
Modified: 2006-06-12 12:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
patch for using pmount-hal (833 bytes, patch)
2005-12-17 18:17 UTC, Vaclav Slavik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel S. Weber 2005-05-11 22:46:21 UTC
Version:            (using KDE KDE 3.4.0)
Installed from:    Gentoo Packages

Hello!

I would like to see the media ioslave use hal's desired device name instead of real device name.  My KDE setup right now mounts devices as their device in /dev, such as sda1 (hopefully my setup isnt messed) Even if i rename the device in media:/ it still gets mounted as sda1

To achieve:  Use pmount-hal instead of regular pmount

pmount-hal - Sends the volume.policy.desired_mount_point[1] of hal to pmount so instead of mounting an    
external firewire drive as sda1, it mounts it as ieee1394disk.  This is good(TM)  This would also mount an ipod as IPOD, instead of sd* whatever :)

[1]
To try pmount-hal:
1)Type in lshal in konsole
2)Find volume.policy.desired_mount_point = 'device_name'
3)Enter "pmount-hal volume.policy.desired_mount_point = 'device_name'"
4)There will device_name in /media. 

Martin Pitt (pmount's author) said that the gnome-device-manager already uses pmount-hal, and works fine.  I just like media:/ way better :)  

Thanks!

-Sam
Comment 1 Samuel S. Weber 2005-05-17 16:42:18 UTC
Actually, you enter the device name

Eg for ipod it would be 

pmount-hal '/org/freedesktop/Hal/devices/block_IPOD'
Comment 2 Rafael Ávila de Espíndola 2005-09-03 23:52:21 UTC
If using pmount-hal is undesirable, one can find the mount point that pmount-hal would use in the property "desired_mount_point". Is it possible to use hal_device_get_property_string in kdebase/kioslave/media/kdedmodule/halbackend.cpp?

Note that pmount-hal also sets things like the sync/async option. Because of this and to share the mount logic with gnome it would be nice if pmount-hal could be used after all.
Comment 3 Gilles Schintgen 2005-09-30 14:27:55 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 Gilles Schintgen 2005-09-30 14:27:55 UTC
*** This bug has been confirmed by popular vote. ***
Comment 5 Vaclav Slavik 2005-12-17 18:17:02 UTC
Created attachment 13961 [details]
patch for using pmount-hal

I'm attaching simple patch that I use on my system -- it makes KDE use
pmount-hal if available and fall back to pmount if not.
Comment 6 Anders Storsveen 2005-12-17 18:22:44 UTC
but still, would be great if I could set the mountpoint once and for all, or a name that is completely unique, so that I can symlink to it.
Comment 7 Harald Hvaal 2006-01-08 19:32:12 UTC
I support this one as well. I think it's weird having KDE using a HAL backend, and using the pmount-hal wrapper.
Comment 8 Kevin Ottens 2006-06-12 12:32:04 UTC
SVN commit 550578 by ervin:

Merge coolo's branch, it contains quite some fixes and interesting 
features. It'll be available in KDE 3.5.4, couldn't be committed before,
but thanks to the partial feature unfreeze...

FEATURE:
BUG: 50185
BUG: 105482
BUG: 108823
BUG: 114854
BUG: 120619
BUG: 121833
BUG: 127788
CCMAIL: coolo@kde.org


 M  +3 -2      Makefile.am  
 M  +7 -0      configure.in.in  
 M  +2 -2      kcmodule/managermodule.cpp  
 M  +4 -3      kcmodule/notifiermodule.cpp  
 M  +1 -1      kfile-plugin/kfile_media.desktop  
 M  +7 -2      kfile-plugin/kfilemediaplugin.cpp  
 M  +4 -0      libmediacommon/medium.cpp  
 M  +20 -1     libmediacommon/medium.h  
 M  +14 -1     mediaimpl.cpp  
 M  +643 -41   mediamanager/halbackend.cpp   [POSSIBLY UNSAFE: popen]
 M  +20 -0     mediamanager/halbackend.h  
 M  +72 -9     mediamanager/mediamanager.cpp  
 M  +8 -0      mediamanager/mediamanager.h  
 M  +6 -3      medianotifier/medianotifier.cpp  
 M  +1 -1      mounthelper/Makefile.am  
 M  +32 -19    mounthelper/kio_media_mounthelper.cpp  
 AM            propsdlgplugin (directory)   branches/work/coolos_media/propsdlgplugin#549689