Bug 105119 - Crash upon sending mail
Summary: Crash upon sending mail
Status: RESOLVED DUPLICATE of bug 108312
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.8.1
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 107771 117039 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-05-05 01:02 UTC by Tristan Miller
Modified: 2007-09-14 12:17 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tristan Miller 2005-05-05 01:02:23 UTC
Version:            (using KDE KDE 3.4.0)
Installed from:    SuSE RPMs

I started composing a new message.  While doing so, I had to refer to literally dozens of other messages, so I did a lot of navigating through folders, quicksearches, and even moving some messages between folders while the composer window was still open.  After about half an hour of this, I finished my message and hit the send button.  KMail promptly crashed with the following backtrace:

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 1864)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#4  0x401d519a in KMMessage::asDwString ()
   from /opt/kde3/lib/libkmailprivate.so
#5  0x401d5238 in KMMessage::asString () from /opt/kde3/lib/libkmailprivate.so
#6  0x4026a3cf in KMComposeWin::autoSaveMessage ()
   from /opt/kde3/lib/libkmailprivate.so
#7  0x402641fc in KMComposeWin::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#8  0x41dcb31b in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#9  0x41dcb0e4 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#10 0x42114109 in QTimer::timeout () from /usr/lib/qt3/lib/libqt-mt.so.3
#11 0x41dedbb3 in QTimer::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#12 0x41d693b6 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#13 0x41d686de in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0x418d4d7e in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#15 0x41d55a43 in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0x41d0dee7 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0x41d7c100 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#18 0x41d7bff6 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0x41d6964f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0x0804a38f in main ()
Comment 1 Tristan Miller 2005-05-13 07:04:34 UTC
Another crash today upon sending mail.  Not sure if this is the same bug or not.

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 17456)]
[New Thread 32769 (LWP 18253)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#4  0x401d519a in KMMessage::asDwString ()
   from /opt/kde3/lib/libkmailprivate.so
#5  0x401d5238 in KMMessage::asString () from /opt/kde3/lib/libkmailprivate.so
#6  0x4026a3cf in KMComposeWin::autoSaveMessage ()
   from /opt/kde3/lib/libkmailprivate.so
#7  0x402641fc in KMComposeWin::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#8  0x41dcb31b in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#9  0x41dcb0e4 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#10 0x42114109 in QTimer::timeout () from /usr/lib/qt3/lib/libqt-mt.so.3
#11 0x41dedbb3 in QTimer::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#12 0x41d693b6 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#13 0x41d686de in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0x418d4d7e in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#15 0x41d55a43 in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0x41d0dee7 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0x41d7c100 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#18 0x41d7bff6 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0x41d6964f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0x0804a38f in main ()
Comment 2 Tristan Miller 2005-06-10 17:22:03 UTC
Another crash today, this time with KMail 1.8.1.  Backtrace looks pretty much the same as the last two.
Comment 3 Malte S. Stretz 2005-06-20 10:43:27 UTC
*** Bug 107771 has been marked as a duplicate of this bug. ***
Comment 4 Malte S. Stretz 2005-06-20 10:44:59 UTC
From bug 107771:
 * This happened just after I entered my KWallet password.
 * Is it possible that this is a race condition between autoSaveMessage and the sending?
Comment 5 Pavel Kraus 2005-11-14 16:58:22 UTC
The same happens consistently to me with 1.8.2 in KDE 3.4.2, slackware, kernels 2.4.26 and 2.6.13. I try to send mail and kmail crashes with the mail staying in outbox. When trying to send it from outbox, kmail crashes again. Mail is sent by passing it to localhost:25.

(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1253058880 (LWP 15334)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#3  0xb7d6d055 in KMMsgBase::setTransferInProgress ()
   from /opt/kde/lib/libkmailprivate.so
#4  0xb7d38f31 in KMSender::doSendMsgAux ()
   from /opt/kde/lib/libkmailprivate.so
#5  0xb7d38d21 in KMSender::sendProcStarted ()
   from /opt/kde/lib/libkmailprivate.so
#6  0xb7d3cf70 in KMSender::qt_invoke () from /opt/kde/lib/libkmailprivate.so
#7  0xb62111ec in QObject::activate_signal ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#8  0xb6211820 in QObject::activate_signal_bool ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#9  0xb7d3d1eb in KMSendProc::started () from /opt/kde/lib/libkmailprivate.so
#10 0xb7d3a5f8 in KMSendProc::start () from /opt/kde/lib/libkmailprivate.so
#11 0xb7d37fa8 in KMSender::doSendMsg () from /opt/kde/lib/libkmailprivate.so
#12 0xb7d37417 in KMSender::sendQueued () from /opt/kde/lib/libkmailprivate.so
#13 0xb7e45577 in KMMainWidget::slotSendQueued ()
   from /opt/kde/lib/libkmailprivate.so
#14 0xb7e3c2ea in KMMainWidget::qt_invoke ()
   from /opt/kde/lib/libkmailprivate.so
#15 0xb62111ec in QObject::activate_signal ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#16 0xb6211014 in QObject::activate_signal ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#17 0xb6acd11b in KAction::activated () from /opt/kde/lib/libkdeui.so.4
#18 0xb6acc88a in KAction::slotActivated () from /opt/kde/lib/libkdeui.so.4
#19 0xb6acc9b9 in KAction::slotPopupActivated ()
   from /opt/kde/lib/libkdeui.so.4
#20 0xb6acd411 in KAction::qt_invoke () from /opt/kde/lib/libkdeui.so.4
#21 0xb62111ec in QObject::activate_signal ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#22 0xb65340fa in QSignal::signal () from /usr/lib/qt/lib/libqt-mt.so.3
#23 0xb622b3dd in QSignal::activate () from /usr/lib/qt/lib/libqt-mt.so.3
#24 0xb6318c49 in QPopupMenu::mouseReleaseEvent ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#25 0xb6ab8a71 in KPopupMenu::mouseReleaseEvent ()
   from /opt/kde/lib/libkdeui.so.4
#26 0xb62475f7 in QWidget::event () from /usr/lib/qt/lib/libqt-mt.so.3
#27 0xb61b495f in QApplication::internalNotify ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#28 0xb61b4054 in QApplication::notify () from /usr/lib/qt/lib/libqt-mt.so.3
#29 0xb67ec585 in KApplication::notify () from /opt/kde/lib/libkdecore.so.4
#30 0xb6149e81 in QETWidget::translateMouseEvent ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#31 0xb6147f1e in QApplication::x11ProcessEvent ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#32 0xb615ee54 in QEventLoop::processEvents ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#33 0xb61c6d18 in QEventLoop::enterLoop () from /usr/lib/qt/lib/libqt-mt.so.3
#34 0xb61b4c11 in QApplication::enter_loop ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#35 0xb631bab9 in QPopupMenu::exec () from /usr/lib/qt/lib/libqt-mt.so.3
#36 0xb7c98dfa in KMFolderTree::slotContextMenuRequested ()
   from /opt/kde/lib/libkmailprivate.so
#37 0xb7c9d792 in KMFolderTree::qt_invoke ()
   from /opt/kde/lib/libkmailprivate.so
#38 0xb62111ec in QObject::activate_signal ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#39 0xb6546f05 in QListView::contextMenuRequested ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#40 0xb62f6644 in QListView::contentsContextMenuEvent ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#41 0xb63278cf in QScrollView::viewportContextMenuEvent ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#42 0xb6326e00 in QScrollView::eventFilter ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#43 0xb62f50e8 in QListView::eventFilter () from /usr/lib/qt/lib/libqt-mt.so.3
#44 0xb7c9ba4f in KMFolderTree::eventFilter ()
   from /opt/kde/lib/libkmailprivate.so
#45 0xb620eb1e in QObject::activate_filters ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#46 0xb620ea4c in QObject::event () from /usr/lib/qt/lib/libqt-mt.so.3
#47 0xb624756f in QWidget::event () from /usr/lib/qt/lib/libqt-mt.so.3
#48 0xb61b495f in QApplication::internalNotify ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#49 0xb61b45c4 in QApplication::notify () from /usr/lib/qt/lib/libqt-mt.so.3
#50 0xb67ec585 in KApplication::notify () from /opt/kde/lib/libkdecore.so.4
#51 0xb614a276 in QETWidget::translateMouseEvent ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#52 0xb6147f1e in QApplication::x11ProcessEvent ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#53 0xb615ee54 in QEventLoop::processEvents ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#54 0xb61c6d18 in QEventLoop::enterLoop () from /usr/lib/qt/lib/libqt-mt.so.3
#55 0xb61c6bc8 in QEventLoop::exec () from /usr/lib/qt/lib/libqt-mt.so.3
#56 0xb61b4bb1 in QApplication::exec () from /usr/lib/qt/lib/libqt-mt.so.3
#57 0x0804a404 in ?? ()
#58 0xbffbf620 in ?? ()
#59 0xbffbf530 in ?? ()
#60 0x00000000 in ?? ()
#61 0x00000000 in ?? ()
#62 0xb6652cc0 in vtable for QGArray () from /usr/lib/qt/lib/libqt-mt.so.3
#63 0x081658a8 in ?? ()
#64 0x0000eaf9 in ?? ()
#65 0x0000eb10 in ?? ()
#66 0xb7f9dbf0 in vtable for KMKernel () from /opt/kde/lib/libkmailprivate.so
#67 0xb5a91fcb in __libc_start_main () from /lib/tls/libc.so.6
#68 0xb5a91fcb in __libc_start_main () from /lib/tls/libc.so.6
#69 0x0804a161 in ?? ()
Comment 6 Pavel Kraus 2005-11-15 19:27:38 UTC
Update. When I changed kmail settings to send outgoing mail through sendmail (postfix in my case), problem disappeared. 
Comment 7 Tommi Tervo 2005-11-25 11:07:58 UTC
*** Bug 117039 has been marked as a duplicate of this bug. ***
Comment 8 David Jarvie 2005-11-25 13:07:37 UTC
I have always had my outgoing mail delivered by sendmail (postfix), yet the crash happened to me (see bug 117039).
Comment 9 Tristan Miller 2005-11-25 14:01:00 UTC
Ditto -- my mail's always been delivered by a local postfix installation, and the crash still happens to me.
Comment 10 Andreas Kling 2006-07-31 14:29:21 UTC

*** This bug has been marked as a duplicate of 108312 ***