Bug 105051 - Kmail crash when trying to email an *.iso file
Summary: Kmail crash when trying to email an *.iso file
Status: RESOLVED DUPLICATE of bug 59069
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.8
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-05-03 22:34 UTC by flat fish
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description flat fish 2005-05-03 22:34:26 UTC
Version:           1.8 (using KDE KDE 3.4.0)
Installed from:    SuSE RPMs
Compiler:          Intel 2.6ht 
OS:                Linux

Send a message and attach an *.iso file (cdimage), kmail goes crazy, locks
up the machine (a P4 2.6ghz with 1g memory) and finally crashes.
This happens when using from kontact or just launching kmail by itself.
I launched from a cli and here is the output:

flatfish@linux:~> kmail
flatfish@linux:~> kmail: WARNING: KMMessagePart::setCharset(): trying to set a charset for a non-textual mimetype.
kmail: Fix this caller:
kmail: ====================================================================
kmail:
kmail: ====================================================================
kmail: WARNING: KMMessagePart::setCharset(): trying to set a charset for a non-textual mimetype.
kmail: Fix this caller:
kmail: ====================================================================
kmail:
kmail: ====================================================================
*** KMail got signal 6 (Crashing)
KCrash: Application 'kmail' crashing...


When I hit the attach button it recognizes the file as an ISO, the
progress bar goes to 100 percent, it shows the file at the bottom of the
screen and then the hard drive starts thrashing, the system gets real slow
and it finally crashes.

This happens on 3 different machines with Suse 9.3.

Any ideas?

flatfish+++
Comment 1 Thiago Macieira 2005-05-04 03:29:05 UTC
How big is this file you're trying to attach?

And can you paste the crash backtrace here, please?
Comment 2 flat fish 2005-05-13 20:14:47 UTC
There is no crash backtrace, the program just disappears.
I started it from a CLI hoping I would get more info and pasted the output above.
The file is a 650mb ISO.
flatfish
Comment 3 Thiago Macieira 2005-05-14 01:49:18 UTC
You're probably running out of memory. (Yes, even with 1GB of RAM)
Comment 4 Ismail Donmez 2005-06-12 22:36:41 UTC

*** This bug has been marked as a duplicate of 59069 ***