Bug 104888 - Would like MusicBrainz to be usable on more than one track at once
Summary: Would like MusicBrainz to be usable on more than one track at once
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 1.2.3
Platform: Debian testing Linux
: NOR wishlist with 443 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 131814 144311 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-05-01 04:27 UTC by Adeodato Simó
Modified: 2010-12-11 22:28 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.4


Attachments
Patch to allow musicbrainz queries on multiple files at a time (8.73 KB, patch)
2005-07-24 15:39 UTC, Robert Hogan
Details
multiple music brainz queries (8.47 KB, patch)
2005-07-25 22:44 UTC, Robert Hogan
Details
multiple music brainz queries (8.43 KB, patch)
2005-07-25 23:00 UTC, Robert Hogan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adeodato Simó 2005-05-01 04:27:42 UTC
This is Debian wishlist #293389 (http://bugs.debian.org/293389), by Daniel 
Frank <debian-bugs@cosmo-canyon.de>: 
 
---------------------------8<---------------------------------------------- 
MusicBrainz is very useful to sort an archive but currently you have 
to use this function for every file seperatly. It would be very useful 
to just select a bunch of files, then go to the menu and tell amarok to 
try getting the info for these files from MusicBrainz. 
---------------------------8<----------------------------------------------
Comment 1 Phil 2005-07-06 19:15:18 UTC
Exactly what I was going to submit! This would be very useful.
Comment 2 Robert Hogan 2005-07-24 15:39:29 UTC
Created attachment 11906 [details]
Patch to allow musicbrainz queries on multiple files at a time

This will run a musicbrainz query against all files selected. Unfortunately, it
is not against SVN but beta1 of 1.3. I will add an updated patch later in the
week. In the meantime, perhaps someone can tell me if this is the best way of
doing it or not.
Comment 3 Robert Hogan 2005-07-25 22:44:31 UTC
Created attachment 11925 [details]
multiple music brainz queries

this is a patch against current svn. it also fixes a problem the previous patch
had with filename encoding.
Comment 4 Robert Hogan 2005-07-25 23:00:00 UTC
Created attachment 11926 [details]
multiple music brainz queries

corrected version of patch.
Comment 5 Ben Morris 2005-09-24 18:48:45 UTC
I was just about to submit this too, I'm going through manually now. As far as I can see, this could be done in three ways: just choosing the most likely option for each track (i.e. completely automating it), having the current "MusicBrainz Results" windows open once for each track, and making some kind of new interface with all tracks in it (unlikely).

I think it should certainly allow the user to decide if it should be fully automated or ask.

What system is implemented in the patch?
Comment 6 mstearn 2005-10-17 11:50:50 UTC
I too was about to submit this. I think that juk has the best approach for this. In fact, that is the only reason I ever load up juk. Perhaps you could also show the current meta-data for the track in addition to the file name. I haven't looked too hard at the source code, but since they are both kde projects it might be very easy to just "borrow" the code, or even better, pull it out into a new KPart so both projects benefit from the enhancements.
Comment 7 Chris Hamons 2006-07-12 17:05:10 UTC
I'd vote for having the results window coming up for each track.
Comment 8 Andrew Chanler 2006-07-20 03:07:24 UTC
This is a feature I would enjoy very much.  The MusicBrainz Results window for each song would be good enough, but the way I imagine it is highlighting some tracks in my play list, right clicking and choosing "Find Tags with MusicBrainz" from the context menu.

Then a dialog would pop up with file names on the left and a drop done list on the right so that each track would have a drop down of the possible results from MusicBrainz.  And then a Save button at the button.  Also on each drop down would be an option that says "Make no changes" in case MusicBrainz returns a bogus answer.
Comment 9 Kevin Funk 2007-02-17 15:06:39 UTC
*** Bug 131814 has been marked as a duplicate of this bug. ***
Comment 10 Kevin Funk 2007-04-16 19:31:03 UTC
*** Bug 144311 has been marked as a duplicate of this bug. ***
Comment 11 Myriam Schweingruber 2008-11-14 11:27:15 UTC
MusicBrainz has been droped for a better solution to come later in Amarok 2
Comment 12 Roman Zimmermann 2009-03-23 08:45:41 UTC
What will this better solution be? Is there already a bug report for it?
I think this wish is still valid until this (or the better feature) is implemented or another report exists that covers this.
Comment 13 markuss 2009-04-04 14:35:23 UTC
I use a current Amarok 2.1 snapshot and there's no sign of any "better" solution. In fact there is no solution at all.
Comment 14 markuss 2010-12-11 15:32:06 UTC
So much for "WONTFIX": Amarok 2.4 with MusicBrainz support, incl. mass tagging. http://amarok.kde.org/en/releases/2.4/beta/1
Changing to "FIXED".