Bug 104689 - bad filename sorting alphanumeric characters with _ character
Summary: bad filename sorting alphanumeric characters with _ character
Status: RESOLVED DUPLICATE of bug 105057
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-28 10:18 UTC by Roman Fordinal
Modified: 2005-10-28 14:41 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Fordinal 2005-04-28 10:18:15 UTC
Version:            (using KDE KDE 3.3.2)
Installed from:    Gentoo Packages

i am currently using kde v. 3.3.2 and i have a problem with filename/folder sorting in kde apps. i got used to have folders beginning with underscore grouped at the beginning of the list/end of the list, depending on the alpha sorting set. seems like this behavior has changed at some point and now these folders are scattered among others, ignoring the underline and being sorted from the first alphanumeric character - f.e. "settings, _temp, tip, _trash" instead of "_temp, _trash,settings, temp" as before. is there a way to change this behavior?
i tried to find a way myself, but had no luck there. in console listing, everything looks ok - the old way.
any ideas?
Comment 1 Roman Fordinal 2005-07-08 09:03:06 UTC
same problem in KDE-3.4.1
Comment 2 Wolfgang Winkler 2005-08-24 20:07:04 UTC
Setting LC_ALL=C changes this behaviour in KDE-3.4.1 resulting: "_temp, _trash, settings, tip" but files starting with numbers are still sorted first: "5something, _temp, setting,..."
Comment 3 Roman Fordinal 2005-08-29 09:38:31 UTC
I have `LANG="sk_SK.utf8"` set for my national environment and the LC_COLLATE was set also for sk_SK.utf8 by default and it was wrong, but overriding it with manually setting LC_COLLATE="C" solves this problem.
Comment 4 Tommi Tervo 2005-10-28 14:41:56 UTC

*** This bug has been marked as a duplicate of 105057 ***