Bug 104335 - calendar recurrence function doesn't save
Summary: calendar recurrence function doesn't save
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: RedHat RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-21 19:05 UTC by Jorge Aquino
Modified: 2012-08-17 12:00 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jorge Aquino 2005-04-21 19:05:24 UTC
Version:            (using KDE KDE 3.4.0)
Installed from:    RedHat RPMs
OS:                Linux

whenever I try to program in a recurrence for a calendar item, with no set time (i.e. an all-day, not-busy entry/alarm) I can input the information, but when I go to save, the item disappears. Closing and reopening does not retrieve the item. I have tried this on multiple dates, and with differing alarm notification advance dates.
Comment 1 Reinhold Kainhofer 2005-06-21 13:43:21 UTC
Hello Jorge,
Can you please tell us which resource type you use (local file, a groupware server, a remote file, etc..)?

Cheers,
Reinhold
Comment 2 Jorge Aquino 2005-06-21 19:14:13 UTC
this was a calendar file on a local drive; i was not using the groupware 
function.


-ja

On Tuesday 21 June 2005 04:43, Reinhold Kainhofer wrote:
[bugs.kde.org quoted mail]
Comment 3 Reinhold Kainhofer 2005-07-24 19:30:05 UTC
Did you maybe select a filter that hides recurring entries in korganizer? See Settings->Filter->... (or the window title) for the currently active filter, and Settings->Edit Filter for the settings of that filter.

Cheers,
Reinhold
Comment 4 Reinhold Kainhofer 2006-11-02 18:49:19 UTC
Reassigning all KOrganizer bug reports and wishes to the newly created 
korganizer-devel mailing list.
Comment 5 Reinhold Kainhofer 2006-11-02 19:23:16 UTC
Reassigning the bug also changed the status from UNCONFIRMED to NEW. Undoing that manually :-(
Comment 6 FiNeX 2008-09-29 00:43:34 UTC
I've tried to reproduce the bug in korganizer 3.5.10 and 4, but the bug seems to be fixed :-)
Comment 7 Ralf Engels 2012-08-17 11:55:42 UTC
Git commit 6ed029b3aa49e9e9e7b7af0816db23b754173ef7 by Ralf Engels.
Committed on 17/08/2012 at 13:49.
Pushed by rengels into branch 'master'.

GPodder Improvements Patch Rev2

GPodder Improvements Patch Rev2

Use Solid::Networking::status() to prevent offline running of any
procedure that requests data from gpodder.net. Fixed some typos in
ChangeLog. Added some extra verifications, to see if suggested podcasts is
ready for use in GpodderServiceModel.

GPodder Improvements Patch Rev1

Put messages to show that gpodder service failed to get data from
gpodder.net. Done some cleanup and added some comments.

GPodder Service improvements

Full status synchronisation implemented. Cleanup and some refactoring.
GPodder Provider saves podcast subscriptions changes if the user closes
amarok before a expected synchronisation to end, so as to synchronize them
in the next start. Forcing GPodderService to verify if the username and
password is not empty before creating a mygpo::ApiRequest. Solved some
problems related to the KWallet use in GPodderService.

Courtesy: Lucas Gomes
FIXED-IN: 2.7

M  +1    -1    src/browsers/playlistbrowser/PlaylistsByProviderProxy.cpp
M  +7    -5    src/browsers/playlistbrowser/PodcastModel.cpp
M  +3    -0    src/browsers/playlistbrowser/PodcastModel.h
M  +4    -0    src/core-impl/podcasts/sql/SqlPodcastProvider.cpp
M  +21   -15   src/core-impl/podcasts/sql/SqlPodcastProvider.h
M  +5    -1    src/services/gpodder/GpodderPodcastRequestHandler.cpp
M  +1    -1    src/services/gpodder/GpodderPodcastRequestHandler.h
M  +366  -126  src/services/gpodder/GpodderProvider.cpp
M  +25   -7    src/services/gpodder/GpodderProvider.h
M  +50   -12   src/services/gpodder/GpodderService.cpp
M  +86   -40   src/services/gpodder/GpodderServiceConfig.cpp
M  +10   -3    src/services/gpodder/GpodderServiceConfig.h
M  +63   -31   src/services/gpodder/GpodderServiceModel.cpp
M  +2    -3    src/services/gpodder/GpodderServiceModel.h
M  +54   -32   src/services/gpodder/GpodderServiceSettings.cpp
M  +2    -2    src/services/gpodder/GpodderServiceSettings.h
M  +5    -4    src/services/gpodder/GpodderSortFilterProxyModel.cpp
M  +5    -1    src/services/gpodder/GpodderSortFilterProxyModel.h

http://commits.kde.org/amarok/6ed029b3aa49e9e9e7b7af0816db23b754173ef7