Bug 104327 - Simplified modes of the messages output should detect library creation
Summary: Simplified modes of the messages output should detect library creation
Status: RESOLVED NOT A BUG
Alias: None
Product: kdevelop
Classification: Unclassified
Component: Output Views (show other bugs)
Version: 3.1.2
Platform: unspecified Linux
: NOR wishlist with 30 votes (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-21 17:39 UTC by Michel Nolard
Modified: 2012-08-16 17:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 2.7


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Nolard 2005-04-21 17:40:02 UTC
Version:           3.1.2 (using KDE 3.3.2,  (3.1))
Compiler:          gcc version 3.3.5 (Debian 1:3.3.5-8)
OS:                Linux (i686) release 2.6.7-meg-0.6

The "simpplified" and "very simplified" modes of the "Messages" output should detect library creation at least when using simple patterns like
 rm -f xxx.a
 ar cru xxx.a yyy.o zzz.o ...
 ranlib xxx.a

I know that the way static libraries are built differs on the system, but I see that these modes can detect the linker step when using GBS, although not everybody uses it ;)

Thanks.
Comment 1 Jens Dagerbo 2007-01-07 21:36:26 UTC
The output parser is unable to recognize patterns spanning multiple lines. Implementing such recognition would mostly likely be quite slow and suck unnecessary resources at a time when they are needed for the build.

I think this is a wish, since it lies far outside what the output parser attempts to do.
Comment 2 Andreas Pakulat 2008-06-29 22:55:42 UTC
as Jens said this is not feasible to do for output as there might be a lot of output to be processed and this would slow down kdevelop quite a lot.
Comment 3 Ralf Engels 2012-08-16 12:43:12 UTC
Git commit 74ff722e94089ffc70ad284b0f2e9b5043a0636a by Ralf Engels.
Committed on 16/08/2012 at 14:33.
Pushed by rengels into branch 'master'.

Add composer button to wikipedia applet

Adds a new composer button for the Wikipedia applet.

Courtesy of: Ryan McCoskrie
Related: bug 272982
FIXED-IN: 2.7

M  +1    -0    ChangeLog
M  +13   -0    src/context/applets/wikipedia/WikipediaApplet.cpp
M  +1    -0    src/context/applets/wikipedia/WikipediaApplet.h
M  +3    -0    src/context/applets/wikipedia/WikipediaApplet_p.h
M  +44   -28   src/context/engines/wikipedia/WikipediaEngine.cpp

http://commits.kde.org/amarok/74ff722e94089ffc70ad284b0f2e9b5043a0636a
Comment 4 Milian Wolff 2012-08-16 17:58:49 UTC
Ralf: wrong bug!

But this one is outdated anyways, I'll close it as invalid.