Bug 103852 - "KFontDialog" shows wrong names for Font Styles "Medium"
Summary: "KFontDialog" shows wrong names for Font Styles "Medium"
Status: RESOLVED UPSTREAM
Alias: None
Product: kdelibs
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: VLO normal with 100 votes (vote)
Target Milestone: ---
Assignee: James Richard Tyrer
URL:
Keywords:
: 295266 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-04-14 03:33 UTC by James Richard Tyrer
Modified: 2012-03-04 01:25 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Hack for first two issues (758 bytes, patch)
2005-04-14 03:36 UTC, James Richard Tyrer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Richard Tyrer 2005-04-14 03:33:09 UTC
Version:            (using KDE KDE 3.4.0)
Installed from:    Compiled From Sources
Compiler:          GCC-3.4.3 
OS:                Linux

The KFontDialog shows all Oblique font faces as Italic.

Note that these are NOT the same.  Fonts that are only slanted compared to the Regular face are properly called Oblique.  Italic normally refers to a face that have more differences than just being slanted.

The KFontDialog shows all Normal font faces as Regular.

I don't see that it is an improvement to change the name of the font.  It can only confuse a user if KDE changes the name of the font face.

The KFontDialog shows font faces that are actually called Medium as something else (i.e. Regular).  I fully realize that the name of the standard face for many fonts has the style "" (that is nothing) and we need to have something other than a blank.  BUT, if the standard face actually has a name, I see no reason that it should be changed.  And, since some fonts are called Regular, it might be better to choose a different word such as: "Standard" (it might be preferable to use a word that is not used as the face name of any font if possible).

-- 
JRT
Comment 1 James Richard Tyrer 2005-04-14 03:36:16 UTC
Created attachment 10620 [details]
Hack for first two issues

This hack appears to fix the first two issues.	But, when I use it, the name of
the font face Medium is now changed to Normal.	I have not figured out where
that happens.

-- 
JRT
Comment 2 Thomas Zander 2005-04-14 13:11:12 UTC
For normal usage Oblique is the same as Italic.  I am fully aware of the differences, but users should not be.
In places where this difference is needed (painting/DTP applications) and users are expected to know the difference this could be done.

Currently; less is more.   And less technical terminology is always easier to understand.
Comment 3 James Richard Tyrer 2005-04-15 00:33:47 UTC
Re: Comment #2:

My theory on this has nothing to do with your comment.  The point is that the font dialog should show the actual font face name.  The fact that it shows something other than the actual font face name can not be a benefit for users.

I can't see how Oblique is any more technical than Italic.  If a user doesn't know what any of the face terms mean, they can simply click on it and they will have a sample.  

Since the first two points are not a bug but deliberate coding, this will have to be debated as a usability issue.

This doesn't address the third point which is now the only point since I found the source of the first two issues.

Since my patch fixes the first two issues, I am changing the Bug title to only the third one: 

> The KFontDialog shows font faces that are actually called Medium as something else (i.e. Regular).

And changing the priority back to NOR

I note that this is also the case for Times Roman (and other fonts whose normal face is called Roman) which seems to screw up a lot of things.

There is an additional issue when the installed fonts do NOT include a Standard face (or the standard face is not Medium).  For example: "ITC Bookman" (which is a common font) where I only have: Demi and Light installed.  Other weights exist, but they are not as common so it is normal to have only these two installed.  So, what happens? KDE changes the names of the Demi Weight.  How does this help the user?

GNOME does this correctly (although I think that it also misses some of my fonts) except for Times Roman (and possibly other Roman issues) so I see no reason that KDE should feel the need to change the font names.

We need to remember that this carries over to KOffice where it might be more common for users to want to use a wider selection of fonts.

And  finally.  I also notice that the File Info pop up in Konqueor gives different font names for the AFM and PFB files.  It doesn't change the AFM file but it does change the PFB file.  This can only confuse users.

-- 
JRT
Comment 4 James Richard Tyrer 2005-04-15 02:21:27 UTC
Addition to my Commemnt #3

> So, what happens? KDE changes the names of the Demi Weight.  How does this help the user? 

I forgot to explain to those that haven't read up on fonts that this is WRONG.

The face weight "Book" is slightly lighter than "Medium" so the normal weight for ITC Bookman, in my example, would be: Light and you would use Demi for Bold.  So, when KDE presumes that Demi is the normal weight, this is WRONG!  

If we are going to dumb this down for newbies, we need to get it right.  Light should be called Regular and Demi should be called Bold.  But, remember that Medium and Bold do exist and a user might install those as well.

http://www.myfonts.com/fonts/linotype/itc-bookman/

So, if that happens, then what do we do?

Note that contrary to some misinformation Book != Medium.  See above link.

To rant on: I don't seem to have a Type1 font with both Book and Medium installed, but I do have Futura that is TrueType with both Book and Light installed.  KDE calls them both "Regular"  

Note that there is a bug with TrueType that different weights are sometimes displayed as different families.  That is really a system issue, except that when it interacts with KDE renaming font faces to Regular, it becomes a serious problem.  So, if you install both Roundhand and Roundhand-Bold as TrueType, they are listed as two families rather than two styles and KDE has "Regular" as the style for both.

Also, if the only weight that you have installed is Book, KDE calls it Regular.

And, a small note on Oblique.  There are a few fonts that call this: "Slanted".  I have a Letter Gothic that uses it.  The old X system considers Oblique == Slanted.  IAC, clearly Slanted is not a technical term. :-)


Comment 5 Thomas Zander 2005-04-16 13:29:17 UTC
JRT: the bug reporter should not change priorities, its not your bug! You know this.  Please refrain from doing so.
Setting priority back.
Comment 6 James Richard Tyrer 2005-04-16 15:45:45 UTC
Re: Comment #5

I am the reporter so it *is* my bug.

The bug is not assigned to you, so I do not understand why you are summarily deciding that nothing will be done about this problem.  

KDE has serious problems with fonts that need to be fixed if possible.  I realize that if the problem is really Qt that there isn't anything that can be done. 

I might also note that bug reporters do not appreciate having their reports summarily dismissed.  In my case, if your intention is to see that nothing is done about the bug, then you can assign it to me -- especially in this case since I have already submitted a patch to fix part of it.  Please contact me by private e-mail if you wish to discuss this further.

-- 
JRT
Comment 7 Thiago Macieira 2005-04-16 17:14:20 UTC
I know coolo doesn't have a lot of free time on his hands, so I think he'll appreciate any help. And since you say it's your bug...
Comment 8 gmud 2006-10-11 22:17:27 UTC
These font issues are really annoying and should be fixed. There is a mixture of problems concerning fonts in kde and qt3 (I don't know much about qt4).
Comment 9 Christoph Feck 2011-07-27 14:14:19 UTC
Git commit 7fc5544684e9933e97a19198987945d97aa8e066 by Christoph Feck.
Committed on 27/07/2011 at 16:10.
Pushed by cfeck into branch 'master'.

Do not substitute Normal with Regular

The W3C document calls fonts without weight or slant "Normal",
see http://www.w3.org/TR/css3-fonts/
CCBUG: 103852

M  +3    -8    kdeui/fonts/kfontchooser.cpp

http://commits.kde.org/kdelibs/7fc5544684e9933e97a19198987945d97aa8e066
Comment 10 Christoph Feck 2011-07-27 14:16:07 UTC
That's an Qt problem. Qt actually returns "Normal" for all fonts that aren't bold or italic (including variants and combinations).

Please report to Qt developers at Nokia via https://bugreports.qt.nokia.com/secure/Dashboard.jspa
Comment 11 Christoph Feck 2012-03-04 01:25:56 UTC
*** Bug 295266 has been marked as a duplicate of this bug. ***