Bug 103540 - file dialog selection does not remember where it came from
Summary: file dialog selection does not remember where it came from
Status: RESOLVED FIXED
Alias: None
Product: kio
Classification: Unclassified
Component: kfile (show other bugs)
Version: 3.4
Platform: RedHat RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Carsten Pfeiffer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-09 09:33 UTC by disclosed
Modified: 2007-01-15 10:21 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description disclosed 2005-04-09 09:33:20 UTC
Version:           3.4 (using KDE KDE 3.4.0)
Installed from:    RedHat RPMs

in the konqueror File Manager when you move up (..) from a directory konqueror remembers which directory it came from and puts the cursor around that Directory name.

example ~/ contains 1000 dirs.
somewhere in the middle is the directory kde3.3_rpms.
if i enter this directory and then move up from it (..) from konqueror will put the cursor on kde3.4_rpms. this is extreamly conveniant.

however this is not working in the file open/save dialogs.
if i move up from a directory, it always scrolls to the top.

the Open/Save dialog should remember where it came from in the same way as the File Manager does.
Comment 1 disclosed 2006-09-27 21:00:32 UTC
still present in kde 3.5.4 on FC5.
Comment 2 Carsten Pfeiffer 2006-09-28 20:42:55 UTC
SVN commit 589847 by pfeiffer:

enable directory highlighting per request (i.e. when going up it highlights
the directory that was left)
BUG: 103540


 M  +1 -1      kdiroperator.cpp  
 M  +1 -1      kdiroperator.h  


--- branches/KDE/3.5/kdelibs/kio/kfile/kdiroperator.cpp #589846:589847
@@ -74,7 +74,7 @@
     KDirOperatorPrivate() {
         onlyDoubleClickSelectsFiles = false;
         progressDelayTimer = 0L;
-        dirHighlighting = false;
+        dirHighlighting = true;
         config = 0L;
         dropOptions = 0;
     }
--- branches/KDE/3.5/kdelibs/kio/kfile/kdiroperator.h #589846:589847
@@ -517,7 +517,7 @@
      * I.e. when you go from /home/gis/src to /home/gis, the item "src" will
      * be made the current item.
      *
-     * Default is off.
+     * Default is on.
      */
 	// ### KDE4: make virtual
     void setEnableDirHighlighting( bool enable );
Comment 3 disclosed 2006-11-02 22:31:05 UTC
reporting from kde 3.5.5 on FC6.
This bug is not compleatly fixed. it works in most directories, but if you are standing in your a directory to which you have a quick link, in the quick link pane, then the file dialog will remember where it came from but not mark that directory.

example
1. stand in ~ (supposte that ~ has a quick link)
2. open a subdorectory.
3. go back.
4. observe that the subir is not marked, instead the focus has moved to the icon of ~.

Comment 4 Carsten Pfeiffer 2006-11-03 11:12:53 UTC
Hmm, I cannot reproduce that -- works fine for me.  With what view configuration are you experiencing this?

IIRC, highlighting might fail if you're entering a symlinked directory. Could this be your case?
Comment 5 disclosed 2006-11-03 15:53:14 UTC
no, i do not have symlinks in the direcotries in question, will add some screenshots later.
Comment 6 David Faure 2007-01-15 10:21:13 UTC
SVN commit 623695 by dfaure:

Revert 589847, selecting the last directory when going up leads to bugs since its name is being used when pressing OK
(even if a filename was typed previously to navigating down and back up). The right fix would be to give the lineedit
precedence over the selected item but this look a bit more involved, I'll let Carsten do that :)
BUG: 136630
CCBUG: 103540
CCMAIL: Carsten Pfeiffer <pfeiffer@kde.org>


 M  +1 -1      kdiroperator.cpp  
 M  +2 -1      kdiroperator.h  


--- branches/KDE/3.5/kdelibs/kio/kfile/kdiroperator.cpp #623694:623695
@@ -74,7 +74,7 @@
     KDirOperatorPrivate() {
         onlyDoubleClickSelectsFiles = false;
         progressDelayTimer = 0L;
-        dirHighlighting = true;
+        dirHighlighting = false;
         config = 0L;
         dropOptions = 0;
     }
--- branches/KDE/3.5/kdelibs/kio/kfile/kdiroperator.h #623694:623695
@@ -517,7 +517,8 @@
      * I.e. when you go from /home/gis/src to /home/gis, the item "src" will
      * be made the current item.
      *
-     * Default is on.
+     * Default is off, because this behavior introduces bug #136630.
+     * Don't enable until this bug is fixed.
      */
 	// ### KDE4: make virtual
     void setEnableDirHighlighting( bool enable );