Bug 103446 - Crash when generating completion database
Summary: Crash when generating completion database
Status: RESOLVED DUPLICATE of bug 78978
Alias: None
Product: kdevelop
Classification: Applications
Component: Language Support: CPP (old) (show other bugs)
Version: 3.2.0
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-07 20:09 UTC by Anthony Graham
Modified: 2013-03-31 00:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
specific headers involved (78.18 KB, application/x-tgz)
2005-04-07 20:41 UTC, Anthony Graham
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anthony Graham 2005-04-07 20:09:50 UTC
Version:           3.2 (using KDE KDE 3.4.0)
Installed from:    Compiled From Sources
Compiler:          GCC 
OS:                Linux

Hi, I'm using the PCS database creator in the project settings -> c++ specific -> code completion.

I tried to get it to use the SDL header files in /usr/include/SDL

and it processed to 70% and was showing the showing sdl_name.h as it got stuck, within seconds the system's hard disk activity goes crazy, I'm assuming it's swapping because eventually kicker and kwm (or whatever manages the windows) teerminate through what I can only assume is lack of memory.

it's not actually stuck on sdl_name.h, it's sdl_opengl.h which is the problem as removing this file allowed the process to complete sucessfully.

I have about 3 seconds to kill kdevelop before it makes the system unusable. 

I'm running kde 3.4, kdevelop 3.2 on gentoo amd64.

I can supply the headers which are culprit in this problem if needed.
Comment 1 Anthony Graham 2005-04-07 20:41:34 UTC
Created attachment 10543 [details]
specific headers involved

these are the files involved,  SDL_opengl.h seems to be the main culprit
Comment 2 yosemitesam 2005-04-22 21:11:56 UTC
I have the same problem: creation stops at 70% while parsing SDL_net.h. After some time and frantic hard disc activity kdevelop terminates...
Comment 3 Jens Dagerbo 2006-05-01 22:31:24 UTC
Probable dupe.

*** This bug has been marked as a duplicate of 78978 ***
Comment 4 Aleix Pol 2013-03-31 00:54:13 UTC
Moving all the bugs from the CPP Parser. It was not well defined the difference between it and C++ Language Support and people kept reporting in both places indistinctively