Bug 103399 - different cursor shapes - block,underline,bar
Summary: different cursor shapes - block,underline,bar
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-07 04:07 UTC by Joseph Roback
Modified: 2015-04-28 23:48 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Roback 2005-04-07 04:07:02 UTC
Version:            (using KDE KDE 3.4.0)
Installed from:    Gentoo Packages

Just a simple wish.

Instead of just a block cursor, give some choices.

BLOCK     -> current cursor shape in konsole)
UNDERLINE -> _
BAR       -> |

Again just a little cute option for konsole. :)
Comment 1 Kazuo Teramoto 2006-09-30 23:58:03 UTC
*** This bug has been confirmed by popular vote. ***
Comment 2 Kazuo Teramoto 2006-10-01 00:01:45 UTC
I bar-like cursor shape i gonna be great. To all people using a text-editor like vim or emacs this is big feature.
If this can be done please make possible to change the shape using escape seqs (with it i can use a block shape in normal mode and a bar shape in insert mode, in vim)
Comment 3 Robert Knight 2006-10-01 04:56:07 UTC
Reference note:  The VT510 spec defines a DECSCUSR escape sequence to do this:  http://vt100.net/docs/vt510-rm/DECSCUSR .  It would need to be extended to allow for a bar-style cursor

> To all people using a text-editor like vim or emacs this is big feature. 

I use Vim quite a bit myself and regard this as a nice little touch rather than a big feature.  Be careful when making generalisations about large groups of users.
Comment 4 Ken Rice 2007-01-03 22:57:28 UTC
The ability to change the Pointer's shape to something other than the i-beam shape
would be a very welcome addition. It can be quite difficult to find where the mouse "is" in a session.  So many times we hear "where's the mouse, I can't see it" when introducing people to the superior Cut-and-paste's we can do in our environment. I apologize that I am now
going to invoke some words about xterm here, but with "Xterm*pointerShape:right_ptr" 
it is quite evident where the mouse is in a corresponding xterm, vim "session", etc. 
Changing the "color" will be of some help, and I can see where that can be of use,
but changing the pointer's shape will help me immensely as I change over individuals and companies while employing konsole and KDE. (thanks, sorry if I'm too windy here).
Comment 5 Robert Knight 2007-05-07 23:59:14 UTC
Implemented in KDE 4.
Comment 6 J. Becker 2007-07-04 21:23:23 UTC
Also, you can change the shape of the cursor when it is hovering OVER the konsole window fairly easily. Check out KDE-look.org for mouse cursor themes. (Change and install new ones by KDE Control Panel, Peripherals, Cursor Theme.) I'm using Grounation (highly recommended!) which changes the I-beam text cursor to a 3D vertical line with a shadow. If you prefer colors, Komix cursors are also brightly colored and highly visible. (If you are using the closed-source NVIDIA video drivers, the NVIDIA control panel and xorg.conf settings can turn on cursor shadows.)

These changes help make your cursor much more visible. Cursor themes are a feature of the underlying X architecture and you can use them in other WM's (with or without konsole).

So this suggestion doesn't solve the question of what shape the cursor should be when konsole has focus (personally, I prefer the box but I'd love to be able to make it bright red or something) but it does help when you've got a lot of windows on the screen. But thanks to Robert Knight and the KDE team, that wish has been granted in KDE 4. Hurray!
Comment 7 Robert Knight 2007-07-05 11:37:05 UTC
> (personally, I prefer the box but I'd love to be able to 
> make it bright red or something)

You can do that.  By default the cursor colour is set to match the character underneath it ( with the character underneath drawn in an inverted colour ), but you can also specify a custom cursor colour to use.
Comment 8 Kazuo Teramoto 2007-07-25 00:01:57 UTC
Hi,
I'm looking at the code of kde4 konsole (trying to "port" it to my konsole 3.5). One thing, in kde4 konsole don't look possible to change the shape inside a session (using a escape sequence) is this not possible, can this be implemented? 

Because for me, I like to vim to change the cursor shape to IBeam in Insert mode and back to block in normal mode, to do this vim send a escape sequence (defined in t_SI, t_EI) to term. Can konsole implement some escape sequence to change the cursor shape?

Sorry to ask for a change in something that is not yet released... :(

Thanks!
^_^
Comment 9 Robert Knight 2007-07-25 12:55:26 UTC
> kde4 konsole don't look possible to change the shape inside a session

You certainly can.  Start a new Konsole session and run:

konsoleprofile CursorShape=<Number>

Where <Number> is 0 (Block), 1 (IBeam) or 2 (Underline)

konsoleprofile is a simple shell script which just does this:

/bin/echo -e "\033]50;$1\a"

Where $1 is replaced with its argument.  

Comment 10 Shmerl 2015-04-21 21:53:18 UTC
Can Konsole support DECSCUSR sequences? It doesn't at present. For example this works in xterm:

printf '\e[5q'

But in Konsole it has no effect. Should I open a separate bug for this?
Comment 11 Shmerl 2015-04-21 21:54:24 UTC
Sorry, I missed the space. Example for xterm:

printf '\e[5 q'