Bug 103362 - kpdf shows complete filename including folder instead of just filename in taskbar
Summary: kpdf shows complete filename including folder instead of just filename in tas...
Status: RESOLVED FIXED
Alias: None
Product: kpdf
Classification: Applications
Component: general (show other bugs)
Version: 0.4
Platform: unspecified Linux
: NOR wishlist with 43 votes (vote)
Target Milestone: ---
Assignee: Albert Astals Cid
URL:
Keywords:
: 137093 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-04-06 16:42 UTC by Markus Waibel
Modified: 2008-01-04 18:03 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Waibel 2005-04-06 16:42:29 UTC
Version:           0.4 (using KDE 3.4.0, Debian Package 4:3.4.0-0pre2 (3.1))
Compiler:          gcc version 3.3.5 (Debian 1:3.3.5-8)
OS:                Linux (i686) release 2.6.8-1-386

Currently, kpdf shows complete filenames including foldernames in the taskbar (e.g. file:///home/wherever/whatever/thefile/is/only/here.pdf). This makes navigation between windows difficult if multiple files are opened. I suggest just showing the filenames (kate does it, e.g.).
Comment 1 Nicolas Dumoulin 2005-12-05 14:52:47 UTC
Or the title metada (if present) ?
Comment 2 Matt Rudary 2006-01-12 22:07:01 UTC
I agree with bobuse -- adding title metadata if present would be a good alternative to long filenames.
Comment 3 Matt Rudary 2006-01-12 22:07:39 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 Pino Toscano 2006-11-09 13:39:27 UTC
*** Bug 137093 has been marked as a duplicate of this bug. ***
Comment 5 Pino Toscano 2006-11-10 21:14:46 UTC
This was recently implemented in KPDF, so with KDE 3.5.6 you will have the file name only in the KPDF window title. Thanks İsmail 'cartman' Dönmez for the patch!
About the possibility to use the document title is available, it was already implemented time ago in okular, the KPDF successor for KDE 4.
Comment 6 Edgar Kalkowski 2007-07-12 12:38:49 UTC
I'm using KPDF 0.5.7 and indeed it only displays the filename as window title. But I've chosen the option to watch changes of the file and if KPDF automatically reloads the changed file the window title again displays the full path!
Comment 7 Pino Toscano 2007-07-12 13:12:41 UTC
SVN commit 686888 by pino:

Sets the filename as title also when reloading the document.

CCBUG: 103362


 M  +1 -0      part.cpp  


--- branches/KDE/3.5/kdegraphics/kpdf/part.cpp #686887:686888
@@ -623,6 +623,7 @@
     }
     if (m_wasPresentationOpen) slotShowPresentation();
     emit enablePrintAction(true);
+    emit setWindowCaption(url().filename());
   }
   else
   {