Bug 102946 - kmail deletes emails from Mail/inbox/
Summary: kmail deletes emails from Mail/inbox/
Status: RESOLVED DUPLICATE of bug 121272
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 102835 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-03-31 17:47 UTC by Lukas Kasprowicz
Modified: 2007-09-14 12:17 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Kasprowicz 2005-03-31 17:47:14 UTC
Version:            (using KDE KDE 3.4.0)
Installed from:    Gentoo Packages
Compiler:          gcc (GCC) 3.4.3-20050110 (Gentoo Linux 3.4.3.20050110, ssp-3.4.3.20050110-0, pie-8.7.7) CFLAGS="-march=pentium-m -O3 -pipe -fomit-frame-pointer -mmmx -msse -msse2 -mtune=pentium-m -funroll-loops"
OS:                Linux

Hi,

A few messages from inbox in kmail suddenly dissapeared. There are no filters moving the messages somewhere else.
After klicking on the messages they got the sender "Unknown" and the subject "No Subject" (don't know if its the same in the english i am using i18n (german)).
The message body was empty. Not all mails dissapeared.
After looking into the folder Mail/inbox/ i noticed, that the files for the mails, dissapeared, were gone. HDD is NOT full.
I have not deleted the mails myself!!!


regards Lukas
Comment 1 Gilles Schintgen 2005-04-02 00:21:35 UTC
Duplicate of bug 102835? Seems like there could be some data loss bug in kmail 1.8.
Comment 2 Eric Thibodeau 2005-04-13 21:04:13 UTC
I seem to be experiencing the same symptoms, though, in my case, I do have some filters, Spam-Assassin configured through KMail.

Symptoms are:
- e-mails vanish into trash folder and seem to be replaced by an empty shell. The source of this Unknown/No-Subject e-mail is as follows:

Status: RO
X-Status: UC
X-KMail-EncryptionState: N
X-KMail-SignatureState: N
X-KMail-MDN-Sent:  

- I say seem to be replaced since some of the e-mails that end up in the trash were actually part of a thread and that is where I found the Unknown/NoSubject e-mail stubs...

I will update as I collect more information. Needless to say, this is rather _scary_ for normal users and should be considered serious. I will provide more detailed information if required (running 3.4 split packages under Gentoo)
Comment 3 Eric Thibodeau 2005-04-13 21:20:28 UTC
My feeling is that the maildir (indexing system?) is getting corrupted. I say this because I just noticed that _some_ of my e-mails show up as quadrupled...and as I delete 3 of the 4 copies, the single e-mail is replaced by the blank mail as stated above.
The single e-mail left after deleting the 3 copies still displays the correct sender and subject until I click on the e-mail.
Inspection of the Trash folder shows that it indeed seems to contain 3 copies of the deleted e-mails (and it will also contain the Unknown/No-Subject e-mails I delete upon appearance).
Comment 4 Don Sanders 2005-05-05 10:19:29 UTC
If someone can work out a way to reproduce mail loss with KMail then 
please let us now. (Reproducing a bug is generally the first step in 
fixing it).
Comment 5 Gilles Schintgen 2005-05-12 10:49:44 UTC
On my system I sometimes get those dreaded empty messages. Just right now I've got one. The remaining content of the mail is as follows:
From: <internet@internet.lu>
Date: Thu, 12 May 2005 07:31:11 GMT
Subject: Serveur email
X-Virus-Status: No
X-Virus-Checker-Version: clamassassin 1.2.1 with ClamAV 0.83/875/Tue May 10 13:27:59 2005 signatures 31.875
X-UID:
X-Spam-Checker-Version: SpamAssassin 3.0.2-gr1 (2004-11-16) on homer.simpson
X-Spam-Level: *
X-Spam-Status: No, score=1.9 required=5.0 tests=ALL_TRUSTED,AWL,BAYES_40,
        MISSING_HEADERS,NO_REAL_NAME,SARE_MSGID_EMPTY,SARE_TOCC_NONE
        autolearn=no version=3.0.2-gr1
Status: R
X-Status: NC
X-KMail-EncryptionState:
X-KMail-SignatureState:
X-KMail-MDN-Sent:


The filtering (clamassassin, spamassassin) was done on my local machine. When accessing my mail account through the webmail interface the message is intact, but somehow it got mangled while downloading (or filtering?) with kmail.

Here's a snippet from my log file:
spamd[13029]: [info] setuid to gilles succeeded_
spamd[13029]: [processing message (unknown) for gilles] 1000._
spamd[13029]: [clean message (1.9/5.0) for gilles] 1000 in 0.2 seconds, 224 byte
s._
spamd[13029]: [result] .  1 - ALL_TRUSTED,AWL,BAYES_40,MISSING_HEADERS,NO_REAL_N
AME,SARE_MSGID_EMPTY,SARE_TOCC_NONE scantime=0.2,size=224,mid=(unknown),bayes=0.
396491974470332,autolearn=no_

The message size (224 bytes) seems to indicate that it was already corrupted when it was passed to spamassassin. Note however that clamassassin is run first, so I can't conclude that it's kmail's fault.

If the complete message would be helpful, just tell me and I'll attach it.
Comment 6 Volker Krause 2005-05-22 17:23:26 UTC
*** Bug 102835 has been marked as a duplicate of this bug. ***
Comment 7 Thiago Macieira 2005-05-22 18:37:57 UTC
*** Bug 102835 has been marked as a duplicate of this bug. ***
Comment 8 Thiago Macieira 2005-05-22 18:39:10 UTC
Don: bug #102835 has instructions (sort of)
Comment 9 Don Sanders 2005-06-09 09:08:35 UTC
Thiago: 102835 does have instructions? Unfortunately I couldn't parse any out of that report.
Comment 10 Lukas Kasprowicz 2005-06-09 10:18:27 UTC
After a bit of testing, i think the Mails dissapear, if following is done:

- Maildir -> Delete old Messages
  -> Move to folder xxx

Mails are moved to Folder xxx, but no mail arrives there. The mails which should be moved get Unknown/No Subject instead. this is in both folders. The original Message dissapears.
Comment 11 Thiago Macieira 2005-06-10 00:23:08 UTC
This is what I called (sort of) instructions:

 The folder is in ~/Mail/inbox, therfore I suspect its in maildir since I 
 killed all the MBOX whei I imprted the mail from Outlook via Mozilla on M2K 
 on another machine. 
 The system did not crash, it just converted the mail in unknown and carried on 
 as if nothing had happened. 
Comment 12 Don Sanders 2005-07-13 10:32:04 UTC
Sorry I'm unable to reproduce the bug using the instructions given. 
Perhaps executing the instructions doesn't always lead to the bug 
being reproduced.
Comment 13 Ryan Silva 2006-04-30 08:02:06 UTC
So have people just forgotten about this or is it just taking this long to fix?? As a software engineer myself, I find this unacceptable. I WAS just getting ready to switch to Kmail but I guess that's not happening because Kmail destroys my e-mail now. This isn't a small bug or a missing feature... this renders the software useless.

How it happened with me:
I have an inbox with several thousand messages. I was going through and deleting spam (multiple select of messages + delete key). After about 15 mins, when I click on a message it turns to "unknown". It does not go to the trash. It is also inconsistent--some messages don't get erased. But most do.
Comment 14 Eric Thibodeau 2006-05-01 13:43:40 UTC
Ryan,

Last time I experienced this issue I was performing something similar with spamassasin, which went crazy on me and caused dupes in my e-mails. When i started deleting these dupes, I started getting these "empty e-mails". This immediately pointed to an index corruption.

So, my recommendation is that yo delete or move (to be safe, I am no kmail dev) the index files of the folder with which you are experiencing the ghost e-mails. In my case, it fixed all dupes and the "empty e-mails".

I guess the dev's responsibility here is to find a way to get kmail to detect corrupted index files. And, if such a feature is prohibitively heavy for regular use, at least add it as a feature (index integrity check checkbox) or even a tool to detect-fix/delete invalid index files.
Comment 15 Thiago Macieira 2006-05-03 01:30:16 UTC
Ryan: as a software developer, you should know better than to label something as unacceptable. Some bugs are easier than others to fix; some are nearly impossible to reproduce under controlled circumstances and, therefore, very difficult to solve properly.

Not to mention, of course, priorities.
Comment 16 fediaevsky alexandre 2006-07-18 09:17:01 UTC
I had the same bug last year (on a Compaq Evo N110 with Mandrake 10.1 official). It started with deletion of mails from my Inbox (I had the feeling it attacked mostly emails from mailing list) and progressively all emails from all directories were concerned. I tried to backup the maildir but most messages were already destroyed. I reinstalled mandrake 10.1 official and I had no problem since now. The damn thing is coming back and I fear I will loose my mail archives in the same way. Do you know a better option to backup emails from kontact tha copying the maildir folder?  
Comment 17 Thomas McGuire 2007-05-07 17:18:13 UTC

*** This bug has been marked as a duplicate of 121272 ***