Bug 102788 - Current page number visible
Summary: Current page number visible
Status: RESOLVED INTENTIONAL
Alias: None
Product: kpdf
Classification: Applications
Component: general (show other bugs)
Version: 0.4.1
Platform: unspecified Linux
: NOR wishlist with 55 votes (vote)
Target Milestone: ---
Assignee: Albert Astals Cid
URL:
Keywords:
: 102919 127926 134413 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-03-29 20:35 UTC by Paul Smith
Modified: 2008-11-30 10:41 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Smith 2005-03-29 20:35:52 UTC
Version:           0.4.1 (using KDE 3.4.0, Mandrake Linux Cooker i586 - Cooker)
Compiler:          gcc version 3.4.1 (Mandrakelinux 10.1 3.4.1-4mdk)
OS:                Linux (i686) release 2.6.8.1-12mdk

In continuous mode, the current page number is not displayed. Therefore, to add this feature in new versions would improve the quality of kpdf, specially when one is dealing with long pdf documents.
Comment 1 Albert Astals Cid 2005-03-29 20:39:36 UTC
Page number is available at lower part of the sidebar.
Comment 2 Paul Smith 2005-03-29 21:04:02 UTC
One may choose not having the sidebar on (for gaining some extra space to view the document) and, then, there is no information regarding the current page number. 
Comment 3 Albert Astals Cid 2005-03-29 22:07:39 UTC
Where do you want the page number to be shown?
Comment 4 Paul Smith 2005-03-29 22:41:43 UTC
I do not have a special preference regarding the place where to put the page number; but maybe you could imitate Acrobat Reader and put at the top toolbar of kpdf what is at the bottom of Acrobat Reader to indicate the current page number. It would be nice to be able to edit the current page number in order to allow us to navigate the document more easily.
Comment 5 Albert Astals Cid 2005-03-30 10:02:32 UTC
You can already edit the page number in the sidebar. We'll see if that is the correct place or not for that functionality.
Comment 6 Sergio Pistone 2005-07-11 06:15:55 UTC
i agree with the poster. i think most people will hide the sidebar when actually reading.
the problem with placing it at the bottom is that you will be still wasting space. maybe the page number could be showed in an editable field in the toolbar (a combobox perhaps?) like the one for changing the zoom value. this way the user will have the choice to add it or remove it to his liking.
Comment 7 venson 2005-08-04 13:38:39 UTC
I agree with this. The page number ought to be made more visible.

It could be added to the toolbar, perhaps?
Comment 8 cyberquiet 2006-02-08 14:31:42 UTC
Voted for this bug. I think the toolbar is the right place for this thing. Probably the thing I like most of KPDF is its compactness. Even when embedded in Konqueror, It doesn't clutter the view as Acrobat does.
Comment 9 Maciej Pilichowski 2006-05-15 12:39:27 UTC
Toolbar. But not as just widget (?) but separated section so I could undock it and keep a floating window. Note -- that window shoud float within Kpdf window, not desktop.

And I hope we are talking about page number like this in navigation panel.
Comment 10 Maciej Pilichowski 2006-05-15 12:40:18 UTC
*** This bug has been confirmed by popular vote. ***
Comment 11 Albert Astals Cid 2006-05-25 19:39:53 UTC
*** Bug 127926 has been marked as a duplicate of this bug. ***
Comment 12 Oscar 2006-08-15 02:45:06 UTC
Perhaps a solution based on the one used in Evince (version 0.5.2) would be adequate? In this program, the current and total number of pages are displayed in the toolbar, with the current page being in an editable field.
Comment 13 Pino Toscano 2007-04-21 11:41:24 UTC
*** Bug 102919 has been marked as a duplicate of this bug. ***
Comment 14 Pino Toscano 2007-05-06 16:20:37 UTC
*** Bug 134413 has been marked as a duplicate of this bug. ***
Comment 15 Brad Hards 2008-11-30 01:18:43 UTC
I believe that this is fully implemented in Okular, and is not going to be implemented in KPDF.

Suggest it be closed as WONTFIX.
Comment 16 Maciej Pilichowski 2008-11-30 07:29:09 UTC
If anything, please close it as fixed then. It is really messy when issues get fixed and after a while they are closed as invalid or wontfix.
Comment 17 Brad Hards 2008-11-30 07:41:56 UTC
My rationale is that is its not fixed in kpdf (Okular is not kpdf), so it didn't seem appropriate to close it as FIXED.

What is the "really messy" concern?
Comment 18 Maciej Pilichowski 2008-11-30 08:27:54 UTC
But okular is "continuation" of kpdf, and the most important thing is not labels but if the issue is/was fixed or not. Messy -- it is really hard to track issues in bugzilla if they are incorrectly closed.
Comment 19 Brad Hards 2008-11-30 10:41:36 UTC
Discussed this with the Okular maintainer.

Okular is not a simple continuation of kpdf, so it is misleading to say a requirement is FIXED.