Bug 102678 - Replace function in KPart uses old replace selection, when replacing with nothing.
Summary: Replace function in KPart uses old replace selection, when replacing with not...
Status: RESOLVED DUPLICATE of bug 101895
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-28 15:51 UTC by Sean Parsons
Modified: 2005-03-28 15:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sean Parsons 2005-03-28 15:51:42 UTC
Version:            (using KDE KDE 3.4.0)
Installed from:    Unlisted Binary Package
Compiler:          gcc (GCC) 3.3.5 (Debian 1:3.3.5-8ubuntu2) 
OS:                Linux

If you were to open up a Kate window and copy in the following text:
Cat
Dog
Cat

Then replace "Cat" with "Cow" in the normal way and then replace "Dog" with "", which should leave you with:
Cow

Cow

It would infact leave you with:
Cow
Cow
Cow

This only occurs when:
1) Performing a replace for 2nd onwards time with that text file.
2) When attempting to replace with nothing.
Comment 1 Sean Parsons 2005-03-28 15:53:42 UTC
As the same KPart is in Quanta, this also affects HTML editing there as well.
Comment 2 Anders Lund 2005-03-28 15:56:54 UTC
Allready fixed.

*** This bug has been marked as a duplicate of 101895 ***