Bug 101908 - adding column in "resize playlist columns manually" mode does not work
Summary: adding column in "resize playlist columns manually" mode does not work
Status: RESOLVED FIXED
Alias: None
Product: juk
Classification: Applications
Component: general (show other bugs)
Version: 2.2
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Michael Pyne
URL:
Keywords:
: 115032 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-03-19 17:44 UTC by Dominik Karall
Modified: 2005-10-25 00:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominik Karall 2005-03-19 17:44:05 UTC
Version:           2.2 (using KDE KDE 3.4.0)
Installed from:    Gentoo Packages

1. set "resize playlist columns manually"
2. remove "track" or any other column shown up in your playlist by right click on the column headings
3. right click on the column headings again and select "track" again

the new added column has a width of maybe 0. so it is impossible to resize the column. the only way to get the column back resizeable, is to select "resize playlist columns automatically" which resizes the column and makes it possible to resize the column for users too.
Comment 1 Michael Pyne 2005-10-06 01:58:49 UTC
Confirmed in 3.4 and 3.5.
Comment 2 Michael Pyne 2005-10-06 02:23:23 UTC
SVN commit 467699 by mpyne:

Fix bug 101908 (adding column in manual column resize mode doesn't work) in KDE 3.5.

CCBUG:101908


 M  +5 -1      playlist.cpp  


--- branches/KDE/3.5/kdemultimedia/juk/playlist.cpp #467698:467699
@@ -1436,7 +1436,11 @@
     // Just set the width to one to mark the column as visible -- we'll update
     // the real size in the next call.
 
-    setColumnWidth(c, 1);
+    if(manualResize())
+	setColumnWidth(c, 35); // Make column at least slightly visible.
+    else
+	setColumnWidth(c, 1);
+
     header()->setResizeEnabled(true, c);
     header()->moveSection(c, c); // Approximate old position
 
Comment 3 Michael Pyne 2005-10-06 02:33:15 UTC
SVN commit 467701 by mpyne:

Backport fix for bug 101908 (adding columns when in manual resize mode doesn't work) to KDE
3.4.

BUG:101908


 M  +5 -1      playlist.cpp  


--- branches/KDE/3.4/kdemultimedia/juk/playlist.cpp #467700:467701
@@ -1333,7 +1333,11 @@
     // Just set the width to one to mark the column as visible -- we'll update
     // the real size in the next call.
 
-    setColumnWidth(c, 1);
+    if(manualResize())
+	setColumnWidth(c, 35); // Make column at least slightly visible.
+    else
+	setColumnWidth(c, 1);
+
     header()->setResizeEnabled(true, c);
     header()->moveSection(c, c); // Approximate old position
 
Comment 4 Michael Pyne 2005-10-25 00:33:57 UTC
*** Bug 115032 has been marked as a duplicate of this bug. ***