Bug 97531

Summary: KDevelop sometimes crashes on project switch
Product: kdevelop Reporter: Andreas Schallenberg <Andreas.Schallenberg>
Component: generalAssignee: kdevelop-bugs-null
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description Andreas Schallenberg 2005-01-20 15:45:15 UTC
Version:            (using KDE KDE 3.3.2)
Installed from:    SuSE RPMs
OS:                Linux

When I switch projects I sometimes get a crash.
Since the projects are large I can say that the
time is nearly the switch itself, after all (?) files
from the previous project have been closed.

I've two stack traces here:

#7  0x418bd3f9 in XTranslateCoordinates () from /usr/X11R6/lib/libX11.so.6
#8  0x4124640c in QWidget::mapFromGlobal () from /usr/lib/qt3/lib/libqt-mt.so.3
#9  0x41de5cfb in QXIMInputContext::setMicroFocus ()
   from /usr/lib/qt3/plugins/inputmethods/libqxim.so
#10 0x41d213a3 in QMultiInputContext::setMicroFocus ()
   from /usr/lib/qt3/plugins/inputmethods/libqimsw-multi.so
#11 0x41246e32 in QWidget::setMicroFocusHint ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#12 0x432f5853 in KateViewInternal::updateMicroFocusHint ()
   from /opt/kde3/lib/kde3/libkatepart.so
#13 0x00000000 in ?? ()
#14 0x0000000f in ?? ()
#15 0x00000000 in ?? ()
#16 0x0000000f in ?? ()
#17 0x00000001 in ?? ()
#18 0x00000000 in ?? ()
#19 0x4326878b in KateViewInternal::lineToY ()
   from /opt/kde3/lib/kde3/libkatepart.so

--------------------------------------------

Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 1102758496 (LWP 6491)]
[KCrash handler]
#7  0x4128fb8b in QFont::QFont () from /usr/lib/qt3/lib/libqt-mt.so.3
#8  0x41de5d2a in QXIMInputContext::setMicroFocus ()
   from /usr/lib/qt3/plugins/inputmethods/libqxim.so
#9  0x41d213a3 in QMultiInputContext::setMicroFocus ()
   from /usr/lib/qt3/plugins/inputmethods/libqimsw-multi.so
#10 0x41246e32 in QWidget::setMicroFocusHint ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#11 0x432f6853 in KateViewInternal::updateMicroFocusHint ()
   from /opt/kde3/lib/kde3/libkatepart.so
#12 0x00000000 in ?? ()
#13 0x00000000 in ?? ()
#14 0x00000000 in ?? ()
#15 0x0000000f in ?? ()
#16 0x00000001 in ?? ()
#17 0x00000000 in ?? ()
#18 0x4326978b in KateViewInternal::lineToY ()
   from /opt/kde3/lib/kde3/libkatepart.so

It looks like lineToY() is causing this...

Its funny that I previously had a similar experience
(bug #81434) but since this machine is freshly installed
and the old report was closed because the code doesnt
exist anymore the two bugs shouldn't be related.

Perhaps the project files are somewhat strange? They
are both custom makefile based. Anyway, the crash should
not occur.
Comment 1 Matt Rogers 2005-01-20 16:11:58 UTC
SUSE bug. A patch they use for XIM input stuff breaks. IIRC, the same bug happens with Fedora as well.


*** This bug has been marked as a duplicate of 89278 ***