Bug 81434 - KDevelop crashes on project switch (rare)
Summary: KDevelop crashes on project switch (rare)
Status: RESOLVED FIXED
Alias: None
Product: kdevelop
Classification: Unclassified
Component: general (show other bugs)
Version: 3.0.3
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KDevelop Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-12 16:22 UTC by Andreas Schallenberg
Modified: 2004-07-17 02:43 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schallenberg 2004-05-12 16:22:58 UTC
Version:           3.0.3 (using KDE 3.2.2, SuSE)
Compiler:          gcc version 3.3 20030226 (prerelease) (SuSE Linux)
OS:                Linux (i686) release 2.4.20-4GB

Switching between two projects (one being a library for
the other) may crash KDevelop. On several sessions
with some (10 to 20) switches I got two crashes, so
I cannot reproduce this rare bug "on-demand".

In both cases I compiled the library project and then
immediately switched to the other without any
further action. KDevelop starts to load the second
one but crashes before it finished.

I don't think it is related to Bug 69906, since I use
SuSE 8.2 on this machine and not Mandrake. A second
difference is Kdevelop not reaching close to 100%
of the task but crash early.

Stack backtrace:
(no debugging symbols found)...Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)...(no debugging symbols found)...
... 15 times skipped ...
(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 3587)]
[New Thread 32769 (LWP 3595)]
(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...0x41795d2a in waitpid () from /lib/libpthread.so.0
#0  0x41795d2a in waitpid () from /lib/libpthread.so.0
#1  0x40d5c369 in KCrash::defaultCrashHandler ()
   from /opt/kde3/lib/libkdecore.so.4
#2  0x41794895 in __pthread_sighandler () from /lib/libpthread.so.0
#3  <signal handler called>
#4  0x0994d692 in ?? ()
#5  0x41139a8c in QObject::inherits () from /usr/lib/qt3/lib/libqt-mt.so.3
#6  0x404ce1c3 in KMdiChildView::setInternalGeometry ()
   from /opt/kde3/lib/libkmdi.so.1
#7  0x080684d5 in MainWindow::slotRestoreAdditionalViewProperties ()
#8  0x0806900b in MainWindow::qt_invoke ()
#9  0x4113c5e1 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#10 0x0807d9bd in ProjectSession::sig_restoreAdditionalViewProperties ()
#11 0x0807ec11 in ProjectSession::recreateViews ()
#12 0x0807e7e5 in ProjectSession::recreateDocs ()
#13 0x0807e4d8 in ProjectSession::restoreFromFile ()
#14 0x08071d6d in ProjectManager::loadProject ()
#15 0x08074ea1 in ProjectManager::qt_invoke ()
#16 0x4113c5e1 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0x40aaf35a in KRecentFilesAction::urlSelected ()
   from /opt/kde3/lib/libkdeui.so.4
#18 0x40aa6ff0 in KRecentFilesAction::itemSelected ()
   from /opt/kde3/lib/libkdeui.so.4
#19 0x40aaf493 in KRecentFilesAction::qt_invoke ()
   from /opt/kde3/lib/libkdeui.so.4
#20 0x4113c5e1 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0x4113ca1b in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0x40aae9a1 in KSelectAction::activated () from /opt/kde3/lib/libkdeui.so.4
#23 0x40aa7525 in KRecentFilesAction::slotActivated ()
   from /opt/kde3/lib/libkdeui.so.4
#24 0x40aaf401 in KRecentFilesAction::qt_invoke ()
   from /opt/kde3/lib/libkdeui.so.4
#25 0x4113c5e1 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0x4148018a in QSignal::signal () from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0x41156db5 in QSignal::activate () from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0x4115e753 in QSingleShotTimer::event ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0x410de2af in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0x410dd560 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0x40cd67d4 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#32 0x410caee6 in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0x410843d8 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0x410f0763 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0x410f0656 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0x410de4cf in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#37 0x080623e4 in main ()

Since there are QT symbols shown:
rpm says "qt3-3.3.1-38" being installed.
Comment 1 Jens Dagerbo 2004-07-17 02:43:02 UTC
Whatever the cause, this backtrace goes through code that no longer exists. Assuming fixed.