Bug 79531

Summary: multiple desktop - multiple kicker / panel settings
Product: [Plasma] kicker Reporter: Mohd Asif Ali Rizwaan <maarizwan>
Component: generalAssignee: John Firebaugh <jfirebaugh>
Status: RESOLVED UNMAINTAINED    
Severity: wishlist CC: jonathan.hume, jonathan.schluessler
Priority: NOR    
Version: 1.1   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description Mohd Asif Ali Rizwaan 2004-04-13 05:22:07 UTC
Version:           1.1 (using KDE 3.2.1, compiled sources)
Compiler:          gcc version 3.2.3
OS:          Linux (i686) release 2.4.22

I use 4 virtual desktops. So it would be great if we can have 4 different kicker settings in each virtual desktop. Because kicker is relatively less spacious than the application buttons and applets which can be added over it. 

I can't use dictionay applet, it take much space. and system tray itself takes much space on kpanel.

I wish that:
1. I can have different applets in different virtual desktops
2. applets from one desktop must not be visible in other desktops

thanks.
Comment 1 Aron Fischer 2004-10-13 19:16:42 UTC
I agree. It should be possible to have completely different settings on each virtual desktop..
Comment 2 Aaron J. Seigo 2005-09-19 19:09:38 UTC
*** Bug 112887 has been marked as a duplicate of this bug. ***
Comment 3 Michael Kump 2007-03-08 15:16:46 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 Lubos Lunak 2008-01-18 14:21:07 UTC
SVN commit 763066 by lunakl:

Set different window role for each panel - this allows controlling them using kwin's
window-specific settings.
CCBUG: 79531



 M  +2 -2      container_extension.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=763066
Comment 5 Jonathan 2009-02-10 22:51:23 UTC
Is there a chance to get this implemented in KDE4?

Some of the desktop effects (Cube, Grid,...) would also benefit from this feature because at the moment the same panels are shown on every desktop even though some widgets (eg. task manager) hold different content for every desktop. (see Bug 158120)
Another advantage would be that when changing to another desktop the task manager of that desktop is shown immediately. At the moment it takes a small part of a second to refill the task manager.
Comment 6 A. Spehr 2009-05-23 04:37:11 UTC
Kicker is currently unmaintained, you can look to your distribution for help, however.
Comment 7 Jonathan 2009-05-26 18:37:45 UTC
The multiple panel aspect is still valid. So isnt it better to rename this bug to something like "multiple desktop - multiple panel settings" instead of marking this one as resolved???