Bug 63276

Summary: Konqueror doesn't remember size and position of its window between restarts
Product: konqueror Reporter: Vladimir Kondratyev <vova>
Component: generalAssignee: Konqueror Developers <konq-bugs>
Status: RESOLVED FIXED    
Severity: normal CC: faure, l.lunak, null
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: RedHat RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description Vladimir Kondratyev 2003-08-26 13:11:32 UTC
Version:           Konqueror 3.1.3-09x.2 Red Hat (Using KDE 3.1.3-0.9x.4 Red Hat) (using KDE KDE 3.1.3)
Installed from:    RedHat RPMs
Compiler:          gcc (GCC) 3.2.2 20030222 (Red Hat Linux 3.2.2-5) 
OS:          Linux

As it's already said in a short description, Konqueror doesn't remember size and position of it's window between restarts. It's very annoying bacause Konqueror on every sturtup opens small window at the top left corner of the screen.
Comment 1 Lubos Lunak 2003-08-26 13:53:33 UTC
You can save the window size when saving the various profiles in the Settings menu. 
 
Comment 2 Vladimir Kondratyev 2003-08-26 14:11:59 UTC
Yes, but I wish that Konqueror has the same window size as I leave it last time.
It's natural to expect such behaviour and not natural (IMHO) to go to some
profile and save it only to store size of the window. Many applications remember
size of its windows and this is very convenient.
Comment 3 George Staikos 2003-08-26 14:30:18 UTC
Subject: Re:  Konqueror doesn't remember size and position of its window between restarts

On Tuesday 26 August 2003 08:12, Vladimir Kondratyev wrote:
> ------- Yes, but I wish that Konqueror has the same window size as I leave
> it last time. It's natural to expect such behaviour and not natural (IMHO)
> to go to some profile and save it only to store size of the window. Many
> applications remember size of its windows and this is very convenient.

  And if javascript resizes the window on you?

Comment 4 Vladimir Kondratyev 2003-08-26 14:47:59 UTC
If javascript resizes window then it's OK. Last size should be remembered.

First of all if javascrip resized windows and I didn't chage its size and close
it then I agree that window size is OK, otherwise I'd change window size (it's a
kind of logic of most of people operate). The second point is how often
javascript resizes  main konqueror window? It seems that such supposition looks
like a theory which rarely happen in practice :)
Comment 5 George Staikos 2003-08-26 14:50:04 UTC
Subject: Re:  Konqueror doesn't remember size and position of its window between restarts

On Tuesday 26 August 2003 08:48, Vladimir Kondratyev wrote:
> ------- If javascript resizes window then it's OK. Last size should be
> remembered.
>
> First of all if javascrip resized windows and I didn't chage its size and
> close it then I agree that window size is OK, otherwise I'd change window
> size (it's a kind of logic of most of people operate). The second point is
> how often javascript resizes  main konqueror window? It seems that such
> supposition looks like a theory which rarely happen in practice :)

  You never go to warez/mp3/porn sites?

Comment 6 Vladimir Kondratyev 2003-08-26 15:08:18 UTC
Visiting porn site is not my main work and I was always thinking that Konqueror
is being developed not for for pornserfers only. Some  people use Konqueror for
file browsing, image previwing, etc, and warring about javascript is a bit
strange in this case.

Anyway (as I've already said) "if javascrip resized windows and I didn't chage
its size and
close it then I agree that window size is OK, otherwise I'd change window
size (it's a kind of logic of most of people operate)"
Comment 7 Davide Ferrari 2003-11-10 14:47:37 UTC
I agree with Vladimir!
And about JS, I think simply Konqui does not have to save position if the last window opened was a pop-up. In all other case, I expect as normal behaviour to save last window size (and position too) as lots of other KDE apps do. Without having to save a particular profile.
Comment 8 Vladimir Kondratyev 2003-11-10 16:43:30 UTC
To have some profilers for managing window sizes is a GUI blooper. It's very complex for ordinar user. Personally I do not use Konqueror any more. It's very annoying that simpliest things are very difficult to configure. I'm using Firebird now and happy with it.
Comment 9 Diederik van der Boor 2004-04-19 09:16:30 UTC
Isn't it possible to have a "Save window positions" in the konqueror settings menu? Currently I've hacked to file management preview to give my filemanagement profile the same windows size as the webbrowser profile.
Comment 10 mhn 2004-11-06 18:04:17 UTC
Really, every normal app I can think of (kde or not) restores its last size when you start it. I don't know if somebody already put this in the kde guidelines, but it's a de facto standard anyway.
Just think of this - how many people will ever discover that they can "save and load profiles"? Profiles should be for toolbars etc (and in that case they are useful), not for size and position. How many of the users who discover this will not get annoyed by it and drop konq altogether?
Comment 11 Simon Strandman 2005-05-06 15:17:03 UTC
I agree, nautilus in gnome and even explorer in windows can do this. Konqueror needs this feature.
Comment 12 Gregory Stark 2005-09-16 20:05:06 UTC
I have no problem with profiles, nice feature. But if I don't save a profile where is konqueror coming up with the default. It seems to be entirely random. Previously it always came up in a tiny window, now I've upgraded and it's opening every window in a huge window that covers my entire 21" monitor. You should at least pick a reasonable default and the size from the last user resize is as good a default as any. Certainly better than an arbitrary size picked with no user input.

Incidentally, I'm a C programmer and I use konqueror for web development. It never occurred to me once that "save profile" might help this situation. Instead I hacked my window manager to have a key to resize konqueror windows to a sane size. I just got used to hitting that key every time I opened a konqueror window. It annoyed me quite a bit; can you imagine how frustrating it would be for a newbie?
Comment 13 Gregory Stark 2005-09-17 02:14:10 UTC
And just to add insult to injury saving the profile doesn't actually work here. I resized a window to my normal 800x1024 and <<save view profile "Web Browsing">> (which brings up a surprise dialog box, the purpose of which is unclear given that the menu item claimed to be saving a specific profile.) I click Ok.

Then I close the window and start a new konqueror. And it pops up in a completely random size. 700x480 to be precise. What orifice did this get pulled from?!

Well at least it's better than what it was before, which was something like 1280x1000 which was just silly.
Comment 14 Michael Stather 2005-10-17 01:34:52 UTC
Konqueror does remember e.g. the "view hidden files" between starts, so I also think it´s completely UNLOGICAL why it doesn´t remember window sizes
IMHO the address of the profile should be saveable like it is "via menu", but the window size should always be saved in the appropriate profile.
Comment 15 Martin Koller 2006-12-30 18:12:37 UTC
*** Bug 27966 has been marked as a duplicate of this bug. ***
Comment 16 Martin Koller 2007-01-14 14:59:34 UTC
Fixed it now for 3.5.6 and KDE 4:

save and restore last known window size if the profile currently
used does not have the size in it.

The position is not stored, as I got the comment that the application
shall only take care about the size, but the position is a case for
the window manager. Other KDE apps seem also to only store the size.
Comment 17 Martin Koller 2007-01-14 14:59:59 UTC
*** Bug has been marked as fixed ***.
Comment 18 David Faure 2008-04-18 18:35:15 UTC
SVN commit 798599 by dfaure:

Rework the way window settings (size and menubar/toolbar visibility) is handled in konqueror;
the KMainWindow autosave mechanism is now used directly with the profiles; so when you resize
a webbrowsing window it is now automatically saved into the webbrowsing profile, etc.
GUI: For this reason the checkbox "save window size in profile" is gone from the profile dialog.

CCBUG: 63276


 M  +0 -1      konqactions.cpp  
 M  +14 -0     konqmain.cpp  
 M  +66 -58    konqmainwindow.cpp  
 M  +7 -6      konqmainwindow.h  
 M  +28 -8     konqmisc.cpp  
 M  +43 -38    konqmisc.h  
 M  +1 -3      konqprofiledlg.cpp  
 M  +0 -7      konqprofiledlg_base.ui  
 M  +0 -6      konqueror.kcfg  
 M  +2 -2      konqview.cpp  
 M  +96 -131   konqviewmanager.cpp  
 M  +12 -11    konqviewmanager.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=798599
Comment 19 Stefan Monov 2008-06-21 22:13:39 UTC
Hi David. About this:
applyWindowSizeFromProfile(profileGroup);

I don't see why you added it. We don't wanna touch the current window just because we're opening a new one.

Indeed, it introduces a bug (visible from r813647 onwards): JS calls to window.open() resize the calling window, which is totally not expected :-)
Testcase: <a onclick="window.open('','','')">Click me</a>

My solution is simply to remove that line; what do you say?
Comment 20 David Faure 2008-06-23 10:43:49 UTC
SVN commit 823384 by dfaure:

oops, resize the new mainwindow, not the calling one, thanks Stefan Monov for spotting.
CCBUG:63276


 M  +1 -1      konqmainwindow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=823384