Bug 52517

Summary: Month view very difficult to read
Product: korganizer Reporter: chris
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED FIXED    
Severity: wishlist CC: kde-bugs, tuju
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Mandrake RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description chris 2003-01-02 12:25:39 UTC
Version:           3.1 (using KDE 3.1.0 (RC5))
Installed from:    Mandrake Linux Cooker i586 - Cooker
Compiler:          gcc version 3.2 (Mandrake Linux 9.0 3.2-1mdk)
OS:          Linux (i686) release 2.4.19-16mdksmp

The month view for me is very difficult to extract info from without studying it hard. The main problem is the use of brackets () and dases - - to represent events spanning multiple days. This just looks unprofessional. Evey other view uses colourised blocks that can hold text, why can't this view ? Also months merge into one long list of white blocks, it's difficult to tell where one month ends and the next starts, could alternate months be made a different shade. i.e Jan white, Feb grey, march white .....etc. The best solution though would be to restrict the view to one month at a time showing only those days from the previous or the next months to fill the empty days on the first and last lines. Most other calendar programs I have used work this way and it sems to work.

Otherwise great program thanks.
Comment 1 chris 2003-02-12 13:09:39 UTC
Running 3.1 now and Kontact. Well the month view has improved a bit. The 
events are now colour coded, this helps lots. However it's still messy when it 
comes to events with no time associated that span multiple days. In the week 
view these type of events are shown perfectly (proper colour box). The main 
problem is when one multiple day event overlaps another, the overlaping 
segment gets pushed onto another line and so doesn't line up correctly with one 
of the two events. Different colours now make this easier to ditinguish but what if 
they are of the same event type ? The two events with the same colour merge 
into one requiring more time to figure out and possibly mistakes to be made. 
 
Also could there be an option to restrict the month view to one month at a time 
with a title as to which month it is and some buttons for moving forward and 
backwards through the months. Kind of the like the date picker at the side, only 
bigger !!! 
Comment 2 chris 2003-02-12 13:11:20 UTC
Where are my manners ? 
 
Thanks very much for listening. 
Comment 3 toddt 2003-03-01 16:32:02 UTC
Just a quick vote of agreement with Chris on the subject of the monthly view.  I 
would greatly prefer for the default behavior of the month view to be similar to a 
paper calendar, in that it should center on the month in question with the name of 
the month clearly listed and days outside of that month should be grayed out or 
otherwise color coded.  The current viewing format is probably useful to some 
people, but it is quite different from the monthly calendar views that I suspect 
most people are accustomed to seeing and I find it quite difficult to use. 
 
Thanks for listening, and great job so far!  I am now happily using kcalendar 
exclusively as the desktop half of my palm pilot calendar. 
Comment 4 Rudolf Lohner 2003-08-11 22:06:13 UTC
Some more suggestions to improve the monthly view: 
 
- If "Month view uses full window" is set it is virtually impossible to 
  navigate up and down by week, month or year. Previous versions had arrows 
  on the right side for this purpose - somehow they disappeared :-( 
  Why not adding single, double and triple up and down arrows for scrolling 
  by week, month and year? 
 
- If "Month view uses full window" is not set the small month window on the 
  left appears and -hey!- you can scroll up and down with the mouse wheel 
  and these movements are even transferred to the large view on the right. 
  But having a small and a large month view is kind of tautological... 
  Could the mouse wheel also work in the large view and also if "Month view 
  uses full window" is set? That would be great! 
 
- The wheel in the small month window works somewhat confusing: 
  If several days are highlighted the window scrolls up and down. 
  If one day is highlighted only, however, this highlighted day moves 
  horizontally, which isn't really useful: scrolling should be up/down also. 
 
- Finally a small bug, which occasionlly occurs, which I cannot reproduce 
  intentionally, however: In month view sometimes the horizontal spacing 
  of the days becomes pretty uneven - wide and narrow columns are generated 
  which never become uniformly spaced again unless you exit and restart 
  korganizer. I have observed this on many older versions too. 
 
Anyway - thanks a lot for your great software! 
 
Rudolf 
Comment 5 Sami J. Kallio 2003-12-01 12:05:42 UTC
I agree there are problems with month view as well as other view. To make the user interface better, one should look at Sari Laakso's User Interface Design Patterns:

http://www.cs.helsinki.fi/u/salaakso/patterns/Calendar-Strip.html
http://www.cs.helsinki.fi/u/salaakso/patterns/Overview-beside-Detail.html
Comment 6 chris 2004-05-20 19:03:25 UTC
Month view is still not what I want. All I need is for an event that is more than one day long to be represented by a coloured bar across all of the days it is associated with. This is how iCal (MacOS X), Evolution etc do it and it's clearer.

A restriction of one month per page in the month view is something I still really miss.
Comment 7 MG 2004-05-25 17:16:04 UTC
I'm using KDE 3.2.0/Korganizer and love it. It would be nice to have the following (in order of importance ;);)) in the Month view :

1) The *current day* should stand out more than the rest of the month, maybe a thicker/bolder border around it and/or with a different background color.

2) This has been mentioned above and I think it would really help to have this,
when scrolling/viewing across months, prior months and future months might be shown with a different background color (grey maybe?).

3) An option to set/unset background colors for weekends. Just to visually separate weekdays/workdays from weekends.

Also, how about a new feature a *Year* view similar to the output of "cal 2004" 
I have this view on my IPAQ calendar which I think is useful.
 
Keep up the good work guys!!!!

MG
Comment 8 Jakob Petsovits 2004-12-04 21:55:23 UTC
Also, the currently (as of 3.3.1) implemented Month View with different colors for different months shows one drawback:

The current month seems to always appear in darker blue while the following month appears in a lighter blue. However, when going down the view by one week (for example by mini-month-view mouse scrolling) and the newly selected week lies completely in the following month, then the following month becomes the current month.

The consequence of this behaviour is that the colors between months swap and therefore visually confuse the watcher. Just by scrolling down one week, the complete big month view changes completely and you have to find your way anew.

As both of the blue month colors make a good appearance, there only has to be a way not to swap them, and instead determining the color of a month by something like (color = monthnumber mod 2).
Comment 9 Ben Pearre 2004-12-13 20:10:04 UTC
IMO the most important buglet herein is that multi-day events should
line up with each-other across days!  Showing them as coloured bars
rather than 

(-- buy the KOrganizer developers a beer ----------------------)

would also be beautiful.

I like the feature by which the month displays _forward_ from the
current week (ie. the most recent Sunday) rather than displaying just
the current month even if we're near the end (as some comments plead),
but the number of weeks should be configurable: if there are too many
appointments in each day, they can only be displayed by making the
whole window bigger, rather than setting Month View to display, say, 4
rows (weeks) rather than 6.

The Current Day should stand out.

ps. you guys are doing an _amazing_ job!!  Thanks so much :)
Comment 10 Ben Pearre 2004-12-20 06:04:51 UTC
Oh, just one more comment, please :)

It would be wonderful if there were an option to tell the month view not to show the icons that indicate when an event has an alarm or repeats, etc.  With the alarm icon and the repeats icon and the time, I need an absurdly small font in order to see what the event actually is without hovering, etc.  And I don't really care to be told every month that the event repeats: I just care to be reminded that it's time to do it.

Thanks again!
Comment 11 Reinhold Kainhofer 2004-12-22 13:13:19 UTC
*** Bug 75572 has been marked as a duplicate of this bug. ***
Comment 12 Bram Schoenmakers 2005-03-17 15:09:08 UTC
CVS commit by bram: 

Addressing some issues in monthview:

o Make sure the first day of the selected month is on the first row. (#56546).
o Show month name and year above cells.
o Give selected cells a sunken effect.
o Select cell when selected from minicalendar.

o Cleanup in MonthViewCell: Merged cellClicked() and selection() to select().

CCBUG: 52517, 81689
BUG: 56546


  M +74 -40    komonthview.cpp   1.122
  M +5 -2      komonthview.h   1.61
Comment 13 Frank ATIKOSSI 2005-04-05 08:45:27 UTC
Scrolling in Calendar views to see previous/next days/weeks 

If it was possible to scroll up and down on the monthly calendar views to be able to see the next week or previous week,
not only the next/previous month..

This could help also to have a mark around the selected day (as for the current day in an another color).
Anyway, nice jobs done !
Comment 14 Ian Turner 2005-04-18 22:39:35 UTC
It appears to me there are two schools of thought on the selection of which weeks to display in the Month View. For convenience, I'll call them the "status quo" group and the "calendar" group.

The calendar group believes that the month view should display all the weeks from whatever month the selected day is in, that days from the month before and the month after should only be displayed if they share a week with the selected month, and that if they are displayed they should be grayed out or otherwise indicated as unimportant.

The status quo group believes that the month view should not be restricted to any particular month, but rather show a rolling forward calendar of some number of weeks -- namely, the status quo. The biggest change this group wants is the ability to scroll the month view up and down with a scrollbar, and the ability to configure the number of weeks shown.

By my eye, the advantage of the calendar group is ease-of-use; having the month view and the calendar widget on the left displaying the same dates is more intuitive and less confusing. On the other hand, I believe that at bottom the status quo is more useful -- at least once one has overcome any initial confusion. The status quo allows one to see forward some number of weeks without caring about the specifics of the Gregorian calendar, and without being distracted by past events.

This difference is probably irreconciliable, but both sides have enough of an argument that the best solution may be to make it an option; something like

 Month View Week Selection
   o  Month View displays whole month.
   o  Month View displays [---] weeks forward.

where [---] is a spinbox and o indicates a radio button.

Since the main advantage of the "calendar" group is ease-of-use, that behaviour should be the default if this question is to be made configurable.

Comments?
Comment 15 Reinhold Kainhofer 2006-11-02 19:33:06 UTC
Reassigning all KOrganizer bug reports and wishes to the newly created 
korganizer-devel mailing list.
Comment 16 Bruno Virlet 2008-06-19 15:04:01 UTC
Solved by the new month view.