Bug 484305

Summary: Calibre viewer window (re-opened) "without memory" in Plasma 6 Wayland
Product: [Plasma] plasma-wayland-protocols Reporter: Duns <web>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: normal CC: ad.liu.jin, aleixpol, web
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Neon   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:
Attachments: an example

Description Duns 2024-03-23 08:14:11 UTC
SUMMARY
***
This problem is only with plasma 6 wayland, in plasma 6 x11 it all correct.
When I close a calibre viewer window and modify its position and size, I cannot re-open it with the *last* position and size, but always with the same position and size. 
***


STEPS TO REPRODUCE
1. Open an epub file with calibre viewer (and TOC) and modify its position and size
2. Close the calibre viewer window.
3. If you re-open calibre viewer you have the original position and size, and not the last one

OBSERVED RESULT

Calibre viewer doesn't remember position and size of a closed window

EXPECTED RESULT

Calibre viewer should remember position and size of a closed window

SOFTWARE/OS VERSIONS
Operating System: KDE neon 6.0
KDE Plasma Version: 6.0.2
KDE Frameworks Version: 6.0.0
Qt Version: 6.6.2
Kernel Version: 6.5.0-26-generic (64-bit)
Graphics Platform: Wayland
Processors: 16 × AMD Ryzen 7 5700G with Radeon Graphics
Memory: 13,5 GiB of RAM
Graphics Processor: AMD Radeon Graphics

ADDITIONAL INFORMATION
Comment 1 Duns 2024-03-23 08:28:07 UTC
Created attachment 167638 [details]
an example

You can see what I mean: the TOC goes back always to its original position. Without memory, so to say.
Comment 2 Jin Liu 2024-03-23 09:40:13 UTC
For me, it remembers size, but not position. Calibre 7.7.0

So it's a duplicate of:
https://bugs.kde.org/show_bug.cgi?id=15329

If it doesn't remember size for you, it's more like a bug in Calibre.

*** This bug has been marked as a duplicate of bug 15329 ***