Bug 473426

Summary: Windows don't work properly after latest update on 2023-08-14
Product: [KDE Neon] neon Reporter: Valter Mura <valtermura>
Component: Packages Testing EditionAssignee: Neon Bugs <neon-bugs>
Status: RESOLVED FIXED    
Severity: normal CC: carlosdemaine, jr, linux4freedom, neon-bugs, neopytek, nicolas.fella, sitter
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Neon   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: screenshot of the desktop, showing the stucked top bar, the bottom bar without process manager working and Firefox without windows decorations

Description Valter Mura 2023-08-15 16:52:36 UTC
Created attachment 160990 [details]
screenshot of the desktop, showing the stucked top bar, the bottom bar without process manager working and Firefox without windows decorations

SUMMARY
***
After system login, the windows are stuck and the boundaries with the commands are not visible and not working (neither title bar, nor status bar).
Maybe it is a compositing issue.
***


STEPS TO REPRODUCE
1. Start the system
2. Open an application
3. Try to move/minimize/maximize or close it by mouse
4. It is impossible to work with the windows

OBSERVED RESULT
It is impossible to resize, move, minimize, maximize the windows.
Global menu is not working.
No commands available on top of the windows.
Command "Alt+TAB" not working to switch between windows (I can open them but cannot switch between them, I need to force closing in order to "focus" to another window below the focused one)
It seems to apply to all applications/windows

EXPECTED RESULT
It should work as expected.

SOFTWARE/OS VERSIONS
Operating System: KDE neon Testing Edition
KDE Plasma Version: 5.27.7
KDE Frameworks Version: 5.109.0
Qt Version: 5.15.10
Kernel Version: 6.2.0-26-generic (64-bit)
Graphics Platform: X11


ADDITIONAL INFORMATION
I have an additional bar, with the global menu for opened applications, which automatically should disappear if not hovering with the mouse (this was the normal behaviour): that  bar now is not working, it is now fixed and doesn't show at all the global menu for the relative opened application(s).
Comment 1 Nicolas Fella 2023-08-15 17:03:05 UTC
Is kwin_x11 running at all?
Comment 2 Valter Mura 2023-08-15 19:47:10 UTC
(In reply to Nicolas Fella from comment #1)
> Is kwin_x11 running at all?

Yes, it is supposed so. I always use X11 because with my Nvidia card Wayland doesn't work well.
Comment 3 Nicolas Fella 2023-08-15 19:48:15 UTC
I'm asking whether it is running *right now*. Because all your symptoms would be explained by it not running
Comment 4 Valter Mura 2023-08-15 20:19:14 UTC
(In reply to Nicolas Fella from comment #3)
> I'm asking whether it is running *right now*. Because all your symptoms
> would be explained by it not running

Well, I think so. Presently I'm answering from a X11 session, using Firefox. But still having the problems reported.
How could I check if kwin_x11 is running or not?
Comment 5 Nicolas Fella 2023-08-15 20:23:19 UTC
Does "pgrep kwin_x11" print any numbers?

Alternatively use System Monitor/top to look for a kwin_x11 process

Or try starting kwin_x11 from a terminal and see if something changes
Comment 6 Valter Mura 2023-08-15 20:28:53 UTC
(In reply to Nicolas Fella from comment #5)
> Does "pgrep kwin_x11" print any numbers?
> 
> Alternatively use System Monitor/top to look for a kwin_x11 process
> 
> Or try starting kwin_x11 from a terminal and see if something changes

It seems it doesn't:

valter@valter-desktop:~$ pgrep kwin_x11
valter@valter-desktop:~$ kwin_x11
kwin_x11: error while loading shared libraries: libKF5GlobalAccelPrivate.so.5: cannot open shared object file: No such file or directory

No kwin_x11 in the system monitor.
Comment 7 Nicolas Fella 2023-08-15 23:06:15 UTC
That explains everything :)

Looks like the latest Neon Update was faulty
Comment 8 Valter Mura 2023-08-17 07:02:06 UTC
(In reply to Nicolas Fella from comment #7)
> That explains everything :)
> 
> Looks like the latest Neon Update was faulty

And with latest update of today 2023-08-17 the things haven't changed and the issue is still present.
The desktop is almost unusable.
Comment 9 Valter Mura 2023-08-17 09:35:29 UTC
And now it is worst than ever: if I open Discover or Muon, the app returns to me:

*E: Field not valid in the preference file /etc/apt/preferences.d/99-jammy-overrides, "Package" header is missing*

Now the system is even more unusable.
Comment 10 Valter Mura 2023-08-17 10:07:23 UTC
(In reply to Valter Mura from comment #9)
> And now it is worst than ever: if I open Discover or Muon, the app returns
> to me:
> 
> *E: Field not valid in the preference file
> /etc/apt/preferences.d/99-jammy-overrides, "Package" header is missing*
> 
> Now the system is even more unusable.

How can I solve this big problem? I cannot update/upgrade and I cannot use windows.
Comment 11 Nicolas Fella 2023-08-17 22:00:25 UTC
*** Bug 473491 has been marked as a duplicate of this bug. ***
Comment 12 EBiForE 2023-08-17 23:04:43 UTC
(In reply to Nicolas Fella from comment #11)
> *** Bug 473491 has been marked as a duplicate of this bug. ***

Duplicate, Ok, Thanks, I'm sorry

You can upgrade your system by ctrl+alt+f3, but not at the moment, because the bug is still present
I have tried with xfce in kde neon as emergency DE and all works well
I hade tried to change themes, disable effects, but kwin crash anyway
Comment 13 Valter Mura 2023-08-19 08:22:12 UTC
I solved the issue for updating/upgrading, but the problem with windows and X11 still remains.
Comment 14 Valter Mura 2023-08-19 09:05:49 UTC
So, summarizing, in brief:

- Window titlebars and borders now missing. (And Ctrl-M doesn't seem to work.)

- Can't drag windows.

- Clicking on windows seems to change focus for the mouse but not the keyboard. (The keyboard focus will change, but I can't work out what does this.)

- Can only close windows if the application has a File Menu with the Quit option.

- Virtual Desktops have disappeared

- I can't minimise/maximise windows

- Panels have stopped autohiding (I have 2 panels set up, one autohiding with the global menu)

- Windows opened are stacked all in the same position, without possibility to move
Comment 15 Leyenda 2023-08-19 10:05:02 UTC
I have the same problem.
I solved the problem with jammy file on /etc/apt, wirtting Package where It was missing or addin priority 1100 if It wasn't.
But, Desktop on x11 is unusable and Wayland even doesnt boot.
Comment 16 Valter Mura 2023-08-19 10:37:01 UTC
After some searches, the issue is supposed (*only supposed*) to come from the packages "libkwinglutils14" and "libkwineffect14", that are responsible of:

"KWin (pronounced as one syllable "kwin") is the window manager for the KDE Plasma Desktop. It gives you complete control over your windows, making sure they're not in the way but aid you in your task. It paints the window decoration, the bar on top of every window with (configurable) buttons like close, maximize and minimize. It also handles placing of windows and switching between them."

I can see that there are available "libkwinglutils13" and "libkwineffect13" as dummy packages in the repositories, but I won't even try to install them next to 14 series.

HTH, will wait for some input from developers/packagers, thank you.
Comment 17 Carlos De Maine 2023-08-21 06:24:25 UTC
hi.  apologies for the breakage.  neon testing was utilising neon unstable's qt5 and kf5 packages.  however recent changes to some kf5 packages in relation to plasma6 have thus filtered down into neon stable and broken stuff.  to solve this problem testing has been diverted since last week to allow the deployment of native qt5 and kf5 packages in testing.  obviously this is a huge change to the tooling infrastructure and is now in being tested before the diversion is removed and the new packages are made available in the archive.
Comment 18 Carlos De Maine 2023-08-21 21:12:29 UTC
ok.  the divert has been removed and all new shiny packages are for neon testing/stable.  can you test by upgrading please?
Comment 19 Leyenda 2023-08-21 21:18:28 UTC
(In reply to Carlos De Maine from comment #18)
> ok.  the divert has been removed and all new shiny packages are for neon
> testing/stable.  can you test by upgrading please?

Upgraded, system is usable again for me 😌 thanks
Comment 20 EBiForE 2023-08-21 21:27:31 UTC
WARNING: You are trying to remove the following essential packages: qt5-phonon (due to plasma-desktop)
Comment 21 EBiForE 2023-08-21 21:27:55 UTC
(In reply to Carlos De Maine from comment #18)
> ok.  the divert has been removed and all new shiny packages are for neon
> testing/stable.  can you test by upgrading please?

WARNING: You are trying to remove the following essential packages: qt5-phonon (due to plasma-desktop)
Comment 22 Carlos De Maine 2023-08-23 06:29:01 UTC
(In reply to EBiForE from comment #21)
> (In reply to Carlos De Maine from comment #18)
> > ok.  the divert has been removed and all new shiny packages are for neon
> > testing/stable.  can you test by upgrading please?
> 
> WARNING: You are trying to remove the following essential packages:
> qt5-phonon (due to plasma-desktop)

you can safely delete that package, it was a mistake
Comment 23 Valter Mura 2023-08-27 20:12:31 UTC
Hi,

for me resolved, I think it can be closed.